An attempt was made to access a socket in a way forbidden by its access permissions


  • This is gettting rediculous.  My application was working quite well until I ran into the database problem I ask about in a previous post.  I tried to solve that problem by reformatting my hard disc and starting from scratch with a virgin copy of vb express. No joy.  I solved the problem by getting rid of the databases and putting the data in the code.

    Before all this happened, I was able to use "click once: to publish my application to the web.  The first time I tried to publish after the new copy of vb was installed I had trouble with signing the application, something I had not encountered before.  I added a test certificate to the the project and tried again.  Now I get the error message which is the title of this post.

    Since it is the compiler code that is trying to access the socket, I have no clue as to what is happening or how to fix it.  I can find lots of stuff on the web about this error message but it all has to do with ASP, nothing about "click once".

    I am the adminastrator of this machine.  I log on as the adminastrator and I work with it as the adminastrator, so I don't understand how I could have "permission" problems.

    Can anyone Help?


    Dick Roose

    Saturday, June 24, 2006 7:50 PM

All replies