none
.NET Framework 4.0 Generic trust failure (Win7 x64) RRS feed

  • Question

  • Hello, when I try to install .NET Framework 4.0 on windows 7(x64) I get generic trust failure. (see image)generic trust failure

    log file

    Any help would be greatly appreciated! I have had this problem for awhile now and it has been restricting my PC use. Thank you.

    EDIT: I tried the .net cleanup utility and got this log.

    EDIT2:

    Problem signature:
      Problem Event Name:    VSSetup
      Problem Signature 01:    Microsoft .NET Framework 4 Setup
      Problem Signature 02:    4.0.30319
      Problem Signature 03:    10.0.30319.1
      Problem Signature 04:    1
      Problem Signature 05:    SetupUtility.exe
      Problem Signature 06:    Download_D_Interactive_Error
      Problem Signature 07:    0x800b010b
      Problem Signature 08:    0
      Problem Signature 09:    unknown
      OS Version:    6.1.7601.2.1.0.256.1
      Locale ID:    1033


    Monday, April 16, 2012 1:37 AM

Answers

  • Hello,

    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/6a08414c-8b96-46bb-a162-8282efc3089a

    This thread was the answer to our problem after all. We had had an old (and now deleted) GP that had implemented a change to this registry key:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing]
    "State"=dword:000002c9
    


    This is the as you would go to your control panel --> internet options --> advanced TAB --> Security section and clicked the "Check for publisher's certificate revocation". I tryed it on both "ON" and "OFF" but that didn't help only after I deleted the reg key altogether before I installed "dotNetFx40_Full_x86_x64.exe" the installation didn't fail.

    User Configuration (Enabled) - GP Sample that we had used:

    The hotfix that the article talked about didn't help us because I think it's already implemented in SP1 (because after Installing our normal Image that is Windows 7 Enterprise x86 with SP1 and no other windows update it gives and error that the fix is already installed on this machine) but the error still remains. If you have to Install dotNET 4 on your SCCM task sequance or similar and get this error you can use this script (if your GP is making changes on this value). The GP will return the values after next restart.

    ::Sets the script path to this folder as long as the "install.bat" and "dotNetFx40_Full_x86_x64.exe" are in the same folder this script will run normal
    set cdpath=%~dp0
    ::Deletes ALL VALUES on current users "HKCU\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing" - if you are using SCCM on this installtion this account is the SYSTEM account
    REG DELETE "HKCU\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing" /va /f
    ::After this runs the .Net 4 Installation runs
    "%cdpath%dotNetFx40_Full_x86_x64.exe" /q /norestart
    

    So it looks like there are multiple reasons that can couse this kind of error and not all of them are connected to .NET 4 directly. DotNET4 Installation just checks so many certficates and authorites that the installation package shows other problems that might be on your enviroment. Thanks to all how have contributed information to fix our problem I hope this helps someone how has this error.

    After reading this post by "LomM", I proceeded  to do these steps:

    1. run regedit

    2. navigate to

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing]

    3. deleted the "State" entry

    4. run setup and it worked perfectly!

    Thanks for your post gimwealan, it lead to this solution. :)

    • Marked as answer by WookieVagina Monday, April 16, 2012 7:33 AM
    Monday, April 16, 2012 7:33 AM

All replies

  • Hello,

    Check out the thread below. It will help you.

    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/2107384c-e030-48d9-9e4d-02537bf3b755

    Monday, April 16, 2012 5:39 AM
  • It is apparent from the log files that some application (i suspect an anti-virus) on the machine is locking the MSI file as soon as it gets laid down on target machine for installation. That cause the signature verification failed. here is what log specified:

    =====================

    [4/19/2010, 12:8:51] Action: Downloading http://go.microsoft.com/fwlink/?LinkId=164177&clcid=0x409 using UrlMon ...

    [4/19/2010, 12:8:52] Action complete
    [4/19/2010, 12:8:52] C:\DOCUME~1\kapa\LOCALS~1\Temp\1\Microsoft .NET Framework 4 Setup_4.0.30319\TMP36.tmp: Verifying signature for netfx_Core_x86.msi...

    [4/19/2010, 12:8:52]Possible transient lock. WinVerifyTrust failed with error: 2148204800
    [4/19/2010, 12:8:52]Possible transient lock. WinVerifyTrust failed with error: 2148204800

     ====================

    I would recommend that you:

    1.     Download the full stand alone setup package from here: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

    2.     Open a command line and extract the package to a local folder using the command: dotNetFx40_Full_x86_x64.exe /x

    3.     To make sure that the netfx_Core_x86.msi is digitally signed, open the folder (in windows explorer) where you extracted the package, right click on netfx_Core_x86.msi file and select ‘Properties’. You should see a “Digital Signature” tab showing that the file has been signed by Microsoft Corporation.

    4.     Now wait for a while so that the Anti-virus scans all extracted files. Alternatively, you can force anti-virus to scan the folder where you extracted the package; so that it doesn't lock these files anymore. See you anti-virus help to find out how to do it.

    5.     Now, using elevated command prompt, go to the folder where you extracted the package and issue this command: Setup.exe /x86 /x64

    This should work. Please let me know if it solves the problem or not.

    Regards,
    Muhammad Ghaznawi

     

    I did everything it said to do but it still gets the same error. (My antivirus program is Panda Cloud Antivirus)

    EDIT:

    I also tried this.

    1. Click Start, click Run, type cmd, and then click OK.
    2. At the command prompt, type regsvr32 Softpub.dll /s, and then press ENTER.
    3. At the command prompt, type regsvr32 Wintrust.dll /s, and then press ENTER.
    4. At the command prompt, type regsvr32 Initpki.dll /s, and then press ENTER.
    5. At the command prompt, type regsvr32 Mssip32.dll /s, and then press ENTER.

    The problem is still here.

    EDIT 2:

    I was getting the same error on attempting to install either the .Net 4 client profile or the entire .Net Framework.  FYI, my machine is Windows 7 x64. 

    After a lot of Google searches and examination of log files, I came to suspect that it was the result of a problem with the certificates on my machine. Specifically, "Trusted Root Certification Authorities".

    Here was my fix: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=25249786-2B8E-4C51-8F4B-727CE25CC2C5

    I ran the program to update the certificates and was then able to install .Net 4.0.

    Hope this helps somebody.

    I tried this but the program I downloaded (rootsupd.exe) doesn't even open when I run it. ?

    Monday, April 16, 2012 7:03 AM
  • Hello,

    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/6a08414c-8b96-46bb-a162-8282efc3089a

    This thread was the answer to our problem after all. We had had an old (and now deleted) GP that had implemented a change to this registry key:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing]
    "State"=dword:000002c9
    


    This is the as you would go to your control panel --> internet options --> advanced TAB --> Security section and clicked the "Check for publisher's certificate revocation". I tryed it on both "ON" and "OFF" but that didn't help only after I deleted the reg key altogether before I installed "dotNetFx40_Full_x86_x64.exe" the installation didn't fail.

    User Configuration (Enabled) - GP Sample that we had used:

    The hotfix that the article talked about didn't help us because I think it's already implemented in SP1 (because after Installing our normal Image that is Windows 7 Enterprise x86 with SP1 and no other windows update it gives and error that the fix is already installed on this machine) but the error still remains. If you have to Install dotNET 4 on your SCCM task sequance or similar and get this error you can use this script (if your GP is making changes on this value). The GP will return the values after next restart.

    ::Sets the script path to this folder as long as the "install.bat" and "dotNetFx40_Full_x86_x64.exe" are in the same folder this script will run normal
    set cdpath=%~dp0
    ::Deletes ALL VALUES on current users "HKCU\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing" - if you are using SCCM on this installtion this account is the SYSTEM account
    REG DELETE "HKCU\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing" /va /f
    ::After this runs the .Net 4 Installation runs
    "%cdpath%dotNetFx40_Full_x86_x64.exe" /q /norestart
    

    So it looks like there are multiple reasons that can couse this kind of error and not all of them are connected to .NET 4 directly. DotNET4 Installation just checks so many certficates and authorites that the installation package shows other problems that might be on your enviroment. Thanks to all how have contributed information to fix our problem I hope this helps someone how has this error.

    After reading this post by "LomM", I proceeded  to do these steps:

    1. run regedit

    2. navigate to

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing]

    3. deleted the "State" entry

    4. run setup and it worked perfectly!

    Thanks for your post gimwealan, it lead to this solution. :)

    • Marked as answer by WookieVagina Monday, April 16, 2012 7:33 AM
    Monday, April 16, 2012 7:33 AM