locked
DreamSpark VS Professional 2013 new download says: license has expired RRS feed

  • Question

  • Help!

    I registered on Dream Spark, got verified, and downloaded the iso image for Visual Studio Professional.

    I burned it to a DVD, ran the install program and everything seemed to install smoothly on my Windows 7 PC.

    When I launch VS, however, I get a pop-up in the Start Page titled: "Product Information", saying... "License: Prerelease Software" and "This license has expired". Then, the only thing it allows me to do is click "Close", which shuts down the whole program.

    I do have a Product Key provided on the Dream Spark download page, but can't figure out how to enter it anywhere since it doesn't allow me to get to the Help menu. It does allow me to sign in to my Microsoft account, and I've done that, but it doesn't help in getting past the license issue. I have uninstalled, and reinstalled the whole package, and still have the same problem.

    I've been hunting around online for a solution. I've found others with the same problem but haven't found a solution that works for me.

    I posted the problem once before, and got a few suggestions... none of which worked:

    - check the validity of the iso (it was valid)

    - set my system date back / set my system date forward (neither worked)

    - uninstall the iso installation and try the web install (I did, and still have the same problem)

    Any other ideas would be much appreciated.

    Thanks in advance for any help!

    Thursday, December 26, 2013 3:03 AM

All replies

  • Hi,

    Have you installed the other VS version On your OS? and now the license of trial has expired.

    Have you remembered when you installed it?

    I suggest that you download the ISO file. Then set your system date back to the license of trial hasn't expired.

    Reinstall it. See if it will helps.

    Regards.

     

     


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, December 27, 2013 3:13 AM
  • Thanks for the suggestion... makes sense to me, but it didn't work.

    I had another version of VS 2010 installed in the summer, and uninstalled it shortly after that. I just tried setting the system clock to dates of that installation to see if it would work, but it did not.

    I changed the system clock to a number of dates, trying dates every few days apart, but did not find any dates that made this installation work.

    I've been wrestling with this problem now for over a month.  It SHOULD work, and at this point I'm looking for a solution on a matter of principle... but would like to use it as well.

    Any other suggestions?  I'm assuming wiping and doing a fresh install of Windows 7 would fix the problem, but I would REALLY like to avoid that if at all possible.

    Any other ideas would be appreciated.

    Saturday, December 28, 2013 7:56 PM
  • Hi,

    Your issue seems very strange to me. I am involving other experts to look at it for you, may they can help you.

    Regards.



    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, December 31, 2013 7:19 AM
  • Hi,

    Per my expirence, this issue is sometimes caused by corrupt Lisense registry key on your computer. Assume this is the case, to find out which is registry key, one way is running Process Monitor and reproduce the issue. , you can verify this by searching the "Licenses" or "License" keywords from the output, to check whether VS process is reading them. If you find such key, you can backup the registry key first and then delete it, after that, perform a re-installation (repair or clean install).

    Steps to run Process Monitor:

    1. Download Process Monitor from http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
    2. Start Process Monitor -> Stop Process Monitor by "Ctrl+E"-> Clear the history by "Ctrl+X”
    3. Just before you are ready to launch Visual Studio, start the Process Monitor by "Ctrl+E".
    4. When the issue is reproduced, for example, the error message regarding Lisense is pop up.
    5. Stop the Process Monitor by "Ctrl +E" immediately
    6. Save the output to a .PML file. Or you can directly view the output from the Process Monitor window. 

    Tuesday, December 31, 2013 8:21 AM
  • Thanks for the suggestion... the solution makes sense to me, and may be on the right track.  As I went through this, I ran into some problems and things are still not solved.

    - I ran Process Monitor, and found around a dozen error messages related to the Licenses.  They all say "file not found" or "Access Denied"

    - In each line, it states a license key that's different than the one I was given by DreamSpark

    - I deleted the registry key... at least I think I did... when I tried to delete it I got an error message in RegEdit that said "Cannot Delete" "Error while deleting key" . However, when I searched to find that key again, it was not there.

    - I closed RegEdit, and ran the Repair option for VS. Around 3/4 through it stops and gives me an error message saying "Fatal Error" "Restart Required".

    - The VS install log says Access Denied to License Key.

    - I restarted the PC, start VS, and still have the same "License has expired" message.

    I'm still looking for a solution. Any suggestions?

    Thanks in advance for your help!

    Thursday, January 2, 2014 12:33 PM
  • hi,

    Please restore all the registry key you have deleted to roll back the change.

    I did a test in a good environment, after I opened VS 2013 and checked the process monitor, I found devenv.exe ( the process name of VS 2013) mainly accessed the following resitry keys:

    HKCR\Licenses\E79B3F9C-6543-4897-BBA5-5BFB0A02BB5C\0bcad

    HKCR\Licenses\E79B3F9C-6543-4897-BBA5-5BFB0A02BB5C\06181

    The key name maybe different as my version is ultimate but yours is Professional. But I believe they should have similar formate:

    HKCR\Licenses\xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx\0bcad

    HKCR\Licenses\xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx\five digits number

    after I delete either one of them, i can reproduce the issue and got the following screenshot:

    When I close the dialogbox, VS just existed.

    Based on above test, firstly you can check whether above resgistry keys exist, if yes, they should be corrupt. You can tried to delete them, repair VS 2013 to check whether they can be added. If you got error message and unable to repair, you can try to un-install VS and perform a clean installation again. Please make sure those registry keys are missing after uninstall. When re-install back, please check they are added back.

    Hope this can help you, if it doesn't work, the issue maybe a little complex, the worst solution is to re-install OS, this away works.

     Or You may require more in-depth level of support. Please visit the below link to see the various paid support options that are available to better meet your needs.

    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Friday, January 3, 2014 8:58 AM
  • Thanks. I think we're on the right track, but not there yet.

    You did reproduce the issue exactly. Your screenshot is exactly what I get.

    The License Key you show, is the same one I find in my registry. I tried deleting it, and it doesn't let me. I get an error message, and it says access denied.

    I uninstalled VS, searched the registry again, and found that the key was still there. I tried deleting it again, and still got the error message. I changed the permissions to Full Control, and tried deleting it, and it still got the error message.

    However, I then shut down and restarted the PC, checked the registry, and found that the license key was gone. So I then did a fresh install of VS, but got the same result, and the same license key is back in there.

    I thought it would work, because I suspected that the previous times I uninstalled and then reinstalled VS it left that license key behind so always created the same problem. However, now it looks like the install is putting that corrupted license key in itself.

    Along with the DreamSpark VS download, there is a separate file that gives you a license key... and it's different than the one that seems to be inserted with the installation routine. 

    What am I supposed to do with that key if I can't get past this point?

    I think we are on the right path here, but can't seem to solve this issue. How did you reproduce the problem, and were you able to correct it?

    Thanks again in advance for your help on this.

    Monday, January 6, 2014 4:38 AM
  • Hi,

    For my repro, I just simply delete the lisence key to reproduce, then restoring the same key make it work again. I am not sure if any other registry key beside this one causing the error on your environment. At least I found the above two in my test. 

    If  the lisense key itself you got has problem, forgive me that I could't do much for you here.

    If possible, you can try to install it on another machine to verify the lisense key, if it works in another machine, you can consider to re-install the OS and install VS again. This is the worst solution but should work and time saving.

    If you require more in-depth level of support. Please visit the below link to see the various paid support options that are available to better meet your needs.

    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone



    Tuesday, January 7, 2014 8:14 AM
  • hello i am having the same issue - paid licenses and all of a sudden today am getting this problem. Please help this is affecting our business.
    Tuesday, January 7, 2014 4:19 PM
  • I have been using the Dreamspark version for some time now, and out of the blue came this message for me too, that my license is about to expire, but I hacve no knowledge that it should be expiring any time soon.
    Tuesday, May 6, 2014 2:15 PM
  • Although Dreamspark does not let me check the product key when I download VS (the Get Key button goes grey), if I log in and check the My Account section, it does show a product key. I copied it in and clicked the Enter License in the VS dialog window. License update went fine and now it's not complaining anymore.

    I do not recall having to do this the last time I installed VS, but I think you could give it a try too.

    • Proposed as answer by Meteorhead Wednesday, May 7, 2014 1:50 PM
    Wednesday, May 7, 2014 1:50 PM
  • Hi daurschel ,

    Do you fix it now?

    Tuesday, June 24, 2014 11:30 AM
  • Hello,

    I have recently also encountered exactly the same problem. When I searched for a solution, I saw this, which did not solve my problem. Below is what I have done, which might be of some help to you, though I do not even guarantee that it worked for me.

    After uninstalling current installation, clear your registry, and go offline and install again.

    Then you have 30 days for activation. Enter your product key in About - Product License Information. Apply. Then close Visual Studio, go online again and login if required.

    Good luck.


    • Edited by _bug_ Sunday, October 5, 2014 9:50 AM add text
    Sunday, October 5, 2014 9:45 AM
  • The problem has been resolved.
    I parallel 2 OS (Win7 and Win8)
    Win 7 I installed it in mid-August 2014. I have installed VS2013 on it.
    Win 8 I installed it in early November 2014. When installed VS2013 on Win8 I encounter problems as you mentioned.
    Thank you very much. Suggestions you made helped me to have solved the problem.
    I do the following:
    - First I removed 2 resitry:
    HKCR \ Licenses \ E79B3F9C-6543-4897-BBA5-5BFB0A02BB5C \ 0bcad
    HKCR \ Licenses \ E79B3F9C-6543-4897-BBA5-5BFB0A02BB5C \ 06 181

    - Next: I reset the time on time (close to the time) that I installed VS2013 testing.
    - Finally: I repair VS 2013 and 2 resitry delighted that I deleted were added. At the same time my VS 2013 back time when I installed it. When I enter the key and then solving the problem.
    I was hoping someone encountered similar problem solved it without having to reinstall the operating system.

    Vấn đề đã được giải quyết.
    Tôi chạy song song 2 hệ điều hành (Win7 và Win8) 
    Win 7 tôi cài nó vào khoảng giữa tháng 8 năm 2014. Tôi có cài VS2013 trên đó.
    Win 8 tôi cài nó vào khoảng đầu tháng 11 năm 2014. Khi cài VS2013 trên win8 tôi gặp phải vấn đề như bạn nêu ra.
    Rất cảm ơn bạn. Gợi ý bạn đưa ra đã giúp tôi đã giải quyết được vấn đề.
    Tôi làm như sau:
    - Đầu tiên tôi xóa 2 resitry:
    HKCR\Licenses\E79B3F9C-6543-4897-BBA5-5BFB0A02BB5C\0bcad
    HKCR\Licenses\E79B3F9C-6543-4897-BBA5-5BFB0A02BB5C\06181

    - Tiếp theo: Tôi chỉnh lại thời gian về thời điểm (gần với thời điểm) mà tôi cài VS2013 thử nghiệm.
    - Cuối cùng: Tôi chọn sửa chữa VS 2013 và rất vui mừng 2 resitry mà tôi xóa đã được thêm vào. Đồng thời VS 2013 của tôi trở lại thời điểm mà tôi mới cài nó. Khi đó tôi nhập key và giải quyết được vấn đề.
    Tôi rất mong ai đó gặp phải vấn đề tương tự cũng giải quyết được nó mà không cần phải cài lại hệ điều hành.

    Thursday, November 6, 2014 9:31 AM