none
Visual Studio 2015 Help Viewer 2.2 displays HTML as RAW text RRS feed

  • Question

  • Hello

    I have the following Problem, the Helpviewer 2.2 displays the downloaded Help content as RAW Text not as HTML.

    My system is windows 7 x64 with IE11.

    What can I do to see the help as HTML?


    Best regards

    Bordon

    Note: Posted code pieces may not have a good programming style and may not perfect. It is also possible that they do not work in all situations. Code pieces are only indended to explain something particualar.


    • Edited by Bordon Friday, September 11, 2015 5:29 AM
    Friday, September 11, 2015 5:28 AM

Answers

  • Thank you for your reply.

    This specific registry settings did not help, but I read the postings you refered. Than I found the advice about the MIME sniffing, I searched again and my solution is:

    1. Open the Local Group Policy Editor (Start -> Run -> "gpedit.msc").
    2. Under "Local Computer Policy", drill down to the following entry: Computer Configuration / Administrative Templates / Windows Components / Internet Explorer / Internet Control Panel / Security Page / Internet Zone (important not Local Machine Zone!!)

    3. Changing the value to enabled.

    As additional hint: Intranet Zone and Local Machine Zone is still "Not configured". For some reasons this did not worked for me only with setting the "Local Machine Zone"...

    At all MS should change this since I changed the settings of my PC. I will see if the changed value will be re initialized after some time since the machine is in a company network.


    Best regards

    Bordon

    Note: Posted code pieces may not have a good programming style and may not perfect. It is also possible that they do not work in all situations. Code pieces are only indended to explain something particualar.


    • Edited by Bordon Monday, September 14, 2015 6:09 AM
    • Marked as answer by Bordon Monday, September 14, 2015 6:09 AM
    Monday, September 14, 2015 6:08 AM

All replies

  • Hi Bordon,

    Thank you for posting in MSDN forum.

    For your issue, please check the following registry keys on your machine:

    HKLM\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3
    HKLM\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\4

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3\2100

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3\2100

    If the value is not 0, set them to 0.

    Refer to: https://social.msdn.microsoft.com/Forums/vstudio/en-US/7521db62-6e0e-485b-b62c-c018307e3f3f/vs2012-help-still-displayed-as-raw-html?forum=vssetup

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/02402c77-0617-48ab-8d6b-e198b4d8b129/vs2012-help-is-displayed-as-raw-html?forum=vssetup

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, September 14, 2015 1:40 AM
    Moderator
  • Thank you for your reply.

    This specific registry settings did not help, but I read the postings you refered. Than I found the advice about the MIME sniffing, I searched again and my solution is:

    1. Open the Local Group Policy Editor (Start -> Run -> "gpedit.msc").
    2. Under "Local Computer Policy", drill down to the following entry: Computer Configuration / Administrative Templates / Windows Components / Internet Explorer / Internet Control Panel / Security Page / Internet Zone (important not Local Machine Zone!!)

    3. Changing the value to enabled.

    As additional hint: Intranet Zone and Local Machine Zone is still "Not configured". For some reasons this did not worked for me only with setting the "Local Machine Zone"...

    At all MS should change this since I changed the settings of my PC. I will see if the changed value will be re initialized after some time since the machine is in a company network.


    Best regards

    Bordon

    Note: Posted code pieces may not have a good programming style and may not perfect. It is also possible that they do not work in all situations. Code pieces are only indended to explain something particualar.


    • Edited by Bordon Monday, September 14, 2015 6:09 AM
    • Marked as answer by Bordon Monday, September 14, 2015 6:09 AM
    Monday, September 14, 2015 6:08 AM
  • Hello

    I have the following Problem, the Helpviewer 2.2 displays the downloaded Help content as RAW Text not as HTML.

    My system is windows 7 x64 with IE11.

    What can I do to see the help as HTML?



    This is an old thread but I was directed to this thread after I ran into similar error. I am using Win Server 2012. I solved this problem by switching off "Internet Explorer Enhanced Security Configuration". More in the thread  - https://social.msdn.microsoft.com/Forums/sqlserver/en-US/1e9b9a34-7ff5-495d-84d8-052a2a7349f4/ssms-181-helpviewer-23-content-rendered-in-html-format?forum=sqltools.


    --In 'thoughts'... Lonely Rogue.

    Wednesday, July 17, 2019 1:02 PM