none
Can't remove Ghost project from source control or add project with same name

    Question

  • We have a ghost project in our source control explorer.  I tried using TFSdelte to remove it says it doesn't exist.  So when I try to create it it says it is already there.  Here is what it says when I try to create the project.  If it already exists, why can't I delete it?  Thanks for any help you can provide.

    Error
    TF30004: The New Team Project Wizard encountered an unexpected error while initializing the Microsoft.ProjectCreationWizard.Portal plug-in.
    Explanation
    TF30171: The Microsoft.ProjectCreationWizard.Portal plug-in used to create the new team project could not be initialized and returned the following error: TF30270: Project site folder "Engage 2006" already exists.

    1/4/2006 4:25:46 PM | Module: ELeadServiceMediator | Team Foundation Server proxy retrieved | Completion time: 0 seconds
    1/4/2006 4:25:46 PM | Module: Wizard | Retrieved IAuthorizationService proxy | Completion time: 0 seconds
    1/4/2006 4:25:46 PM | Module: ELeadServiceMediator | The template information for Team Foundation Server "etg24" was retrieved from the Team Foundation Server. | Completion time: 0.0937614 seconds
    1/4/2006 4:25:46 PM | Module: Wizard | TF30227: Project creation permissions retrieved | Completion time: 0.0312538 seconds
    1/4/2006 4:25:53 PM | Module: Engine | Thread: 12 | New project will be created with the "MSF for Agile Software Development" methodology
    1/4/2006 4:25:53 PM | Module: Engine | Retrieved IAuthorizationService proxy | Completion time: 0 seconds
    1/4/2006 4:25:53 PM | Module: Engine | TF30227: Project creation permissions retrieved | Completion time: 0.0156269 seconds
    1/4/2006 4:25:55 PM | Module: Engine | Wrote compressed process template file | Completion time: 0.2656573 seconds
    1/4/2006 4:26:03 PM | Module: Engine | Extracted process template file | Completion time: 7.9072114 seconds
    1/4/2006 4:26:03 PM | Module: Engine | Thread: 12 | Starting Project Creation for project "Engage 2006" in domain "etg24"
    1/4/2006 4:26:03 PM | Module: Engine | The user identity information was retrieved from the Group Security Service | Completion time: 0.0625076 seconds
    1/4/2006 4:26:03 PM | Module: Initializer | Thread: 12 | The New Team Project Wizard is starting to initialize the plug-ins.
    1/4/2006 4:26:03 PM | Module: CssStructureUploader | Thread: 12 | Entering Initialize in CssStructureUploader
    1/4/2006 4:26:03 PM | Module: CssStructureUploader | Thread: 12 | Initialize for CssStructureUploader complete
    1/4/2006 4:26:03 PM | Module: Initializer | Thread: 12 | The New Team Project Wizard successfully Initialized the plug-in Microsoft.ProjectCreationWizard.Classification.
    1/4/2006 4:26:03 PM | Module: Rosetta | Thread: 12 | Entering Initialize in RosettaReportUploader
    1/4/2006 4:26:03 PM | Module: Rosetta | Thread: 12 | Exiting Initialize for RosettaReportUploader
    1/4/2006 4:26:03 PM | Module: Initializer | Thread: 12 | The New Team Project Wizard successfully Initialized the plug-in Microsoft.ProjectCreationWizard.Reporting.
    1/4/2006 4:26:03 PM | Module: WSS | Thread: 12 | Entering Initialize in WssSiteCreator
    ---begin Exception entry---
    Time: 1/4/2006 4:26:03 PM
    Module: Initializer
    Event Description: TF30207: Initialization for plugin "Microsoft.ProjectCreationWizard.Portal" failed
    Exception Type: Microsoft.TeamFoundation.Client.PcwException
    Exception Message: TF30270: Project site folder "Engage 2006" already exists
    Stack Trace:
       at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Initialize(ProjectCreationContext context)
       at Microsoft.VisualStudio.TeamFoundation.EngineStarter.InitializePlugins(MsfTemplate template, PcwPluginCollection pluginCollection)
    --- end Exception entry ---

     

    Wednesday, January 04, 2006 10:28 PM

Answers

  • Hi John,

    I'm not sure what the problem with the Source Control Explorer is, but the problem with the Project Creation Wizard failing to create a new project is that it's finding a web site on WSS with the same name as a previously created project.  There were many problems with tfsdeleteproject.exe in beta3, most of which have been fixed for RTM.  If it failed at any step it would generally leave parts of the project around.  Many times this included both the reporting sites and the WSS sites.

    To get rid of the offending site:

    1. navigate to http://<your AT>/sites/Engage 2006. 

    2.  Click on the 'Site Settings' at the top of the page. 

    3. On the 'Site Settings' page, click on 'Go to Site Administration'.   

    4. On the Top-level Site Administration page you should see a link called 'Delete this site' under 'Management and Statistics'.  Click on that and delete the site (make sure that there wasn't any data you want to keep first). 

     

    If the reporting site still exists you will need to delete it as well by doing the following:

    1.  navigate to the reporting site (ie: http://<report server name>/Reports/Pages/Folder.aspx)

    2.  Find the reports folder named 'Engage 2006' and click on it.

    3.  You should see the set of reports that we support (ie: Project Velocity, Regressions, etc).  Click on the 'properties' tab.

    4.  On the 'properties tab click the 'delete' button.

     

    Try creating the project again and let post the results...

     

    I hope this helps!

    Friday, January 06, 2006 1:16 AM

All replies

  • Hi John,

    I'm not sure what the problem with the Source Control Explorer is, but the problem with the Project Creation Wizard failing to create a new project is that it's finding a web site on WSS with the same name as a previously created project.  There were many problems with tfsdeleteproject.exe in beta3, most of which have been fixed for RTM.  If it failed at any step it would generally leave parts of the project around.  Many times this included both the reporting sites and the WSS sites.

    To get rid of the offending site:

    1. navigate to http://<your AT>/sites/Engage 2006. 

    2.  Click on the 'Site Settings' at the top of the page. 

    3. On the 'Site Settings' page, click on 'Go to Site Administration'.   

    4. On the Top-level Site Administration page you should see a link called 'Delete this site' under 'Management and Statistics'.  Click on that and delete the site (make sure that there wasn't any data you want to keep first). 

     

    If the reporting site still exists you will need to delete it as well by doing the following:

    1.  navigate to the reporting site (ie: http://<report server name>/Reports/Pages/Folder.aspx)

    2.  Find the reports folder named 'Engage 2006' and click on it.

    3.  You should see the set of reports that we support (ie: Project Velocity, Regressions, etc).  Click on the 'properties' tab.

    4.  On the 'properties tab click the 'delete' button.

     

    Try creating the project again and let post the results...

     

    I hope this helps!

    Friday, January 06, 2006 1:16 AM
  • I followed your steps, but still have problems in completly delete an existing project and recreate a new with the same name:

    Error
    TF24018: Team Foundation Server Configuration Failure. Team project 'OmniShop' already exists on this Team Foundation Server.
    Explanation
    Project name 'OmniShop' already exists on the server. The team project name must be unique on all Team Foundation servers used by the new project.
    User Action
    Choose a name that is unique and re-run the Project Creation Wizard."

    Full log:

    2007-01-11 09:12:52Z | Module: Internal | Team Foundation Server proxy retrieved | Completion time: 0 seconds
    2007-01-11 09:12:52Z | Module: Internal | The template information for Team Foundation Server "db01" was retrieved from the Team Foundation Server. | Completion time: 0,0469452 seconds
    2007-01-11 09:12:52Z | Module: Wizard | Retrieved IAuthorizationService proxy | Completion time: 0 seconds
    2007-01-11 09:12:52Z | Module: Wizard | TF30227: Project creation permissions retrieved | Completion time: 0 seconds
    2007-01-11 09:13:14Z | Module: Engine | Thread: 10 | New project will be created with the "OSPP - Small Project Process v1.3" methodology
    2007-01-11 09:13:14Z | Module: Engine | Retrieved IAuthorizationService proxy | Completion time: 0 seconds
    2007-01-11 09:13:14Z | Module: Engine | TF30227: Project creation permissions retrieved | Completion time: 0 seconds
    2007-01-11 09:13:14Z | Module: Engine | Wrote compressed process template file | Completion time: 0 seconds
    2007-01-11 09:13:15Z | Module: Engine | Extracted process template file | Completion time: 0,6885296 seconds
    2007-01-11 09:13:15Z | Module: Engine | Thread: 10 | Starting Project Creation for project "OmniShop" in domain "db01"
    2007-01-11 09:13:15Z | Module: Engine | The user identity information was retrieved from the Group Security Service | Completion time: 0,0156484 seconds
    2007-01-11 09:13:15Z | Module: Initializer | Thread: 10 | The New Team Project Wizard is starting to initialize the plug-ins.
    2007-01-11 09:13:15Z | Module: CssStructureUploader | Thread: 10 | Entering Initialize in CssStructureUploader
    2007-01-11 09:13:15Z | Module: CssStructureUploader | Thread: 10 | Initialize for CssStructureUploader complete
    2007-01-11 09:13:15Z | Module: Initializer | Thread: 10 | The New Team Project Wizard successfully Initialized the plug-in Microsoft.ProjectCreationWizard.Classification.
    2007-01-11 09:13:15Z | Module: Rosetta | Thread: 10 | Entering Initialize in RosettaReportUploader
    2007-01-11 09:13:15Z | Module: Rosetta | Thread: 10 | Exiting Initialize for RosettaReportUploader
    2007-01-11 09:13:15Z | Module: Initializer | Thread: 10 | The New Team Project Wizard successfully Initialized the plug-in Microsoft.ProjectCreationWizard.Reporting.
    2007-01-11 09:13:15Z | Module: WSS | Thread: 10 | Entering Initialize in WssSiteCreator
    2007-01-11 09:13:15Z | Module: WSS | Thread: 10 | Site information: Title = "OmniShop"  Description = "Product Portal for OmniShop This team project was created based on the 'OSPP - Small Project Process v1.3' process template."
    2007-01-11 09:13:15Z | Module: WSS | Thread: 10 | Base site url:
    http://DB01/sites
    2007-01-11 09:13:15Z | Module: WSS | Thread: 10 | Admin site url: http://DB01:17012/_vti_adm/admin.asmx
    2007-01-11 09:13:15Z | Module: WSS | Thread: 10 | Exiting Initialize for WssSiteCreator
    2007-01-11 09:13:15Z | Module: Initializer | Thread: 10 | The New Team Project Wizard successfully Initialized the plug-in Microsoft.ProjectCreationWizard.Portal.
    2007-01-11 09:13:15Z | Module: GSSStructureUploader | Thread: 10 | Entering Initialize in GssStructureCreator
    2007-01-11 09:13:15Z | Module: GSSStructureUploader | Thread: 10 | Exiting Initialize for GssStructureCreator
    2007-01-11 09:13:15Z | Module: Initializer | Thread: 10 | The New Team Project Wizard successfully Initialized the plug-in Microsoft.ProjectCreationWizard.Groups.
    ---begin Exception entry---
    Time: 2007-01-11 09:13:15Z
    Module: Initializer
    Event Description: TF30207: Initialization for plugin "Microsoft.ProjectCreationWizard.WorkItemTracking" failed
    Exception Type: Microsoft.TeamFoundation.Client.PcwException
    Exception Message: TF24018: Team Foundation Server Configuration Failure. Team project 'OmniShop' already exists on this Team Foundation Server.
    Exception Details: Project name 'OmniShop' already exists on the server.
    The team project name must be unique on all Team Foundation servers used by the new project.
    Stack Trace:
       at Microsoft.VisualStudio.TeamFoundation.WorkItemTracking.WitPcwPlugin.PcwPluginComponentCreator.Initialize(ProjectCreationContext ctxt)
       at Microsoft.VisualStudio.TeamFoundation.EngineStarter.InitializePlugins(MsfTemplate template, PcwPluginCollection pluginCollection)
    --- end Exception entry ---

     

     

     

    Thursday, January 11, 2007 8:13 AM
  • Hi,

    Have you solved the problem, because I have the same. Maybey you give me a hint. I have deletetd the project in TFS, the projcet in reporting services and the site. After reboot of the server the same behaviour. 

    regards,

    Bernd

    Tuesday, February 20, 2007 9:54 AM
  • With new SP 1 you are able to delete newly created projects, but for some reason OLD projects will not be deleted completly. I read some place that the TFS team admitted that there must be a bug somewhere. So I'm just waiting for a SP2 :)
    Thursday, February 22, 2007 12:05 PM
  •  

    We ran up against this problem and found that the solution lay within the user profile.
    In our case we were doing a lot of development testing which involved creating TFS projects, migrating several GB of data from legacy systems into these projects, and then restoring the SQL Server databases in order to re-test other parts of our migration.

    When reverting the databases to a point in time before the TFS projects existed, we found that even after clearing out a few of the registry settings and file system cache locations which had data in them referring to the earlier state, that we were *sometimes* unable to re-create the project in TFS.  On these occasions we found that deleting the user's profile entirely from the server, and then logging back in - where upon the user profile is recreated - that we were then able to re-create the required project.  Obviously the 'problem' lies somewhere with the profile, and deleting the whole profile may be a little excessive - but if you are having trouble in this area - the profile may be a good place to start investigating. (For ourselves we didn;t have the time to establish exactly which cached files were hurting us.)

     

    HTH

     

    Peter Blackburn

    www.sqlreportingservices.net

    Saturday, August 11, 2007 11:29 PM
  • Thanks I was able to remove the project Smile

      Dennis Habib MSFT wrote:

    Hi John,

    I'm not sure what the problem with the Source Control Explorer is, but the problem with the Project Creation Wizard failing to create a new project is that it's finding a web site on WSS with the same name as a previously created project.  There were many problems with tfsdeleteproject.exe in beta3, most of which have been fixed for RTM.  If it failed at any step it would generally leave parts of the project around.  Many times this included both the reporting sites and the WSS sites.

    To get rid of the offending site:

    1. navigate to http://<your AT>/sites/Engage 2006. 

    2.  Click on the 'Site Settings' at the top of the page. 

    3. On the 'Site Settings' page, click on 'Go to Site Administration'.   

    4. On the Top-level Site Administration page you should see a link called 'Delete this site' under 'Management and Statistics'.  Click on that and delete the site (make sure that there wasn't any data you want to keep first). 

     

    If the reporting site still exists you will need to delete it as well by doing the following:

    1.  navigate to the reporting site (ie: http://<report server name>/Reports/Pages/Folder.aspx)

    2.  Find the reports folder named 'Engage 2006' and click on it.

    3.  You should see the set of reports that we support (ie: Project Velocity, Regressions, etc).  Click on the 'properties' tab.

    4.  On the 'properties tab click the 'delete' button.

     

    Try creating the project again and let post the results...

     

    I hope this helps!

    Friday, April 18, 2008 8:22 PM