none
The program '[14400] iisexpress.exe' has exited with code 0 (0x0) RRS feed

  • Question

  • Hi, 

    I am getting below error when I run my web application. 

    The program '[3736] iisexpress.exe' has exited with code 0 (0x0).

    Please help me resolving this error. I have tried almost all suggestions which are on internet.

    vs 2017 issue

    Thanks..

    Monday, September 25, 2017 5:13 AM

All replies

  • Hi Mithilesh3,

    Thanks for your posting.

    Several method below might be helpful:

    1)

    check your solution folder for a hidden ".vs" folder with a "config" sub-folder. If that folder exists and it has it's own applicationhost.config file you need to either rename (or delete) that file or edit it and make sure the website(s) configured inside match the ASP.NET web app(s) in your solution that you are trying to debug. Hope this helps.

    2)

     Solution Explorer in Visual Studio, right click on the web project, chose properties and then navigated to the "web" tab. From there I changed the Project URL to another port number. For example, if it was http://localhost:1052 - I changed it to  http://localhost:4356.

    3)

    If your machine is 64bit, please go to Tools-> options -> projects and solutions:

    Please let me know which one shown above could help.

    Have a good day:)

    Looking forward to your reply.

     

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Monday, September 25, 2017 5:45 AM
    • Proposed as answer by Fletch Zhou Wednesday, September 27, 2017 7:45 AM
    Monday, September 25, 2017 5:44 AM
  • #3 in your answer worked for me.
    Tuesday, February 27, 2018 4:54 PM
  • Thanks response very very good
    Monday, March 5, 2018 5:49 PM
  • Hi guys,

    We were getting the same issue and our solution was very simple: 

    1) Right click on the Web project and select "Set as StartUp Project"

    2) Then change the browser in the top menu, see below picture.

    In our case, it was failing with IE and it works for Chrome and Edge.

    Thursday, May 17, 2018 2:30 PM
  • #3 from your solution list worked for me
    Monday, August 27, 2018 4:16 PM
  • Thanks you very good.
    Thursday, August 30, 2018 3:58 PM
  • Thank you Fletcher,  the second method is solved my problem.
    Monday, January 14, 2019 4:56 PM
  • I too found a Silverlight .Net web app that would not debug. It would start in debug, and the orange bar would be on bottom of screen. Then it went away. Googled all day. At 1:10PM found this url. Got here by googling “The program '[5600] w3wp.exe: Managed (v4.0.30319)' has exited with code 0 (0x0).”  

    #3 The Tools, Options, Project and Solutions recommendation got it to work for me, but wasn't the same.  Mine didn’t have the ‘use the 64 bit version of IIS Express for web sites and projects’ option. It had “Use IIS Express for new file-based web sites and projects.” It was checked. I unchecked it. I think my web app is using IIS 7 not ISS Express. After restarting I could debug!

    Wednesday, May 8, 2019 5:27 PM
  • I ran into the same issue today, for the first time. New installation of VS 2017 on a new box for me...

    Anyway, the 3rd option worked for me as well, at least after I closed down VS and reopened it...

    Thanks!

    Thursday, August 8, 2019 5:02 PM
  • Thank You sir.

    I figure out my problem by your way.

    Best regards...


    az

    Thursday, August 15, 2019 11:43 AM