none
Disable autocomplete with spacebar in Visual Studio 2015 - C# RRS feed

  • Question

  • How do you disable autocomplete with spacebar( + other characters) for C# in VS2015?

    In VS2013 the option was in "Tools->Options->Text Editor->c#->Committed by pressing space bar"

    This option does not seem to exist in VS2015.

    Scott Logan



    • Edited by slogan_oxts Monday, September 28, 2015 11:19 AM Typo
    Monday, September 28, 2015 11:15 AM

Answers

  • >>OK found it,

    Just need to use:

    Edit->IntelliSense->Toggle Completion Mode.  

    Glad to know that you got the answer, if so, you could mark your reply as the answer, so other members who get the same issue could get/research the answer easily from your thread.

    >>This disables it for all characters though which suits me but VS2013 let you choose specific characters I'm not sure why that was removed.

    If you mean that the IntelliSense settings have been changed from the VS2013 to 2015, it really has this issue now.

    Maybe you could submit the suggestions here: http://visualstudio.uservoice.com/forums/121579-visual-studio.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, September 29, 2015 9:15 AM
    Moderator

All replies

  • OK found it,

    Just need to use:

    Edit->IntelliSense->Toggle Completion Mode.  

    This disables it for all characters though which suits me but VS2013 let you choose specific characters I'm not sure why that was removed.

    Monday, September 28, 2015 12:51 PM
  • >>OK found it,

    Just need to use:

    Edit->IntelliSense->Toggle Completion Mode.  

    Glad to know that you got the answer, if so, you could mark your reply as the answer, so other members who get the same issue could get/research the answer easily from your thread.

    >>This disables it for all characters though which suits me but VS2013 let you choose specific characters I'm not sure why that was removed.

    If you mean that the IntelliSense settings have been changed from the VS2013 to 2015, it really has this issue now.

    Maybe you could submit the suggestions here: http://visualstudio.uservoice.com/forums/121579-visual-studio.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, September 29, 2015 9:15 AM
    Moderator