none
MIssing C/C++ option under property pages - configuration properties RRS feed

  • Question

  • Visual Studio PRO 2005

    I can not find the C/C++ option in the Property Pages window under Configuration Properties.

    My list goes General, Debugging, Linker, Manifest Tool, etc...

    I am trying to set up some compiler options as listed in a tutorial I am doing for SDL.

    I have tried re-installing, as well as different install configs. I tried resetting the environment to the General config and the Visual C++ 6 config.

    I have looked over MSDN and the web in general and I am stumped.

    I have also tried it on 2 different computers just to see if it was an external issue.
    Saturday, July 12, 2008 7:59 PM

Answers

  • As soon as I ask the question I find the answer elsewhere.  Typical :-)

    "Thanks to Dr. Mark Young for the following observation: If you are trying to make any of the settings mentioned in the previous two list items, and you are not seeing the C/C++ option under Configuration Properties on your project's Properties page, it is likely because you are trying to set the property before adding a C++ file to your project. So ... make sure you have some C++ code in your project before trying to set any of those properties."


    Source:  http://cs.smu.ca/~porter/csc/ref/vs_ide2005.html
    • Marked as answer by viator Saturday, July 12, 2008 8:07 PM
    Saturday, July 12, 2008 8:07 PM

All replies

  • As soon as I ask the question I find the answer elsewhere.  Typical :-)

    "Thanks to Dr. Mark Young for the following observation: If you are trying to make any of the settings mentioned in the previous two list items, and you are not seeing the C/C++ option under Configuration Properties on your project's Properties page, it is likely because you are trying to set the property before adding a C++ file to your project. So ... make sure you have some C++ code in your project before trying to set any of those properties."


    Source:  http://cs.smu.ca/~porter/csc/ref/vs_ide2005.html
    • Marked as answer by viator Saturday, July 12, 2008 8:07 PM
    Saturday, July 12, 2008 8:07 PM
  • think you i have the same problem and you words help me
    Wednesday, December 1, 2010 10:40 AM
  • This thread is old but thanks, you saved me some frustration.
    Thursday, August 27, 2015 6:33 PM
  • If anyone stumbles upon this thread, you might also have to right click the SOURCE file and go to properties, and then change "EXCLUDE FROM BUILD" to  "RESET TO DEFAULT SETTINGS"
    Wednesday, March 8, 2017 7:57 AM
  • Thanks a lot.
    Thursday, January 25, 2018 4:09 AM