HTTP Error 404.3 - Not Found


  • Hi!

    We are using WCF with WAS and this have worked grate on all computers. But now one of the computers gets the following error when browsing the svc file :

    HTTP Error 404.3 - Not Found

    The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

    The services like tcp.listener and so on are cheked and thay are running properly, the computer is restarted with no success.

    We have tried to add some other services to the Localhost IIS7 but thay are reporting the same error.

    Pleas advice.
    Wednesday, December 02, 2009 9:45 AM


  • This is solved by the following :
    1. Run Visual Studio 2008 Command Prompt as “Administrator”.
    2. Navigate to C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation.
    3. Run this command servicemodelreg –i.
    • Marked as answer by SnowJim Wednesday, December 02, 2009 9:58 AM
    Wednesday, December 02, 2009 9:58 AM