locked
Cannot create any workitem in new team project: "value cannot be null. Parameter name: key"

    Question

  • We used to have one team project we created several years ago and which we still using. Today I created a new one based on the "Microsoft Visual Studio Scrum 2013" template. When I now try to create a workitem, regardless which type I use, I always get

    "Value cannot be null. Parameter name key"

    The TFS activity log shows that work item tracking method "Update" failed with an ArgumentNullException.

    Another observation: I have another team project which has been used to test changes in the work item type definition before applying them to our "production" project. That team project shows the same behaviour. In that project updating existing workitems also fails.

    Another bit of information which might have some relevance: With TFS 2012 (we're now on 2013) we started to use the new planning features by updating our team project and defined several team. Instead of using an area path, we have defined a team field. That works well. The new teamproject uses the standard template, i.e. uses the area paths for defining the team which owns work items.

    Any idea what's going on and how to fix this?

    Wednesday, November 6, 2013 8:50 AM

Answers

All replies

  • This happens when the team field isn't a required field. TFS 2013 expects each work item to be assigned to a team by default. Update the process template to make the team field required for now, this should fix the issue for now.

    Or when the Team field (even when using Area) is incorrectly configured for the team in question.

    I believe this is a known bug in 2013, but I'll let the Product Group reply to that one.

    Martin Hinselwood has had this issue before and he wrote a lengthy blog post on the issue: http://nakedalm.com/issue-tfs-2013-work-item-tracking-gives-you-value-cannot-be-null-parameter-name-key/


    My blog: blog.jessehouwing.nl


    Wednesday, November 6, 2013 2:41 PM
  • I suspected something like that. But I tought that if I have one team project which uses a custom team field I can have other teamprojects in the same collection using the area path as team field. This seems not to be the case.

    I added our custom team field to the new work items in the team project with a default value but continue to use the area path as team field in that project and now the error is gone. 

    Looking forward to hear from the product group about this bug.

    Thursday, November 7, 2013 8:15 AM
  • Hi Martin, 

    Thanks for your post.

    For this scenario, you can submit it to Microsoft Connect Feedback portal at: https://connect.microsoft.com/VisualStudio. Microsoft engineers will evaluate them seriously.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, November 7, 2013 8:24 AM
    Moderator
  • Sorry to ask this question (maybe too obvious), but what does it mean that "Team field (even when using Area) is incorrectly configured for the team in question."?

    We are having the same exact issue after upgrading from TFS 2012 and tried multiple things - reverting team field back to area path, marking is required, but still getting same error.

    Any help would be very much appreciated.

    Wednesday, March 5, 2014 9:30 PM