none
Visual Studio Lab Center - Settring up Win 8 test client RRS feed

  • Question

  • Hi Folks,

      I'm using Visual Studio 2012 Ultimate to set up a windows 8 virtual machine for running some coded UI tests.

    My setup involves Server 2012 running hyper-v connected to a domain (domain X).  On this server I am running two virtual machines - one running a domain controller (domain Y) and the other running windows 8 (connected to domain Y).  Both machines can access the host (and internet) and I can remote into them from the host using remote desktop or via the hyper-v client.

    I have installed the test agent software on the Windows 8 machine and I am using Lab center to set up the Win 8 client.  I have installed the test controller on the hyper-v host and it is connected to a TFS Project.

    At the end of the process setting up a new test client I get an error message  TF259098 Team Foundation Server could not perform the following operation because of one or more errors....

    Microsoft Test Manager could not complete the following action: Validating the user name and password for coded UI tests. TF260948: The user name or password provided to configure the test agent to run as a process is not valid.

    The issue I have is that for the account required for running UI tests, lab center will only let me enter a username that is a member of domain X, however, the test agent is set up to use a domain Y account (as the Win 8 machine is not a member of domain X).

    If I try and enter the correct account, on the verification screen I get a 'failed - verify that the machines are accessible using the username and password provided'  - they are because this is what I use to remote into the machine.

    If I uncheck the 'configure for environment to run UI tests' it appears to complete the setup successfully. Although I get a warning TF259641:  To use the environment, you must install a compatible test agent.    If I click 'install agent' it whirs away, finishes but the warning remains.

    I have looked at configuring a service account on the Team Foundation Server, but under 'team product collections, lab management'  I only have the Configure library Shares and Configure Host Groups which are configured (the service account option is not visible - if it is still used in TFS2012).

    The status of the VM in lab center is shown as 'Not Ready' and I cannot connect to it.

    I can replicate the issue on a Windows 7 client, however, I can connect it using Lab Center.

    Regards

    Andy

    Wednesday, April 24, 2013 4:58 AM

All replies

  • Hi Andy,

    Thank you for your post.

    Seems you want to create environment in MTM Lab center. The creation stopped at "Verification"-"verify that the machines are accessible using the user name and password provided" step. If I miss-understanding anything, please free feel to let me know.

    Hope you can help collect following information to narrow down the issue.

    1. Does the user you enter can access Windows 8 VM?

    2. Is there any detail event log?

    3. Would you please enable tracing for MTM, and share us the log?

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, April 25, 2013 8:04 AM
    Moderator
  • Hi,

    Apologies with the delay in getting back with the results.

    In the Lab center my process is this:-

    Environment:   Test W8 Machine.   Desktop Client, Not Ready    (the VM is running and I am logged in as the admin user)

    There is an environment message: TF259641: To use the environment, you must install a compatible test agent in all machines of the environment.

    I click install to load the test agent.  For the credentials, I use a domain admin account for the machine (note that this machine is in a different domain than MTM) which is the same account I have remoted into the VM above. 

    MTM proceeds to install the agent (Preparing for operation: Repair environment). At the end, it returns to where it was showing the same TF259641 message.

    In the MTM log file there are a few exceptions for the ...AUM.xml file.

    V, 8856, 13, 2013/05/03, 11:56:10.807, ABC\mtm.exe, Step: 0, AttachmentUpload: Cannot read backup file because of System.IO.FileNotFoundException: Could not find file 'C:\Users\xyz\AppData\Local\Microsoft\Team Foundation\4.0\TestManagement\577adcc7-0683-4b97-80be-3ec5a7065134_Aum.xml.bak'.
    File name: 'C:\Users\xyz\AppData\Local\Microsoft\Team Foundation\4.0\TestManagement\577adcc7-0683-4b97-80be-3ec5a7065134_Aum.xml.bak'

    and

    V, 8856, 13, 2013/05/03, 11:57:40.814, ABC\mtm.exe, Step: 0, AttachmentUpload: Cannot read primary file because of System.IO.FileNotFoundException: Could not find file 'C:\Users\xyz\AppData\Local\Microsoft\Team Foundation\4.0\TestManagement\577adcc7-0683-4b97-80be-3ec5a7065134_Aum.xml'.
    File name: 'C:\Users\andreww2\xyz\Local\Microsoft\Team Foundation\4.0\TestManagement\577adcc7-0683-4b97-80be-3ec5a7065134_Aum.xml'

    Where xyz is the user account I am running visual studio lab center under on my development machine, ABC is the domain that the Windows 8 VM is in.


    • Edited by AndyW2007 Friday, May 3, 2013 12:17 AM
    Friday, May 3, 2013 12:13 AM
  • Hi,

    What's the result after install compatible test agent on VM first, then create the environment?

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, May 6, 2013 6:54 AM
    Moderator
  • Same,  that's what I did originally.

    I thought maybe I might have put an 'incompatible one on' however, nothing [tet agent] shows as being installed on the client VM.

    Monday, May 6, 2013 11:33 PM
  • Hi,

    Thank you for your response information.

    I am trying to involve someone to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Regards,


    Lily Wu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, May 7, 2013 7:07 AM
    Moderator
  • Consider add a two way domain trust between domain x and domain y, which is test agent domain and host domain. Could that resolve the error? 

    http://technet.microsoft.com/en-us/library/cc961481.aspx


    Forrest Guo | MSDN Community Support | Feedback to manager


    Tuesday, May 7, 2013 8:06 AM
    Moderator
  • Unfortunately my host machine is running in a production domain and the VMs are running in a local developer environment  (the DC is in another VM connected using a virtual network).

    There doesn't appear to be any issue with the connection to the machine, it is just failing to install the test agent and as far as I can see it is because it cant find one of its own files.

    I thought it might be a Win 8 issue but this also occurs with a Win 7 VM.

    Tuesday, May 7, 2013 11:58 PM
  • Please help me understand why you think it's because it cannot find one of it's own files.

    Since the test agent is in different domain as test controller and TFS, it is necessary to set up domain trust. Otherwise, join the product domain on test agent.

    Does that sound make sense?


    Forrest Guo | MSDN Community Support | Feedback to manager

    Wednesday, May 8, 2013 2:38 AM
    Moderator
  • I figured that it can't find one of its own files because the error messages (see above) are FileNotFound exceptions.

    System.IO.FileNotFoundException: Could not find file 'C:\Users\xyz\AppData\Local\Microsoft\Team Foundation\4.0\TestManagement\577adcc7-0683-4b97-80be-3ec5a7065134_Aum.xml'.

    Setting up a domain trust between a production environment and a dev. environment is out of the question.

    Friday, May 10, 2013 2:11 AM
  • That missing file looks like temporary file, I have similar file but file name prefixed with different ID.

    Let me try to get another people help you on this case.


    Forrest Guo | MSDN Community Support | Feedback to manager

    Friday, May 10, 2013 5:06 AM
    Moderator
  • Has this issue been solved ? I've got almost the same problem, where my test machine is on the same domain with the test controller. I'm using a standard environment instead of an SCVMM environment.
    Friday, October 4, 2013 10:35 AM
  • For those who still are looking for an answer, here is my solution. All these steps were executed on the test controller / test manager machine (which is the same machine in my case) :

    1 - I'm not sure if this is related to my problem but this was something I did before the following steps. At some point I've tried to install the VS Agents separately to the test agent machine. It didn't help to solve my problem but I could see to which machine it was being registered. After executing one of the following steps (I can't remember which one) I saw it being registered to a machine name which was on the test controller's hosts file pointing to 127.0.0.1. I've deleted those records from the hosts file. Now the localhost is pointing to 127.0.0.1 and after completing these steps the test agent is being registered to the test controller with the right machine name.

    2- Since I have two network adapters on the test controller/manager machine, I've added the "bind to" key to the QTControllerConfig.xml file according to this article http://support.microsoft.com/kb/944496/en-us 

    I didn't add it to the QTAgentService.exe.config on the Test Agent and to the QTAgent.exe.config on Test Controller.

    (I don't believe that this step was necessary but it's worth mentioning)

    3 - On the test controller, I've deleted the cache in this directory : C:\Users\username\AppData\Local\Microsoft\Team Foundation\4.0\Cache

    This step does not solve the issue by itself.

    4 - I've deleted the record about a former environment from the file QTControllerConfig.xml which is located at C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE.

    After these steps I could finally install the test agent to my virtual machine from the test manager.


    • Edited by enmosarge Friday, October 11, 2013 8:31 AM
    Friday, October 11, 2013 6:59 AM