Framework 4.0 Multiple Errors... RRS feed

  • Question

  • Hi,

    So I tried installing Framework 4.0 but when I do I get these errors (found in the log):

    Returning IDOK. INSTALLMESSAGE_ERROR [Service '@C:\Windows\Microsoft.NET\Framework64\v4.0.30319\WPF\WPFFontCache_v0400.exe,-100' (WPFFontCache_v0400) could not be installed. Verify that you have sufficient privileges to install system services.]


    PerformOperation returned 1603 (translates to HRESULT = 0x80070643)


    Error 1603:1923 is mapped to Custom Error: Retry
    Retry 1 of 1 of custom error handling
    Retry count over existing limit, not going to retry again.
    OnFailureBehavior for this item is to Rollback.

    And ends as:

    Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:05:45).

    Im on Windows Vista

    Help me Please and Thank you

    • Edited by Qwerty- Monday, September 19, 2011 10:30 PM
    Monday, September 19, 2011 10:27 PM


All replies

  • Qwerty,


    When you run the install program, make sure you're running it as an Administrator.   Right click on the EXE (i think it's dotNetFx40_Full_x86_x64.exe) and select "Run as Administrator".

    Tom Overton
    • Proposed as answer by Alexander Sun Wednesday, September 21, 2011 7:38 AM
    Tuesday, September 20, 2011 12:32 AM
  • if you run as administrator and the issue occurred again, please follow these steps in order to go on with the analysis of your case:


    2.Click on the Start menu, choose Run, type msconfig and click OK

    3.In the System Configuration tool, click on the Services tab

    4. Check the box labeled Hide all Microsoft services

    5. Click the Disable All button to disable all non-Microsoft services

    6.In the System Configuration tool, click on the General tab

    7.Click the Selective startup radio button

    8.Uncheck the box labeled Load startup items

    9. Click OK to accept all changes in the System Configuration tool

    10.Reboot for the changes to take effect

    11. Delete all files in %temp%

    12.Start Fx 4.0 installation

    13.Take a screenshot about the issue

    14. run collect.exe

    15. you can analize the log files in %temp% directory or send me to

    Note: please attach the link of this post in the mail.

    || Michele Brina || Developer Support Engineer ||
    Tuesday, September 20, 2011 8:24 AM
  • Thanks deleting the files in temp worked!
    • Marked as answer by Alexander Sun Thursday, September 22, 2011 3:36 AM
    Thursday, September 22, 2011 12:21 AM
  • Thanks. I got the same problem and it's such a simple solution.
    White Carpet Kitchen Carpet
    Thursday, September 22, 2011 3:41 AM