none
VS Studio 2012 RC goes into endless loop "Loading Components" and never launches RRS feed

  • Question

  • Win 7 Pro 64 bit OS. This machine had a working VS 2012 RC on it, and all .NET FrameWorks, including 4.5 as of yesterday.

    About one day ago, I installed an update to the NuGet Extension, and one other Extension I forget the name of. At that time VS 2012 RC was working fine.

    Today, trying to launch VS 2012 RC: it never loads: instead the "Loading Components" dialog box with progress-bar appears, and never finishes.

    I have tried un-installing VS 2012 RC, and the un-install process throws an error related to the C++ error package not being available at some expected address which is a GUID followed by a file-name.

    Cancelling the error dialogue leads the un-installer to not fail, but to continue, and un-install some parts of VS. But, VS 2012 RC is not un-installed, according to what you see in the 'Programs and Features' Control Panel.

    I am have run a second un-install of VS:  the second un-install apparently did remove VS 2012 RC. After the un-install, there are still a of files left related to Visual Studio. the GAC appears untouched, etc.

    So, I download the latest installer from MS, and try to install:

    The install fails with the message: "Microsoft FrameWork 4.5 Fatal Error During Installation." With the warning message: "MicroSoft Visual Studio Post-Clean Tool ... User cancelled installation."

    The complete log-file is here: 

    https://dl.dropbox.com/u/509136/dd_vs_professional_20121010115358.log.txt

    The main point of failure revealed in the log file is here:

    [0BF8:0298][2012-10-10T12:04:31]: Acquiring package: vs_postclean_vs, payload: vs_postclean_vs, download from: bits://go.microsoft.com/fwlink/?LinkId=250372&clcid=0x409
    [0A3C:0AC8][2012-10-10T12:04:33]: Error 0x80070643: Process returned error: 0x80070643
    [0A3C:0AC8][2012-10-10T12:04:33]: Error 0x80070643: Failed to execute EXE package.
    [0BF8:047C][2012-10-10T12:04:33]: Error 0x80070643: Failed to configure per-machine EXE package.
    [0BF8:047C][2012-10-10T12:04:33]: MUX:  Installation size in bytes for package: netfxfullredist_43 MaxAppDrive: 0  MaxSysDrive: 954947472  AppDrive: 0  SysDrive: 70483718
    [0BF8:047C][2012-10-10T12:04:33]: MUX:  Return Code:0x80070643 Msi Messages:0 Result Detail:0 Restart:None
    [0BF8:047C][2012-10-10T12:04:33]: MUX:  Set Result: Return Code=-2147023293 (0x80070643), Error Message=, Result Detail=, Vital=True, Package Action=Install, Package Id=netfxfullredist_43
    [0BF8:047C][2012-10-10T12:04:33]: Applied execute package: netfxfullredist_43, result: 0x80070643, restart: None
    [0BF8:047C][2012-10-10T12:04:33]: Error 0x80070643: Failed to execute EXE package.

    Is there any type of "cleaner" program available from MS that will guarantee a complete un-install of VS 2012 RC. Is there a "cleaner" program that will remove all left-over files of Extensions like NuGet which remain after the VS 2012 RC removal ?

    Appreciate your help.

    thanks !


    Bill Woodruff



    • Edited by dotScience Wednesday, October 10, 2012 5:26 AM added new information, link to log file, and excerpt from log file
    Wednesday, October 10, 2012 3:28 AM

All replies

  • Hi Bill Woodruff,

    Thanks for your post.

    I've checked your logs, your core error is:

    [0A3C:04E8][2012-10-10T12:01:17]: Error 0x80092009: Failed to get authenticode certificate embedded in: C:\ProgramData\Package Cache\.unverified\cabF1B365A9647847E1A4761665B71DDB59
    [0A3C:04E8][2012-10-10T12:01:17]: Error 0x80092009: Failed to verify signature of payload: cabF1B365A9647847E1A4761665B71DDB59

    As far as I know that the error messages I highlight above are normally raised when the installer is corrupted or the user account you are using are not have the required privilege to perform the installation. 

    Please refer to this page to make sure all RC components includes updates have been removed:

    http://support.microsoft.com/kb/2744926

    The error 0x80092009 sometimes occured when you have update issue on your OS. If you have, ,try this tool to fix:

    http://support.microsoft.com/kb/947821

    Since RC is out of date, I recommend you try install Visual Studio 2012 RTM Trail version:

    http://www.microsoft.com/visualstudio/eng/products/visual-studio-overview

    Ensure you have verified the ISO checksum if you tried ISO format.

    Hope the info helps.

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, October 11, 2012 5:57 AM
    Moderator
  • Barry,

    Thank you very much for your reply and analysis. After twice restoring the computer to a 'restore point' two days before VS Studio 2012 RC became unusable; I then had the same problems. So, I switched strategies to:

    Uninstall RC 1, and install VS Studio 2012 Pro RTM trial version. 

    That has led to a new "boatload of troubles" which I chronicle in detail in this post:

    Now VS 2021 Pro RTM trial will not work

    That message includes links to the outcome of running the ".NET Log Collector" tool, and links to other log files, and is as complete as I can make it.

    So, perhaps the right thing is to close-out this post, since I am in a whole new nightmare, now, with VS Studio Trial RTM :)

    Again, thanks for your time !

    best, Bill


    Bill Woodruff

    Thursday, October 11, 2012 7:03 AM
  • Hi Bill,

    I may have to merge your two case becasue they may due to the same error.

    Would you please try "Aaron"'s solution to remove components on your OS?

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, October 11, 2012 7:14 AM
    Moderator
  • Hi Barry,

    Yes, I will try Aaron's solution. And, I did receive a response from Aaron to my latest top-level post here, which I have responded to.

    Since both my messages are so bloody long and complex, and the issue of "2012 RC going into an endless loop," and the issue of "getting RTM working after using RC," seem rather different to me; I'd kind of not like to see them merged, but if you feel that's appropriate, so be it.

    thanks, Bill


    Bill Woodruff

    Thursday, October 11, 2012 7:33 AM