none
Add-Migration command only prompt “ScriptHalted” RRS feed

  • Question

  • I'm trying to learn how to make App.Net Core application using Razor pages, using this tutorial : https://docs.microsoft.com/en-us/aspnet/core/tutorials/razor-pages/model?view=aspnetcore-3.0&tabs=visual-studio (sorry can't post direct links until Microsoft verify my account)

    After I made the Movie model and scaffold it successfully, I try to make the initial migration of the database.

    However, every time I'm using the command Add-Migration, it just prompts ScriptHalted, even when using the verbose option, same with Update-Database.

    I tried other commands like Enable-Migration and they seems to work, but not the two I need.

    Is there anything that I'm missing ?

    It seems to me that I followed the tutorial perfectly, and tried to find an answer here, yet I didn't come up with any solutions.

    Thursday, October 31, 2019 1:08 PM

All replies

  • Hi PepperTiger,

    Thank you for posting here.

    It seems that your problem have been solved in other forum.

    I suggest you post and mark your asnwer here, so that it will help other members to find the solution quickly if they face a similar issue.

    Thank you for your question and support.

    Best Regards,

    Xingyu Zhao


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 1, 2019 9:33 AM
    Moderator