none
tfpt unshelve - getting "unable to identify the workspace"

    Question

  • I'm attempting to utilize the /migrate switch of the tfpt unshelve command. However when I run the command:

    tfpt unshelve "my shelfset" /source:$/TeamProject1/Branch1 /target:$/TeamProject2/Branch1

    I get:
    "unable to determine the workspace".

    I initially had both paths covered in a single workspace. Then I created separate workspaces for each team project (cleaner anyway) but still get the same results. Any idea as to what I'm overlooking? Any help would be greatly appreciated.
    Wednesday, February 03, 2010 7:44 PM

Answers

  • Whats the working directory from which you are running tfpt?  You need to "cd" to a local path that is mapped to the target workspace.  To ensure that the current working directory is mapped, you can run "tf workspace" and see if the target folders are mapped.

    If that does not work you may have to try mapping the TeamProject1 in the same workspace (I don't know how tfpt unshelve /migrate is implemented internally)
    Wednesday, February 03, 2010 8:51 PM
    Moderator