none
Installing .. advpack.dll RRS feed

  • Question

  • Not sure if this is where to put this question but I can't find anything else on these forums (shrug?). I'm trying to install the 2.0 redistribution package and get an error with c:\windows\system32\advpack.dll when trying to install. Any suggestions?

    The reason I'm looking to install it is because I have an application that requires it. Maybe I actually need something different? Ugh. lol
    Thursday, October 20, 2005 6:24 AM

Answers

All replies

  • Has anyone giving an answer for this question yet...I also have this problem..I'm trying to install the 64-bit version of Microsoft .NET Framework 2.0. I get error

    error creating process
    <C:\DOCUME~1\Home\LOCALS~1\Temp\IXP001.TMP\Install.exe>. Reason:
    C:\WINDOWS\system32\advpack.dll

    Any suggestions....Thanx.
    Sunday, October 30, 2005 2:37 AM
  • What Operating System are you trying to install to?  Is it a 32 bit OS or a 64 bit OS?

    Thanks,
    Tuesday, November 8, 2005 12:05 AM
    Moderator
  • I also have this problem, though I have a 32-bit system
    • Proposed as answer by Mark Hawk Tuesday, January 12, 2010 2:31 PM
    Saturday, November 12, 2005 1:58 AM
  • I am also having the same error when trying to install the 64-bit version of Microsoft .NET Framework 2.0. I am usiing 64-bit Windows. Any resolutions or suggestions?
    Sunday, November 13, 2005 5:12 AM
  • carzylady,

    Can you try the following:

    Save the .NET Framework setup on your local drive
    Extract the package by executing the following:
    run the following command with the EXE that was extracted
    dotnetfx.exe /c

    You will be prompted, and go ahead and enter a path to extract the files.
    such as c:\dotnetfx

    Then go that that location and launch install.exe

    Let me know at what point you see failures.

    Thanks,
    Monday, November 14, 2005 10:45 PM
    Moderator
  • awong,

    Can you try the instruction above provided to crazylady?  The package name for 64 bit will be NetFx64.exe.  Download it and run it with the /c command to extract it.

    Are you using an AMD64 or Intel64 machine?

    Thanks,

    Monday, November 14, 2005 10:49 PM
    Moderator
  • Please help,

    RobF did what u told me i ran:

    "netfx64.exe/c" as an argument to the 'install' file,

    I get the install.exe is not a valid Win32 application.

    Can you help me
    Sunday, November 20, 2005 11:45 PM
  • mine is an AMD 64 machine running Windows XP 32-bit
    Sunday, November 20, 2005 11:50 PM
  • Since you are running the 32 bit OS, you will need the 32 bit .Net Framework redistributable.

    Please install from

    http://www.microsoft.com/downloads/details.aspx?familyid=0856EACB-4362-4B0D-8EDD-AAB15C5E04F5&displaylang=en

    Thanks,
    Robert
    Monday, December 5, 2005 7:00 PM
    Moderator
  • solution:

    in the environment variables change both the TEMP and the TMP from the x:\documents and Settings\user\...

    To c:\Temp or any other folder.

    for me it works...

    greetz
    • Proposed as answer by Mentalchains Saturday, February 10, 2018 6:20 PM
    • Unproposed as answer by Mentalchains Saturday, February 10, 2018 6:21 PM
    Wednesday, December 14, 2005 12:24 PM
  • Hello,

    Might be a silly question, but... NTFS is what type of OS?? I still get eh same problem when trying to install the x64 version and gthe link you provide is x86.  Neither of these work, I get an error saying I need a higher version of .NET when I use the x86.  Any help would be appreciated.

     

    Thank you

    Monday, January 2, 2006 4:03 PM
  • Thank you so much, it worked after I extracted  the files!
    Friday, March 3, 2006 9:32 PM
  • 1. Remove advpack.dll (use Unlocker if it says the file is in use)

    2. Place the advpack.dll from here in the spot of the old advpack.dll which you have just removed.
    Sunday, March 12, 2006 3:27 PM
  • The reason I'm looking to install it is because I have an application that requires it. Maybe I actually need something different? Ugh. lol
    Monday, May 29, 2006 10:02 AM
  • Would this fix apply to the following error message:
    Error creating process <C:\DOCUME~1\jsmith\Local Settings\Temp\IXP000.TMP\Bootstrapper_en_us.exe
    Reason: C:\WINDOWS\System32\advpack.dll

    Thank you
    Saturday, June 10, 2006 12:39 AM
  • Did you install the windows xp 64 bit version or the windows 32 bit version?

    If your trying to install a 64bit driver on 32 bit win xp you will get this message.

     

    Solution: If your running on a 64 bit processor, install the 64 bit windows xp.

    Saturday, June 10, 2006 7:50 AM
  •  TheAmiMan wrote:
    solution:

    in the environment variables change both the TEMP and the TMP from the x:\documents and Settings\user\...

    To c:\Temp or any other folder.

    for me it works...

    greetz

    I now receive

    "Error creating process <C:\TMP\IXP000.TMP\Install.exe>. 

    Reason: C:\Windows\system32\advpack.dll"

    Any ideas?

    Thursday, June 22, 2006 1:46 PM
  • I still receive the error.

    Error creating process <C:\Tmp\IXP000.TMP\Install.exe>.  Reason: C:\Windows\system32\advpack.dll

    Any other suggestions would be greatly appreciated!

    CMS

     

    Thursday, June 22, 2006 2:03 PM
  • I have been all over the net trying to find a way to reinstall Net Framework 2.0 because I stupidly tried to install it before installing the redistributable pack.  They keep telling me to delete advpack.dll and then try to reinstall Net Framework 2.0.  I have had prior experience with dll's and it was messy.  I don't want to delete a dll unless I have to.  Is it safe to delete this dll?  And can it be safely reinstalled once I have deleted it?  I would really like to know.  Will Internet Explorer 7 automatically include Net Framework 2.0?  And if it does will it fix my mistake?  Please let me know.  By the way, my operating system is Win XP Pro. service pack 2 with 32 bit P4 processor.
    Thursday, June 22, 2006 8:27 PM
  • how do you know what bit your OS is?
    Saturday, July 22, 2006 11:50 PM
  • I had the same problem described in prior posts on this thread:

    Error creating process <C:\DOCUME~1\jsmith\Local Settings\Temp\IXP000.TMP\install.exe
    Reason: C:\WINDOWS\System32\advpack.dll

    I got around it with the trick described in a later post (netffx64.exe /c), but when I tried to run the install exe, nothing happened; the msi file ran, but gave an error message about being incompatible with my machine. I have Windows XP service pack 1 (when I tried to install
    service pack 2, I got stuck in a loop on reboot [boot up partway, shut down, boot up partway, etc.]) and had to remove it) with an AMD Athlon 64 p646 bit processor, which should be compatible with netfix64.exe . any ideas?
    Thursday, August 3, 2006 6:32 PM
  • How can I tell if i have the 32 or 64 bit OS, because I too cannot install the Microsoft.Net Framework.   I looked at the computer properties, but it just says XP Professional.

    Thanks

    Monday, August 7, 2006 4:14 PM
  • From command line I entered:

    C:\Documents and Settings\All Users\Documents>netFx64.exe /c

    Asked for location .... using the browser I directed installer to the .net folder.

    The install completed without error.

    • Proposed as answer by joshua20089 Sunday, August 24, 2008 3:34 AM
    Monday, August 28, 2006 8:55 PM
  • I took the deep plunge.  I repaired my Windows.  Needless to say that when I tried to reinstall Net Framework 2 SDK it still didn't work.  It gave me the same error.  Microsoft has no better suggestions.  I guess I will have to buy a new hard drive and start all over again.  Or I guess I will wait until Windows Vista comes out.  This is so aggravating.
    Monday, August 28, 2006 11:08 PM
  • Thanks Alot!!!  Followed the easy steps of entering command in command mode...and worked with no hassel!
    • Proposed as answer by locatedBanned Monday, June 14, 2010 9:47 PM
    Tuesday, January 23, 2007 7:27 AM
  • I built a new computer and this time I installed the software in the right order.  And guess what?  I got the same error.  I'm going to buy a copy of Windows Vista.  I only wish someone knew what was going on with the Rich Text Box.  The Rich Text Box of Visual Basic 6 ceased working and I need it for one of my projects.  I haven't found any solution yet.  Any Ideas?
    • Proposed as answer by locatedBanned Monday, June 14, 2010 9:47 PM
    Thursday, January 25, 2007 6:04 AM
  • Hi,

              I am using windows server 2003.

               Using NetFx64.exe /c command I have extracted the files.

              When I click on 'install.exe' I am getting  the following error eventhough I have logged in as the 'administrator'. 

     'windows cannot access the specified device,path,or file. you may not have the appropriate permissions to access the item.'

    Please help.

    Thanks and Regards,

     

    Wednesday, January 31, 2007 8:50 AM
  • it is 32 bit os

     

    Thursday, February 22, 2007 3:44 AM
  • how do i get this program to download on my system, for i require advpack.dll in order for me to complete the program to run properly, so where do i find it?
    Thursday, June 14, 2007 3:42 PM
  • Sorry, I dont really understand all of that.

     

    I've got a 32 bit thingumujiggy.

     

    I've downloaded the net framework and saved it but thats where my understanding ends

    Saturday, July 7, 2007 9:47 PM
  • When i analyzed i found out that i was trying to install 64 bit framework on 32 bit machine. Installed x86 setup instead of x64, worked fine for me.
    Tuesday, July 10, 2007 1:04 PM
  •  Robert Schmidt wrote:

    From command line I entered:

    C:\Documents and Settings\All Users\Documents>netFx64.exe /c

    Asked for location .... using the browser I directed installer to the .net folder.

    The install completed without error.

     

    This didn't solve my problem. Any other helpful suggestions?

     

     

    Saturday, November 3, 2007 5:16 AM
  •  

    How did you find out whether your PC was a 64 bit or 32 bit?  No one has answered that question yet! Thanks.
    Monday, November 26, 2007 4:00 AM
  • Here's how to tell if you're running a 32 or 64 bit PC:

     

    http://support.microsoft.com/kb/827218

    Monday, November 26, 2007 4:12 AM
  • I am running Vista.  I have exactly the same problems as all the people in this thread - and I can't run the program with the /c parameter (not even sure how to do it within Vista, it won't run from the command prompt even though I am trying it from the directory where the program is installed).

     

    I have downloaded the dll from the link provided - I checked and there is actually one in the correct directory and it is 122kb (it came installed with the machine) and the new one I've just downloaded is 98kb. However, even though I am the Administrator, Vista just WON'T LET ME put the new one in the \system32 directory!!!!!! Nor will it let me delete or rename the old one!

     

    This is sooooo frustrating.

     

    Help!

     

     

     

     

     

    Wednesday, November 28, 2007 1:32 PM
  • I am having the same block occuring to me I tried the crazy lady thing and I still get the same message. I am using windows XP on a pc emmulator on my Mac. I do not have the .net 2.0 framework or earlier additions on the c drive oranywhere and I can not get it to install.

     

    Friday, December 14, 2007 12:15 AM
  • As my colleague found, here is what is causing it.

    Sometimes the installer cannot write into your user's %TEMP% directory.

     

    So, what you need to do is to create, for example, a temp directory "C:\Temp\" on your C drive and then change the value of the %TEMP% environment variable to this directory path. After that you can run the installer and everything should be fine. At least it was for me.

    • Proposed as answer by inayaarime Wednesday, May 26, 2010 12:40 AM
    Friday, February 29, 2008 6:47 PM
  • THANK YOU THANK YOU THANK YOU

     

    I spent all afternoon on this - yours was the first post anywhere that a dope like me could actually use.

     

    Tuesday, May 6, 2008 8:55 PM
  • You Rock! I couldn't install service pack 3 for Office 2003 but this worked!
    Sunday, December 13, 2009 11:24 PM
  • kinda frustating....I'm so sorry about everything. I was trying to put some of my update files in an archive state so to speak and i ended up deleting them instead 
    Saturday, February 6, 2010 4:49 PM
  • As others already suggested, I first extracted a set of .NET 2.0 SDK installation files from the "setup.exe".

    step 1. Open a command prompt.

    step 2. Go to the folder where you have downloaded the "setup.exe".

    step 3. Type setup.exe /c. It will ask you where to extract.

    step 4. Create a temporary folder and specify it. The installation package will be extracted there.

    step 5. Open the temporary folder by Windows Explorer. Double-click "install.exe" there.

    These steps gave me successful result. Hope it work for you, too.

    • Proposed as answer by locatedBanned Monday, June 14, 2010 9:46 PM
    Tuesday, April 6, 2010 6:50 AM
  • Ok, now i notice the 64 bit system seems required to for most of this, so lets look at an overview type question.

    I am building (mostly on a 32 bit machine) for a 64 bit machine.  In a particular instance i need to make a full 64 bit .net assembly. Since the redistributable package will not run on the 32 bit machine, i am guessing i need to move to a 64 bit to complete this process for the instance? It would seem to me that since code is being handled, you code write code that would not run on the local machine, but wouldn't be the first time i was wrong.

    It seems the goal is the thing to notice over the immediate issue.

    • Proposed as answer by Katnipkitkat Sunday, June 27, 2010 11:39 AM
    Monday, May 10, 2010 9:39 PM
  • Oops, didn't mean to propose an existing message as an answer, I meant to say I found an answer.  This seems to be an old problem, but for those of us that cannot afford to keep up with technology and are still running windows 2000 on older machines it still happens, happened to me today when trying to install Directx 9.  Searched all over the place for a solution but couldn't find one that worked.  Had an idea, search for a much older version of Directx 9 which I needed to fix the error I was getting on another program I wanted to install.  I found the file "directx_aug2008_redist" on the microsoft site, downloaded it, installed it, and my error creating process <C:/DOCUME~1/UserName/LOCALS~1/Temp/IXP000.TMP/dxwsetup.exe> error went away.  Another thing I discovered was the if you go to your temp directory while the error is on the screen before you hit ok you will see that the directory was created and the files were copied to it and dxwsetup.exe is there. If you try to then run dxwsetup.exe from the temp directory you get an error that says (my OS is in Japanese and I can't read all the kanji) something along the lines of it not being a win32 application (which was what prompted me to search for an older version 9).
    Sunday, June 27, 2010 12:06 PM
  • Thanks! that worked for me! I changed it to the "A:\" drive.
    Saturday, February 10, 2018 6:19 PM
  • If you do not know how to change environment variables here is a link that shows you how.

    https://www.java.com/en/download/help/path.xml

    Saturday, February 10, 2018 6:21 PM