none
Blazor : Error MSB3073 on an old or new project RRS feed

  • Question

  • Hello, I just updated the Microsoft.AspNetCore.Blazor.* packages (v3.1.0-preview1.19508.20) and when compiling a project I have this error :

    Erreur MSB3073 La commande "dotnet "C:\Users\chris\.nuget\packages\microsoft.aspnetcore.blazor.build\3.1.0-preview1.19508.20\targets\../tools/Microsoft.AspNetCore.Blazor.Build.dll" write-boot-json "obj\Debug\netstandard2.0\BlazorApp2.dll" --references "D:\VSO\BlazorApp2\BlazorApp2\obj\Debug\netstandard2.0\blazor\bootjson-references.txt" --embedded-resources "D:\VSO\BlazorApp2\BlazorApp2\obj\Debug\netstandard2.0\blazor\embedded.resources.txt" --linker-enabled --output "D:\VSO\BlazorApp2\BlazorApp2\obj\Debug\netstandard2.0\blazor\blazor.boot.json"" s'est arrêtée avec le code -2147450730. C:\Users\chris\.nuget\packages\microsoft.aspnetcore.blazor.build\3.1.0-preview1.19508.20\targets\Blazor.MonoRuntime.targets BlazorApp2 635


    If I open this file Blazor.MonoRuntime.targets, at the end : 

        <WriteLinesToFile
          Condition="'@(_UnlinkedAppReferencesPaths)' != ''"
          File="$(BlazorEmbeddedResourcesConfigFilePath)"
          Lines="@(_UnlinkedAppReferencesPaths)"
          Overwrite="true" />
    
        <Exec Command="$(BlazorBuildExe) write-boot-json &quot;@(IntermediateAssembly)&quot; $(_ReferencesArg) $(_EmbeddedResourcesArg) $(_LinkerEnabledFlag) --output &quot;$(BlazorBootJsonIntermediateOutputPath)&quot;" />
    
        <ItemGroup Condition="Exists('$(BlazorBootJsonIntermediateOutputPath)')">
          <_BlazorBootJson Include="$(BlazorBootJsonIntermediateOutputPath)" />
          <_BlazorBootJsonEmbeddedContentFile Include="$(BlazorBootJsonIntermediateOutputDir)_content\**\*.*" />
          <BlazorItemOutput Include="@(_BlazorBootJson)">
            <TargetOutputPath>$(TargetDir)$(BlazorBootJsonOutputPath)</TargetOutputPath>
            <Type>BootJson</Type>
          </BlazorItemOutput>
          <BlazorItemOutput Include="@(_BlazorBootJsonEmbeddedContentFile)">
            <TargetOutputPath>$(TargetDir)dist/_content/%(RecursiveDir)%(FileName)%(Extension)</TargetOutputPath>
          </BlazorItemOutput>
          <FileWrites Include="$(BlazorBootJsonIntermediateOutputPath)" />
          <FileWrites Include="@(_BlazorBootJsonEmbeddedContentFile)" />
        </ItemGroup>
    
      </Target>
    
    </Project>

    Anyone have any idea what the problem is? Thanks,Christophe


    Christophe Peugnet
    http://www.peug.net
    sodeasoft.com



    Wednesday, October 16, 2019 6:15 AM

Answers

All replies

  • Hi!,

    the installation of version version 16.4.0 Preview 2 solved the problem!


    Christophe Peugnet
    http://www.peug.net
    sodeasoft.com

    Thursday, October 17, 2019 5:39 AM
  • Hi Christophe,

    Welcome to the MSDN forum.

    Glad to hear that your issue solved and congratulations to you.

    Accrording to your description, the nuget package is version v3.1.0 and when the package works, it need the related Runtime package since the lower version is not compatible with the higher version . So you should install the latest version .Net Core 3.1 SDK

    However, as far as l know ,the nuget package and SDK are both preview and latest version. So I'm thinking that the vs version is required and maybe the current vs version is not available. It is from this point that I found this blog.

    >>Visual Studio 16.4 Preview 2 and is also releasing today. It is a release to use.NET Core 3.1 Preview 1. So just updating Visual Studio will give you both releases.

    So, install the VS 16.4 preview is necessary as the blog said.This also verifies your answer.

    >> Since you have solved this issue, we suggest that you can mark it as answer so that it will help other community members search and handle similar issues.

    Thanks for your understanding.

    Best Regards,

    Perry


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, October 17, 2019 8:12 AM