locked
TF30177: Team Project Creation Failed RRS feed

  • General discussion

  • I tried with the default collection, and with a test collection; same setup, same result both times. I can forward a log if necessary.

    I configure with the MSF for Agile workflow, Git for Source Control, and I get the following exception when Git is setting up.

    Is there something else we need to install on the server and/or Team Explorer in order for this to work properly?

    Error
    TF30170: The plugin Microsoft.ProjectCreationWizard.TestManagement failed during task TestResolutionState from group TestManagement.
    Explanation
    Plugin error text: “System.MissingFieldException: Field not found: 'Microsoft.TeamFoundation.TestManagement.Common.WitCategoryRefName.SharedDataSet'. at Microsoft.TeamFoundation.TestManagement.Client.TestManagementTeamProject.get_SharedParameterDataSetWorkItemTypeName() at Microsoft.TeamFoundation.TestManagement.Client.TestManagementTeamProject.get_HasSupportForSharedParameterDataSets() at Microsoft.TeamFoundation.TestManagement.Client.TestManagementTeamProject..ctor(TestManagementService manager, String projectName) at Microsoft.TeamFoundation.TestManagement.Client.TestManagementService.b__0(String name) at Microsoft.TeamFoundation.TestManagement.Client.ObjectCache`2.Get(Key key, Creator creator) at Microsoft.TeamFoundation.TestManagement.Client.TestManagementService.GetTeamProject(String projectName) at Microsoft.TeamFoundation.TestManagement.PcwPlugin.ContextWrapper.get_Project() at Microsoft.TeamFoundation.TestManagement.PcwPlugin.PcwPluginComponentCreator.SetPermissionsIfNeeded(ContextWrapper wrapper) at Microsoft.TeamFoundation.TestManagement.PcwPlugin.PcwPluginComponentCreator.Parse(ContextWrapper wrapper, XmlNode taskXml, Boolean fExecute)”
    User Action
    Contact your Team Foundation Server administrator.


    • Edited by mwpowellhtx Monday, April 21, 2014 12:25 AM
    • Changed type mwpowellhtx Monday, April 21, 2014 12:50 AM I need prompt feedback on this please
    Sunday, April 20, 2014 11:31 PM

All replies

  • As an experiment, I tried adding a Team Project with TFVC for SC. Same exception.

    I am interested in running with Git, not TFVS.

    For installation, I installed on a fresh Windows Server 2012 R2 VirtualBox VM, SQL Server 2012 Standard, TFS 2013 Update 2, etc, etc.

    Would like to run with VS2012 Update 4. Trying to configure Team Project(s) via Team Explorer 2013.

    Open to suggestions.

    Monday, April 21, 2014 12:49 AM
  • Hi Mwpowellhtx,  

    Thanks for your post.

    To create TFS 2013 team project, you must using VS 2013 Team Explorer to create it.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, April 21, 2014 2:53 AM
    Moderator
  • I did use Team Explorer 2013. This was the error I got out of the box. In my estimation with bugs like this, it's a non starter to adopt TFS 2013 at any level.

    • Edited by mwpowellhtx Monday, April 21, 2014 12:21 PM
    Monday, April 21, 2014 12:20 PM
  • Hi Mwpowellhtx, 

    I was also getting the same error while creating Team Project. Some how after lots of googling I found one useful link. This will resolve your error.

    1. Close all instances on Visual Studio and Microsoft Test Manager
    2. Open Visual Studio command prompt in admin mode.
    3. Perform the following steps:

    ngen uninstall Microsoft.TeamFoundation.TestManagement.Client
    ngen uninstall Microsoft.TeamFoundation.TestManagement.Common

    If still the issue is not fixed, do the following:

    1. Open admin command prompt.
    2. Navigate to <System_Drive>:\Windows\Assembly\NativeImages_v4.0.30319_32
    3. dir /s Microsoft.TeamFoundation.TestManagement.Client.ni.dll
    4. Delete all instances of this native image dll (del /s Microsoft.TeamFoundation.TestManagement.Client.ni.dll)
    5. dir /s Microsoft.TeamFoundation.TestManagement.Common.ni.dll
    6. Delete all instances of this native image dll (del /s Microsoft.TeamFoundation.TestManagement.Common.ni.dll)

    The problem should get fixed. 

    Link: https://connect.microsoft.com/VisualStudio/feedback/details/850264/tf30162-task-testresolutionstate-from-group-testmanagement-failed

    Regards,

    - Manoj



    Monday, April 21, 2014 2:14 PM
  • Manoj ... that's work

    1. Close all instances on Visual Studio and Microsoft Test Manager
    2. Open Visual Studio command prompt in admin mode.
    3. Perform the following steps:

    %Windir%\Microsoft.NET\Framework\v4.0.30319\ngen.exe uninstall Microsoft.TeamFoundation.TestManagement.Client
    %Windir%\Microsoft.NET\Framework64\v4.0.30319\ngen.exe uninstall Microsoft.TeamFoundation.TestManagement.Common

    Try to create again and voila!!!

    Thanks!!!


    • Edited by Denis Paiva Tuesday, April 22, 2014 10:39 AM
    Tuesday, April 22, 2014 10:38 AM
  • You are "DA MAN". I have been searching for a solution to this all day .............. THANK YOU.

    I had to do both steps but it worked.

    BTW can you tell me what is so special about the NativeImages_v4.0.30319_32 directory?


    robi singh

    Thursday, June 5, 2014 7:01 PM