none
Lightswitch and TFS preview build servers with Azure RRS feed

  • Question

  • Is there any support to use the buildserver in TFSpreview with lightswitch projects running in Windows Azure (on websites or cloudservices)? I have tried but the buildserver has problems to deploy the solution to Azure.

    With deploying to a azure website service via tfspreview build server I get this error:

    C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Web\Microsoft.Web.Publishing.targets (4007): Web deployment task failed. (Object of type 'manifest' and path 'C:\a\bin\_PublishedWebsites\Server_Package\Server.SourceManifest.xml' cannot be created.)
    
    Object of type 'manifest' and path 'C:\a\bin\_PublishedWebsites\Server_Package\Server.SourceManifest.xml' cannot be created.
    One or more entries in the manifest 'sitemanifest' are not valid.
    Could not find file 'C:\a\src\24 uurs race Brandaen\Brandaen.24uursrace\Brandaen 24 uursrace Digitaal\Server\obj\Debug\Package\PackageTmp'.  Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#RemoteAppNotFound.
    Could not find a part of the path '\\?\C:\a\src\24 uurs race Brandaen\Brandaen.24uursrace\Brandaen 24 uursrace Digitaal\Server\obj\Debug\Package\PackageTmp'.

    With deploying to a azure cloud service via tfspreview build server I get this error:

    Exception Message: There was no Windows Azure project (.ccproj) detected in the solution. Continuous delivery to an Azure Cloud Service requires an Azure project. (type CCProjNotFoundException)Exception Stack Trace:    at System.Activities.Statements.Throw.Execute(CodeActivityContext context)   at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)   at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

    TF270003: Failed to copy. Ensure the source directory C:\a\bin exists and that you have the appropriate permission



    Wednesday, September 19, 2012 8:44 AM

All replies

  • Remco, have you had any success with this? I am looking to do the same thing.
    Thursday, November 1, 2012 1:38 PM
  • Same Problem here - no idea
    Thursday, December 27, 2012 6:41 PM
  • A while ago I had this problem, solved the problem by setting the profile to MSBuild.

    Example:

    c:\Windows\Microsoft.NET\Framework\v4.0.30319>MSBuild.exe "Projeto.csproj" /target:rebuild;publish /property:Configuration=Release;DeployOnBuild=true;PublishProfile="PublishProfiles\Release.pubxml"


    Gilson Joanelo - Desenvolvedor Web

    Monday, April 8, 2013 4:43 PM