locked
Source Control Explorer Doesn't View PDF Files

    Question

  • At our site the TFSVC Source Control Explorer is not mapping PDF files to Adobe Acrobat when attempting to view a PDF document stored in version control.  Upon attempt of a view a PDF an error dialog is displayed: "The line endings in the following file are not consistent...".  I have tried all options in this dialog and searched for settings elsewhere to configure PDF file types.  How can we fix this problem?
    Monday, December 19, 2005 9:40 PM

Answers

  • Hi hsiceo

     

    It's not possible to set this on version control level. But if you've got a PDF file in a project you can right-click in the solution explorer and choose "Open with..". Now you can choose which editor you want to use. If Acrobat isn't already listed you can add it and after that click the button "Set as default".
    After that, your PDF's will always open with Acrobat Reader regardless if you open it from source control browser or elsewhere in the Visual Studio. But you need to configure that for all your Studios.

     

    Is this helping you?

    Nicolas

     

    Wednesday, February 6, 2008 3:11 PM
  • Yuck.

    This is actually a Visual Studio issue (try dragging a PDF from explorer to VS and you'll get the same behavior). I'll talk to the team and see if we can possibly work around this, but it'll be dicey.

    If you view the file from the command line (tf view filename), you'll get the pdf open in Acrobat (or possibly a prompt to choose the viewer).

    Stay tuned...

    Tuesday, December 20, 2005 3:05 PM
    Moderator

All replies

  • Yuck.

    This is actually a Visual Studio issue (try dragging a PDF from explorer to VS and you'll get the same behavior). I'll talk to the team and see if we can possibly work around this, but it'll be dicey.

    If you view the file from the command line (tf view filename), you'll get the pdf open in Acrobat (or possibly a prompt to choose the viewer).

    Stay tuned...

    Tuesday, December 20, 2005 3:05 PM
    Moderator
  • Is there any new information about this issue ?
    Monday, February 12, 2007 12:51 PM
  • No - Microsoft is still waiting for Apple to go out of business.
    Monday, February 12, 2007 3:45 PM
  • Has there been any development on this issue yet?
    Thursday, April 26, 2007 6:13 PM
  • Don't hold your breath.
    Thursday, April 26, 2007 7:40 PM
  • Microsoft,

     

    When will this bug be fixed?

    Wednesday, February 6, 2008 1:31 PM
  • Hi hsiceo

     

    It's not possible to set this on version control level. But if you've got a PDF file in a project you can right-click in the solution explorer and choose "Open with..". Now you can choose which editor you want to use. If Acrobat isn't already listed you can add it and after that click the button "Set as default".
    After that, your PDF's will always open with Acrobat Reader regardless if you open it from source control browser or elsewhere in the Visual Studio. But you need to configure that for all your Studios.

     

    Is this helping you?

    Nicolas

     

    Wednesday, February 6, 2008 3:11 PM
  • Hello,

    the issue was opened 4 years ago - after googling for "open pdf from team explorer", it's the first hit here. And it's still open (?!) - it's pretty useless to get the hex dump of a file or to have to include it into a VS project when it does NOT belong there.

    Please, make it openable from the TeamExplorer right away, it's the only normal behaviour.

    Thank you,
    Andrej
    Monday, July 13, 2009 12:26 PM
  • I know this post is old, but...

    With the help of this article on PHKelley's blog (http://blogs.msdn.com/phkelley/archive/2009/02/12/adding-a-command-to-the-source-control-explorer-context-menu.aspx), I've created a file launcher add-in for the Source Control Explorer.  This allows you to right-click on a file and select "Lauch File in Host App" and view the file in the program currently associated with that file type.  You can download it at http://visualstudiogallery.msdn.microsoft.com/en-us/c3c902a5-0914-4f31-9576-51ef721ec73b.  Hope this helps.
    Friday, September 4, 2009 7:23 PM
  • Is there a version compatible with Visual Studio 2010?
    Wednesday, June 2, 2010 6:38 AM
  • Nicolas Mueggler's contribution from Feb 2008 solved the problem for me in VS2010. Thanks Nicolas!
    Friday, January 14, 2011 6:24 PM
  • I've rediscovered this same problem, but in this case using the Team Explorer plugin for Visual Studio 2013.  Since many members of our team are not programmers, they are only using the Team Explorer plugin to access Work Items and Versioned Items from Team Foundation Server.

    This means that the work-around indicated in 2008 (5 years ago, mind you!) WILL NOT WORK for us.  I've verified that the work-around works if you have full-blown Visual Studio - in which case you can use the Solution Explorer to access a PDF file to configure the 'Open With...' attribute.

    However, most of our team doesn't HAVE the Solution Explorer - so there is no way it can work!

    MICROSOFT: Can you please point me to the registry setting (almost certainly what it is, I'd guess) so we can patch this for our users?  This is a completely ridiculous bug to have around for so long - the least you can do is supply some kind of patch for it.

    Wednesday, January 29, 2014 12:33 AM
  • I am trying to view a PDF as well in TFS 2012 and I am getting the same message as Nicholas.  I followed the instructions to right-click on the PDF and "Open with".  The problem is that the menu does not have an "Open with" option.  I only have a "View" option which opens the HEX.  Microsoft's online and offline help does not offer a solution for this issue and one is needed.  (I am not a programmer.) Thanks!
    Wednesday, July 16, 2014 1:35 PM
  • @GSR-STC

    1. Step: Make a new Project (WPF Project)

    2. Step: Copy the PDF-File in the File Location from the WPF project.

    3. Step: Add the PDF-File to your project.

    4. Step: Right Click --> Open With

    5. Step: Chosse Adobe Reader xxx

    6. Step: Set als default

    For me this works then also in TFS Explorer.

    Thursday, September 3, 2015 12:31 PM