none
Reading .NET 4.0 dump files in WinDBG RRS feed

  • Question

  • I'm familiar with the WinDBG paradigm. Been reviewing a lot of dump files using WinDBG x64 version. For the most part dump files were  .NET 2.0 applications and psscor2.dll. Current WinDBG version I am using is 6.12.0002.633. Recently, I've been trying to open x64 dump IIS dump files generated from a .NET 4.0 application pool using psscor4.dll. Any command I run returns, "Failed to request <Command> information"

    1. I've mscordacwks.dll from c:\Windows\Microsoft.NET\Framework64\v4.0.30319 on the server
    2. Renamed to mscordackwks_AMD64_AMD64_4.0.30319.xxxx.dll. xxxx matches the compiled version in the file
    3. Open WinDBG, open the dump file and add the path to the above DLL to exepath
    4. Run a basic command !eeversion to check all is fine and I get GC Heap not initialized, so GC mode is not determined yet.
      In plan phase of garbage collection
    5. Next I type !threads and get, Failed to request ThreadStore
    6. Next !threadpool and I get, Failed to request ThreadpoolMgr information

    I done some basic google search with these error messages and they all point to not having the correct mscordacwks.dll or opening x86 files in WinDBG x64 or x64 files in WinDBG x86. Didn't sound relevant to me

    Any help/guidance is much appreciated

    Saturday, August 31, 2013 4:19 PM

All replies

  • Hi G33kkahuna,

    Welcome to MSDN forum.

    I think this thread is specific to WinDbg. This form is  to discuss problems about CLR development. So I am helping you to move this thread directly into WinDbg forum.

    If you have any concerns, please don’t hesitate to let me know. I will be glad to help you again.

    Best Regards,


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, September 2, 2013 8:53 AM
  • Could it be, psscor4 does not succeed, because CLR Version is too recent?  

    0:000> !eeversion
    4.0.30319.18047 retail
    GC Heap not initialized, so GC mode is not determined yet.
    In plan phase of garbage collection
    SOS Version: 4.0.0.4 retail build
    0:000> !threads
    Failed to request ThreadStore
    0:000> !threadpool
    Failed to request ThreadpoolMgr information

    Have you tried loading sos.dll matching your mscordacwks, clr.dll?

    With kind regards


    Monday, September 2, 2013 10:44 AM