none
Ordered Test not executing all tests completely RRS feed

  • Question

  • I have 16 ordered tests which has about 1 to 21 testcases in each.

    When i had consolidated the 16 ordered tests in 1 ordered test out of 169 tests cases only 65 are running and rest are not executed. May i know what could be the reason.

    Friday, October 20, 2017 10:18 AM

Answers

  • Thanks for your reply. The time out for the ordered test was set 30 mins due to which its stopping executing after 30 mins. I have changed it to 6hrs. Thanks for your help.
    Monday, October 23, 2017 5:01 AM

All replies

  • Hi Hepsiba Pedada,

    According to your description, there are 16 ordered tests and you put them into one ordered test, is it right?

    What's type of the tests in your ordered tests? Are they have any relationship between each other? For example, if there has log in and log out test in your tests. When if you have logged out and then execute other tests which used the log in session, the test will fail.

    So I suggest you re-order your tests order in Ordered Test with following steps.

    1. Run Ordered Test 1 and Ordered Test 2 to make sure they could run successful standalone.
    2. Add these two Ordered Tests into One Ordered Test and run this Ordered Test to check whether it could run successful.
    3. If it failed, please check the tests order in Ordered Test 1 and Ordered Test 2. Adjust them to make them could be run successful.
    4. If it successful, please add another Ordered Test and repeat to step 2 to step 4 again.

    Best Regards,
    Weiwei


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, October 23, 2017 2:26 AM
    Moderator
  • Thanks for your reply. The time out for the ordered test was set 30 mins due to which its stopping executing after 30 mins. I have changed it to 6hrs. Thanks for your help.
    Monday, October 23, 2017 5:01 AM