locked
Visual Studio 2013 - Build Tools x86 - Fatal error during installation [Resolved] RRS feed

  • General discussion

  • I had troubles installing vs 2013 and found a solution. I want to share in case it will be helpful to someone. I didn't find a question with the same symptoms.

    Symptoms:

    Installation finishes with an error

    "Setup Failed!

    bla-bla-bla ... or examine the log file. 

    - Build Tools - x86

        Fatal error during installation"

    in the log file :

    [0368:19D8][2014-05-19T09:57:03]i301: Applying execute package: Msi_BuildTools_MSBuild_x86, action: Install, path: C:\ProgramData\Package Cache\{FB3A15FD-FC67-3A2F-892B-6890B0C56EA9}v12.0.21005\packages\BuildTools_MSBuild_x86\BuildTools_MSBuild.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7"'
    
    ......
    
    [0368:19D8][2014-05-19T09:57:18]e000: Error 0x80070643: Failed to install MSI package.
    [0368:19D8][2014-05-19T09:57:18]e000: Error 0x80070643: Failed to execute MSI package.
    [17F0:1348][2014-05-19T09:57:18]e000: Error 0x80070643: Failed to configure per-machine MSI package.

    How it was resolved:

    I tried several times to install (after installing all windows updates etc), and somehow by luck after closing the installation window I've got the window (Sorry, I can't insert images until MS will be able to verify my account. Such a stupid thing...) "Do you want to send more information about the problem?" and a list of files to send.

    Unfortunately I don't know what I did that made this window to appear. I tried several times later to reproduce but installation ended up with a different window with only a close button without any info about log files.

    But I found that the installer creates these files every time (even when the info about them is not shown) in 'C:\Users\{yourUserName}\AppData\Local\Temp'
    you can find the files by just sorting by 'date modified'. In my case the files were:

    C:\Users\{username}\AppData\Local\Temp\dd_vs_ultimate_20140519092642.log  
    C:\Users\{username}\AppData\Local\Temp\dd_vs_ultimate_20140519092642_143_vs_preclean_vs.log  
    C:\Users\{username}\AppData\Local\Temp\dd_vs_ultimate_20140519092642_147_Msi_BuildTools_MSBuild_x86.log  
    C:\Windows\Logs\CBS\CBS.log

    The file that was really helpful is dd_vs_ultimate_20140519092642_147_Msi_BuildTools_MSBuild_x86.log 
    I searched for "error" in it and found:

    05/19/14 09:28:53 DDSet_Error: Failed to create process (0x00000570) : The file or directory is corrupted and unreadable.  
    05/19/14 09:28:53 DDSet_CARetVal: 00000570:(null) 
    05/19/14 09:28:53 DDSet_CARetVal: 80070570:Failed to run '"C:\Windows\Microsoft.NET\Framework\v4.0.30319\ngen.exe

    I tried to run the ngen.exe by hands and it didn't run saying 'the file or directory is corrupted and unreadable'

    I replaced the file with the one from my laptop and that did the trick.

    (optional) also I checked the file CBS.log. I searched for "corrupt" and found:
      2014-05-19 09:48:15, Info                  CSI    0000072f [SR] Could not reproject corrupted file [ml:520{260},l:98{49}]"\??\C:\Windows\Microsoft.NET\Framework\v4.0.30319"\[l:16{8}]"ngen.exe"; source file in store is also corrupted

    It confirmed that ngen.exe is corrupted. You can create CBS.log by running the command 'sfc /scannow' in the command promt cmd.exe. As I understand it should give a report about all corrupted files.


    Monday, May 19, 2014 7:44 AM

All replies

  • Hi Stanislav,

    Thank you for sharing your solutions & experience here. It will be very beneficial for other community members who have similar questions.

    And I will change the type of thread to discussion. let more people discuss the issue.

    Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HEREto participate the survey.

    Tuesday, May 20, 2014 2:56 AM
  • Our IT Support finds the issue and sloved it for me; There is Windows Security Patch casues Windows Installer failed. After remove KB2918614, I can re-install both Visual Studio 2012 and 2013.

    For VS2012 Pro error is Microsoft Visual C++ 2012 x64 Minumum Runtime - 11.0.507 Fatal error during installation.

    For VS2013 Pro error is Build Tools - amd64 Fatal error during installtion.

    Hope, this information applies to Windows 7 Pro x64 platform.

    Tuesday, September 2, 2014 10:12 PM
  • i decided using windows update. After the update, the visual studio installing normally.
    Friday, January 9, 2015 11:44 AM
  • I found this post as a result of similar errors during installation, and they went away when I ran the install "as Administrator", even though my Windows account was an Administrator account.
    Wednesday, March 25, 2015 10:52 PM
  • I got the same error updating from visual studio 2015 update 2 to update 3, and i had all windows updates installed. What i see is VS needs this file "Microsoft Build Tools 2015 Update 3" to run amd64 libraries. I download the file separately and installed didn't get any errors after opening visual studio, but i had to run a repair to reinstall VS update 3. Thats how i solved it.
    Monday, August 1, 2016 10:02 AM