none
Enabling word-wrap for the code window but not for Find results RRS feed

  • Question

  • Hello,

    I have recently upgraded to VS2013 Professional from VS2012. I think the following is a VS 2013 upgrade issue, but I am not certain.

    In VS 2012, I was able to set the code windows view to word wrap so that I would not need to scroll horizontally, but my search results in Find Results 1 and Find Results 2 would display on one line. I liked this set up.

    In VS 2013, I can not achieve the same results: either both code and find results have word wrap, or neither of them do.

    I’m sure that there must be a simple solution to this.

    Any help would be greatly appreciated!

    Many thanks in advance,

    Keith


    R K Howard

    Tuesday, January 14, 2014 12:23 PM

Answers

  • I did a bit more investigation and I have now solved it. I am not sure if this was a VS 2012 vs. VS 2013 issue, but it now works for me, and I hope that other people can benefit from this too.

    Take each following step to add the Toggle Word Wrap button to the toolbar:

    >Right click the tool bar at the top of the screen.

    >Click ‘Customise…’.

    >Select ‘Commands’ > ‘Toolbar’.

    >Choose the toolbar you want to add the option to. (I added it to ‘Text Editor’.)

    >Click ‘Add Command…’.

    >Select the ‘Edit’ category > ‘Toggle Word Wrap’.

    >Click ‘OK’.

    >Use the ‘Move Up’ and ‘Move Down’ buttons to place the new command where you would like it to appear on the toolbar.

    >Click ‘Close’.

    Then take each following step to word wrap code, but not find results:

    >Click ‘Tools’ > ‘Options’ > ‘Text Editor’ > ‘All Languages’

    >Uncheck ‘Word wrap’.

    >Click ‘OK’.

    >Click the newly added ‘Toggle Word Wrap’ button in the toolbar to toggle word wrap for code whilst leaving the find results non-wrapped (see the below image - please don't be too distracted by my lengthy naming conventions...). J

    Thanks,

    Keith


    R K Howard

    Wednesday, January 15, 2014 1:19 PM

All replies

  • Hi Keith,

    Could you share us the screen shot about the different result in VS2012 and VS2013?

    Generally we could set the word wrap under the option Tools->Options->Text Editor->All Languages->Word wrap.

    But I check it in VS2012 and VS2013, it seems that it has the same function like the VS2010 here, I mean that if we enable it, it would impact the code Edit window and Find results window. Maybe you could check it with the same app in your VS2012 and VS2013. It seems that just the width is different like the following screen shot.

    VS2012:

    VS2013:

    But we could make sure that the Word wrap worked in Find Results window of VS2012/VS2013 if we enable it. If I have misunderstood anything, please make free feel to let us know.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, January 15, 2014 5:54 AM
    Moderator
  • Hello,

    I can no longer produce the desired result, even in VS 2012. I think that that is because I have upgraded to VS 2013 and something has changed in the settings file, as a result. Again, previously, in VS 2012, I was able to word wrap the code pane whilst the Find Results did not word wrap. Now, both are either worded wrapped or not.

    I guess that that is a "feature" of VS 2013. I'll just drop this now.

    Thanks.

    Keith


    R K Howard

    Wednesday, January 15, 2014 11:21 AM
  • I did a bit more investigation and I have now solved it. I am not sure if this was a VS 2012 vs. VS 2013 issue, but it now works for me, and I hope that other people can benefit from this too.

    Take each following step to add the Toggle Word Wrap button to the toolbar:

    >Right click the tool bar at the top of the screen.

    >Click ‘Customise…’.

    >Select ‘Commands’ > ‘Toolbar’.

    >Choose the toolbar you want to add the option to. (I added it to ‘Text Editor’.)

    >Click ‘Add Command…’.

    >Select the ‘Edit’ category > ‘Toggle Word Wrap’.

    >Click ‘OK’.

    >Use the ‘Move Up’ and ‘Move Down’ buttons to place the new command where you would like it to appear on the toolbar.

    >Click ‘Close’.

    Then take each following step to word wrap code, but not find results:

    >Click ‘Tools’ > ‘Options’ > ‘Text Editor’ > ‘All Languages’

    >Uncheck ‘Word wrap’.

    >Click ‘OK’.

    >Click the newly added ‘Toggle Word Wrap’ button in the toolbar to toggle word wrap for code whilst leaving the find results non-wrapped (see the below image - please don't be too distracted by my lengthy naming conventions...). J

    Thanks,

    Keith


    R K Howard

    Wednesday, January 15, 2014 1:19 PM
  • Hi Keith,

    Glad to see this issue has been resolved and thank you for sharing your solutions here. It will be very beneficial for other community members who have similar questions.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, January 16, 2014 2:56 AM
    Moderator
  • Hi Jack,

    Any chance for me getting my VERY FIRST POINT!? :))

    I have asked numerous questions over the past couple of years, and I would like to start answering some, where I have the knowledge, as a bit of payback.

    Thanks.

    Keith


    R K Howard

    Thursday, January 16, 2014 11:15 AM