none
Unable to uninstall .Net Framework 4.7.1 RRS feed

  • Question

  • Hello,

    I am trying to set up a Sharepoint 2013, On-Premise Dev Environment on a Windows Server 2012 R2.

    Because there is no internet connectivity on the server, I installed the pre-requisites manually (offline). The sharepoint installation however fails stating that .Net Framework 4.5 is not installed. Upon digging I found that .Net Framework 4.7.1 is installed instead.

    I have done couple of things, but I have not been able to uninstall this version of .Net Framework. Below are the things I have tried -

    1. Uninstalled the below updates - 

    Update for Microsoft Windows (KB4054854)

    Update for Microsoft Windows (KB3186539)

    2. Ran the dotnetfx_cleanup_tool to remove .Net Framework 4.7.1.

    But my registry still shows that .Net Framework 4.7.1 is installed (Dword 461310)and I cant proceed any further.

    It will be very helpful if someone can point what I might be missing here. Or what I can do to uninstall this version of .Net Framework.

    Many Thanks!

    Monday, September 30, 2019 3:19 PM

All replies

  • Hi AmritaSengupta,

    Welcome to the MSDN forum.

    When you install the .NET Framework 4.7.1, in Windows Server 2012, Update for Microsoft Windows (KB4033345) is displayed under Installed Updates in Control Panel, so you can uninstall KB4033345 to remove the .NET Framework 4.7.1 and reboot the computer. For more detail information, please check this.

    However, since your OS is Windows Server 2012 R2 which is shipped with .NET Framework 4.5.1 per .NET Framework versions and dependencies, it means we cannot uninstall the .NET Framework 4.5.1 and .NET Framework 4.5.1 is an in-place update that replace .NET Framework 4.5 on your computer, I suppose you already have the .NET Framework 4.5 on your computer. Please download and use the .NET Framework setup verification toolto verify the .NET Framework 4.5 is existing or not. Alternatively, if you have VS versions like 2015/2017, open VS and create a new project, scan the available framework versions to check it.

    If you can find the installed .NET Framework 4.5 and the SharePoint installation cannot defect it, I would recommend you to seek for a better support from the SharePoint support forum, thanks for your understanding.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, October 1, 2019 1:51 AM
    Moderator