none
Developer Mode package failed to install RRS feed

  • Question

  • I get the following error when trying to set my device to developer mode:

    Developer Mode package failed to install. Error code 0x80004005 I tried everything on this forum - with no luck

    Monday, March 20, 2017 10:26 PM

Answers

  • Hi,

    Thank you for your update.

    Please launch regedit.exe and modify this key:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU
    • UseWUServer to 0 (to disable), restart

    After this, when you enable Developer mode from the For developers settings dialog, the error will gone.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by kevins69 Friday, March 24, 2017 1:29 PM
    Wednesday, March 22, 2017 8:58 AM
  • Hi kevins69,

    Welcome to MSDN forum.

    Please  have a look at the thread: https://social.msdn.microsoft.com/Forums/en-US/a7e94e5b-db19-492f-a1c1-d5fa3aa87d0d/enabling-developer-mode-fails-with-error-code-0x80004005?forum=Win10SDKToolsIssues

    To fix this.

    1. Open the Settings app.
    2. Click on “Apps & features”
    3. Choose “Manage Optional features”
    4. Press the button “Add a feature”
    5. Select the package for Windows Developer Mode
    6. Click “Install”
    7. Reboot your PC
    8. Launch Command Prompt as Administrator
    9. Run: sc config debugregsvc start=auto

    Finally, return to the “For Developers” Settings page. You will still see the error code, 0x80004005 but you should now be able to enable Windows Device Portal and the Device Discovery features.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by kevins69 Tuesday, March 21, 2017 1:23 PM
    Tuesday, March 21, 2017 6:51 AM

All replies

  • Hi kevins69,

    Welcome to MSDN forum.

    Please  have a look at the thread: https://social.msdn.microsoft.com/Forums/en-US/a7e94e5b-db19-492f-a1c1-d5fa3aa87d0d/enabling-developer-mode-fails-with-error-code-0x80004005?forum=Win10SDKToolsIssues

    To fix this.

    1. Open the Settings app.
    2. Click on “Apps & features”
    3. Choose “Manage Optional features”
    4. Press the button “Add a feature”
    5. Select the package for Windows Developer Mode
    6. Click “Install”
    7. Reboot your PC
    8. Launch Command Prompt as Administrator
    9. Run: sc config debugregsvc start=auto

    Finally, return to the “For Developers” Settings page. You will still see the error code, 0x80004005 but you should now be able to enable Windows Device Portal and the Device Discovery features.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by kevins69 Tuesday, March 21, 2017 1:23 PM
    Tuesday, March 21, 2017 6:51 AM
  • Thanks Joyce - but I did go through that thread and tried to do the steps. When I got to:

    step # 4. Press "Add Feature" there was no  package for Windows Developer Mode available.

    thanks

    Kevin

    Tuesday, March 21, 2017 1:15 PM
  • Hi,

    Thank you for your update.

    Please launch regedit.exe and modify this key:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU
    • UseWUServer to 0 (to disable), restart

    After this, when you enable Developer mode from the For developers settings dialog, the error will gone.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by kevins69 Friday, March 24, 2017 1:29 PM
    Wednesday, March 22, 2017 8:58 AM
  • I'm also having the same issue. Large enterprise customer.  None of the steps above work. There's no packages available in the Features section and setting the registry key on WUServer to 0 still doesn't do it. Is there a spot where you can download the package separately? If not I may just open a Premier case for this because I've so far tried everything else. This is on 1607 btw and it doesn't seem to happen on 1511.
    Thursday, March 23, 2017 11:32 PM
  • Hi Joyce,

    I'm having a similar problem like Alex has reported. I work for a large, state agency. I've found the registry key you gave to Kevins69. However, in my case it looks as though WUStatus points to what I presume is a WSUS server. I think that my IT group would not want me to replace the URL to the server with the value of 0.

    So I'm wondering how am I to proceed? Should I go to my supervisor and ask for permissions to be able to work on UWP apps? (I work on a development group so writing UWP apps for us would be something I can see us doing.) Or is replacing the URL with a 0 acceptable?


    Rod


    • Edited by Rod at Work Tuesday, March 28, 2017 4:59 PM grammatic correction
    Tuesday, March 28, 2017 4:45 PM
  • Hi Rod and Alex,

    Welcome to MSDN forum.

    I recommend you could post a new thread to describe your issue, because different environment may have different reasons to cause the issue. We will try to help you analyze and troubleshoot, thank you for understanding.

    Best regards,

    Joyce



    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 29, 2017 8:20 AM
  • Joyce,

    No, it's actually the same problem. The issue lies in the fact that the Developer Mode package isn't available on the WSUS server in managed enterprises. There's no feature available in Optional Features and when i set the UseWUServer to 0 it doesn't work either. I check Event Viewer Windows Update and the error says "0x8024002e - Access to an unmanaged server is not allowed." If your enterprise has that option set or has firewall rules enabled that block external WU then you are out of luck for that option.

    The answer to this is you need to either put the Developer Mode file onto the WSUS server at your enterprise (what we're eventually going to do at this customer) or you can download it separately, use DISM to service your Windows build online, restart, and it will be there.  Those instructions are as follows:

    1. Download the CAB file for the update at http://download.windowsupdate.com/c/msdownload/update/software/updt/2016/07/microsoft-onecore-developermode-desktop-package_433cce320961a4406bc787f5fcc4d2ac35d73b23.cab.  Don't extract the CAB.

    2. Launch CMD with administrator permissions

    3. Execute the following command: DISM.exe /Online /Add-Package /PackagePath:c:\pathtodownload\theabovefilename.cab.  Change the obvious things to where you stored and named the file.

    4. restart

    5. enable Developer Mode and you should no longer get an error.

    Knowing what I know now I doubt I'll file a Premier case or engage the PG about this because the software is behaving by design.

    Thanks,

    --Alex

    • Proposed as answer by Alex Bowman Wednesday, October 18, 2017 6:04 PM
    Wednesday, October 18, 2017 6:04 PM
  • sadly even the last suggestion did not help. Developer mode can be selected, but developer mode package fails to install.

    14393, Enterprise, test mode enabled.

    Friday, January 26, 2018 8:33 PM
  • Worked for me, thanks!

    C:\temp>DISM.exe /Online /Add-Package /PackagePath:c:\temp\developermode.cab

    Deployment Image Servicing and Management tool
    Version: 10.0.14393.0

    Image Version: 10.0.14393.2457

    Processing 1 of 1 - Adding package Microsoft-OneCore-DeveloperMode-Desktop-Package~31bf3856ad364e35~amd64~~10.0.14393.0
    [==========================100.0%==========================]
    The operation completed successfully.

    C:\temp>

    Thursday, February 7, 2019 7:07 PM