none
Graphics Tools refuses to install RRS feed

  • Question

  • Hi, I'm having an issue. I'm a game developer and am trying to use Visual Studio 2015 for the integrated graphics shader debugger. For some reason or another, I cannot install graphics tools for Visual Studio when selecting Debug->Graphics->Run Diagnostics.

    A page comes up saying: Graphics Tools failed to install. The DISM installer reported error 14081.

    When I tried to install it manually (as according the link provided), it fails there also. No error message comes up; it simply fails to install under optional features and apps. Other features can be installed (and uninstalled) from the menu, but Graphics Tools does not.


    Please help.

    Thursday, December 31, 2015 6:45 PM

All replies

  • This seemed to be a problem on my machine, not with VS in general. A fresh re-install of Windows somehow fixed the problem.
    • Edited by T_Lane Sunday, January 3, 2016 8:14 PM
    Friday, January 1, 2016 1:58 AM
  • Couple questions:

    1) Was your previous build of Windows one that has been part of the Windows Insider program?

    2) Is your machine on a domain?

    The reason I ask these questions is because we have had problems in the past installing graphics tools in these situations.


    Jim

    • Proposed as answer by Greazer Wednesday, January 6, 2016 5:23 PM
    Monday, January 4, 2016 10:07 PM
  • I ahev this issue as well, machine has never been part of the insider program or been on a domain. This is a windows Home install with VS 2012 - 2015 on it.
    Monday, January 11, 2016 8:31 PM
  • Are you getting the same DISM error code as the original poster?

    When you say it's a Windows Home install, I assume you're running Windows 10, with the latest update? The version should be Version 1511 (OS Build 10586.29). You can see this by typing Win+R, then running "winver".


    Jim

    Tuesday, January 12, 2016 7:05 PM
  • 14081 is ERROR_SXS_ASSEMBLY_MISSING: The referenced assembly could not be found. 

    If anyone can repro this still, please provide the file c:\windows\logs\cbs\cbs.log so we can get more info on the problem.

    Tuesday, January 12, 2016 9:53 PM
  • Couple questions:

    1) Was your previous build of Windows one that has been part of the Windows Insider program?

    2) Is your machine on a domain?

    The reason I ask these questions is because we have had problems in the past installing graphics tools in these situations.


    Jim

    Hi Jim,

    I'm running Win10 Enterprise (10240) and having trouble installing the Graphics Tools.  Most likely this machine did have the Insider Preview installed, but it's been so long, I can't remember.  Machine is on a domain.  Do you have a suggestion on what to do in this case?

    Friday, September 2, 2016 4:28 PM