none
Unspecified error (Exception from HRESULT: 0X80004005 (E_FAIL)) has occurred: while creating new web application RRS feed

  • Question

  • I have installed Visual Studio 2015 Community version. I am using Windows 7 64 bit system. 

    I have performed following steps to create new web application and "Unspecified Error" is thrown. I have also repaired the visual studion 2015 but the error still throwing.

    1) Go to File > New > Project

    2) Clicked "Asp.net Web Application" with .Net Framework 4.5.

    Result: "Unspecified error (Exception from HRESULT: 0X80004005 (E_FAIL)) has occurred" error is thrown 

    Hint: I found that the "WebApplication1" folder is successfully created with App_DATA, App_Start,....., WebApplicaiton1.csproj folders/files. But the .sln file is not creating.

    Tuesday, May 26, 2015 3:11 PM

Answers

  • Hi Saurabh,

    For this particular issue, I searched some solutions below, hope they will helpful:

    1. Go to Control Panel -> Programs and Features -> Turn Windows Features on or off, inside that, we had to select Internet Information Services -> Web Management Tools -> IIS 6 Management Compatibility -> IIS Metabse and IIS 6 configuration compatibility.

    2. Edit the web application’s project file with a text editor and change this line from True to False:

    <UseIIS>True</UseIIS>

    3. Grant IIS AppPool identity permissions to the %systemroot%\inetsrv\config

    4.Run in command prompt: aspnet_regiis –i or aspnet_regiis.exe –ga

    If the above doesn’t work, please use the devenv /log to start visual studio and log all activity to the log file. You can get the log file at: %APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml, open it in the IE to see whether there are errors. Refer to: https://msdn.microsoft.com/en-us/library/xee0c8y7.aspx?f=255&MSPPError=-2147217396

    Best Regards,

    JiayiLi

    Thursday, May 28, 2015 9:41 AM
    Moderator

All replies

  • Hi Saurabh_It49,

    Does the error “0x80004005 occur” only when creating web application or when creating any other templates?

    If it occurs only when creating web application, I found two solutions to solve it, you can have a try:

    1. Use Devenv.exe, refer to: https://msdn.microsoft.com/en-us/library/xee0c8y7.aspx?f=255&MSPPError=-2147217396

    Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

    Devenv.exe /ResetSettings: Restores the IDE's default settings

    2. Install the IIS Express, refer to: http://www.microsoft.com/en-us/download/details.aspx?id=34679

    If it occurs whatever you created, I think you need to reset your visual studio templates, please follow the steps below:

    1. Open Windows Explorer, and navigate to <Visual Studio Installation Path>\Common7\IDE (by default is C:\Program Files \Microsoft Visual Studio 10.0\Common7\IDE);
    2. Delete the ItemTemplatesCache, ProjectTemplatesCache folder;
    3. Open Visual Studio Command Prompt under Start menu -> All Programs -> Microsoft Visual Studio -> Visual Studio Tools (run it with administrative privilege);
    4. Run the devenv /InstallVSTemplates switch;
    5. Run the devenv /Setup switch;

    Hope this information is helpful.

    Best Regards,

    JiayiLi

    Wednesday, May 27, 2015 7:57 AM
    Moderator
  • Hi JiayiLi,

    First of all thank you so much for your valuable feedback. I am replying you all my effort as per your steps.

    Yes it occurs for web applications only. It means if I go with “Windows Form” option then it works fine.

    Regarding your two solutions…

    1) I have reset settings but no luck

    2) I downloaded your specified IIS Express. When I tap to install it shows me message regarding I already have latest one. So it seems that I have latest IIS Express.

    I also extecuted both commands over “Visual Studio 14.0” path but error is still throwing on.

    One more thing, today I also downloaded “Visual Studio 2013” and created web application on it. I got the same error (Unspecified Error 0x80004005…) on last step. So it seems there is common error for both VS2013 and VS2015 community versions.

    Regard,

    Saurabh



    Wednesday, May 27, 2015 1:32 PM
  • Hi Saurabh,

    For this particular issue, I searched some solutions below, hope they will helpful:

    1. Go to Control Panel -> Programs and Features -> Turn Windows Features on or off, inside that, we had to select Internet Information Services -> Web Management Tools -> IIS 6 Management Compatibility -> IIS Metabse and IIS 6 configuration compatibility.

    2. Edit the web application’s project file with a text editor and change this line from True to False:

    <UseIIS>True</UseIIS>

    3. Grant IIS AppPool identity permissions to the %systemroot%\inetsrv\config

    4.Run in command prompt: aspnet_regiis –i or aspnet_regiis.exe –ga

    If the above doesn’t work, please use the devenv /log to start visual studio and log all activity to the log file. You can get the log file at: %APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml, open it in the IE to see whether there are errors. Refer to: https://msdn.microsoft.com/en-us/library/xee0c8y7.aspx?f=255&MSPPError=-2147217396

    Best Regards,

    JiayiLi

    Thursday, May 28, 2015 9:41 AM
    Moderator
  • I had the same issue and I fixed it. Log  in as Admin your pc.Go to %systemroot%\inetpub\wwwroot.

    Right click and propertied> security> ISS_IUSRS and give all the permissions.

    Tuesday, December 29, 2015 3:32 PM
  • Hi,

    I have resolved this error by just changing project folder in C:\Project2016 instead by default path.

    Default path: C:\users\...\documents\visual studio 2015\Projects


    ckp

    Wednesday, October 5, 2016 9:05 PM
  • Hi JiayiLi,

    I had same problem and it resolved after installing IIS, Please download from the below link and instal.

    https://www.microsoft.com/en-us/download/details.aspx?id=34679

    Hope it will helpful for you.

    Regards,

    Shyam

    Monday, January 15, 2018 12:15 AM
  • I was getting the same error, and was able to resolve by just changing the directory location, previously I was saving it on onedrive folder,

    Do it a try.

    Regards

    Irshad Babar,

    • Edited by Irshad Babar Monday, April 16, 2018 10:52 AM
    • Proposed as answer by Kedders Friday, September 14, 2018 9:19 AM
    Monday, April 16, 2018 10:51 AM
  • hello sir i tried all the solutions you have given above but still that error is coming when i am creating the web application in visual studio
    Wednesday, September 19, 2018 5:12 AM
  • Thanks Chirag..This worked for me !!!

    Thursday, October 4, 2018 9:24 AM