none
Can't debug my application RRS feed

  • Question

  • Hi,

    I have recently installed Visual Studio 2010 Professional edition on my Windows 7 computer. I also have Visual Studio 2008 Professional installed on the same computer. I used to use the VS 2008 up until now.

    I have a problem debugging an application I just created using VS 2010. When I try to step into the code, I keep getting this error message "No source available. No symbols are loaded for any call stack frame. The source code cannot be displayed" and then the application halts executing. I've searched all over the internet looking for an answer, but I've got none.

    Can you please help me fix this problem?

    Thanks in advance!

    Abdul

    Friday, September 14, 2012 3:46 AM

Answers

  • Hi Abdul,

    Glad to receive your reply.

    If you want to reset your VS settings, you could check this MSDN document “How to: Reset Your Settings”.

    You could also locate to the IDE folder then run these commands, or you can set path to the system environment.

    C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE

    Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Devenv.exe /ResetAddin: Removes commands and command UI associated with the specified Add-in.

    Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

    And then create a new app, check it again.

    I received your app, I try to debug it, and it worked normally.

    Sincerely,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Abdul A. Ali Tuesday, September 25, 2012 8:42 AM
    Tuesday, September 25, 2012 5:43 AM
    Moderator

All replies

  • Can anyone tell me how to fix this please? Anyone?


    • Edited by Abdul A. Ali Friday, September 14, 2012 3:09 PM Typographical mistakes
    Friday, September 14, 2012 3:08 PM
  • There are some steps you can take, to get some more information.
    Does your project build debug info - (for example in a C# project:  in Property Pages window (Project->Properties)  at 'Build'/'Compile' tab pressing the 'Advanced' button:  'Debug Info' should be set to 'full')?
    During debugging is there an exception message in 'Output' Window (View->Output)?
    Is VS able to find the symbol-files?
    'Module' window (Debug->Windows->Modules) will show loaded symbol-files - right clicking at a module and choosing 'Symbol Load Information' will show the load attempts of Visual Studio for pdb-files.
    If it is a managed application, you may want to 'Enable unmanaged code debugging' in project property pages, which may yield a more complete call-stack ('Debug->Windows->Call Stack'), if at 'Debug->Options and Settings...' in 'Debugging->Symbols' tab 'Microsoft Symbol Servers' is checked.
    At 'Debug->Options and Settings...''Debugging General' you may also disable 'Enable just my Code' (also managed only).

    With kind regards

     

    Friday, September 14, 2012 6:27 PM
  • Hi Abdul,

    Sorry for the reply no help.

    Just to make this issue clearly, what kind of app are you debugging? Did you attach to a managed app?

    No source available. No symbols are loaded for any call stack frame. The source code cannot be displayed

    I have met the similar issue, we often try to load symbols in the Modules window like this blog “The Importance of Debugger Symbols: or Reloading Symbols while Debugging”.

    Visual Studio can download the debugging symbol files from a symbol server, but if you use a symbol server other than the Microsoft public symbol servers, make sure that the symbol server and its path are trust worthy. For detailed information, see “How to: Use a Symbol Server”.

    If still no help, could you share us a simple sample? We will try to debug it in our PC.

    Have a nice weekend,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Friday, September 21, 2012 8:13 AM
    Moderator
  • Hey.

    Thanks for the response. I have tried all the solutions you guys have suggested. But I've got nothing changed yet. I am still getting the same problem.

    But here's one interesting thing: console applications are working perfectly! I've created more than three console applications on the same computer; they all debugged perfectly. The problem occurs only when I try to debug a Windows Forms application, or a Web application.

    Also the problem is not just with my application. It's with every Windows Forms or Web application I create using Visual Studio 2010. So I think the problem has less to do with this particular application and more to do with the Visual Studio and the core libraries.

    I also have Visual Studio 2008 installed besides the VS 2010. If I debug the same applications on the VS 2008, the debug goes perfectly --but I don't want to use the VS 2008 for some reasons.

    Using all those facts, can anyone tell me what to do? I think the VS 2010 has some problems, maybe missing some libraries.

    Please help me!

    Abdul


    Friday, September 21, 2012 7:16 PM
  • Hi Abdul,

    Glad to receive your reply.

    As you said that the console apps worked well, but all the winform apps and web app have this issue, I doubt that it is not the VS debugger tool issue.

    To make sure that it isn’t related to any settings, if possible, I suggest you try to reset your VS settings. You could try to change the Platform target to Any CPU or other, clean and rebuild you app, check it again.

    In addition, if you have other VS2010 Environment, try to run the same app in it, if it worked well, I doubt that it is related to you VS2010 installing. If possible, you could try to repair your VS2010, note: please install the VS2010 sp1.

    If you didn’t have the Environment, you could share me a simple sample, I will try to debug it in my PC. You could send it to jackzhai at Hotmail dot com.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Monday, September 24, 2012 7:14 AM
    Moderator
  • Hi Jack,

    Thanks so much for reply. I have tried to clean the solution and then rebuild, but nothing has changed. I really think this has a lot to do with my VS installation. You said in your reply to reset the VS. Can you tell me how to that please? I don't want to uninstall it.

    I can't debug even the simplest Win Forms app. The problem is not just with the one I'm developing. I would've emailed you my whole app, but I can't. Company policy!

    I emailed you a very simple Win Forms app that's only showing a message at loading. It basically does nothing, but the point is to show you how even the simplest Win Forms app is not debugging.

    Regards,

    Abdul


    Monday, September 24, 2012 7:46 AM
  • Hi Abdul,

    Glad to receive your reply.

    If you want to reset your VS settings, you could check this MSDN document “How to: Reset Your Settings”.

    You could also locate to the IDE folder then run these commands, or you can set path to the system environment.

    C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE

    Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Devenv.exe /ResetAddin: Removes commands and command UI associated with the specified Add-in.

    Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

    And then create a new app, check it again.

    I received your app, I try to debug it, and it worked normally.

    Sincerely,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Abdul A. Ali Tuesday, September 25, 2012 8:42 AM
    Tuesday, September 25, 2012 5:43 AM
    Moderator
  • Hi Jack,

    Thanks you so much for the reply. The problem got solved. As you told me, the VS needed to be reset. I have followed the procedure described in the link above to reset the VS, and BOMMM!!! Every thing is working perfectly now.

    Thanks again for the help.

    Regards,

    Abdul

    Tuesday, September 25, 2012 8:47 AM