locked
Cannot connect to SQL Azure server data using Management studio or ODBC RRS feed

  • Question

  • Dear all,

    I have created an SQL server database on azure on my test account.

    I try to connect to that SQL server using SQL server 2008 R2 Management studio but no luck
    I take care that server allaows remote connection, TCP enable and port 1433 open.
    Firwal rrul are configure on SQL azure

    When I try accessing to the server using the given connection iformation and my login, I get an error saying Server not found or access denied.

    If I connect to my database with my SQL login directly from the portal it works ok. SO I guess it is coming from the server which cannot be reached.

    Any idea ?

    regards


    Your knowledge is enhanced by that of others.

    Thursday, August 8, 2013 8:46 AM

Answers

  • got it working by re applying SP2.

    I did not notice that the SP2 install of SQL server failed when pushed by our SUS server

    thanks to all of you

    regards

    serge


    Your knowledge is enhanced by that of others.

    Saturday, August 10, 2013 5:44 PM

All replies

  • What server name are you using to connect to the SQL Azure server?

    The correct one is that you can find on the Azure Portal under the SQL Azure Server section (or under Server in the SQL Azure management web interface).

    The server name should be in the form: [SERVER_NAME].database.windows.net

    Furthermore, be sure you are using the correct username: [USERNAME]@[SERVER_NAME]

    For example, if your SQL Azure server name is myname, and you user name is serge you have to use:

    server: myname.database.windows.net

    username: serge@myname

    password: [YOUR PASSWORD]

    The SQL Azure management web interface allows you to login by using only [USERNAME] but SQL Server Management Studio does not.



    • Edited by dsmwb Thursday, August 8, 2013 5:05 PM
    Thursday, August 8, 2013 4:56 PM
  • This is what I have done

    I took the server name from the portal and login as you mention

    What is wierd is that I can even not connect thougha simple ODBC datasource test from Administrative tool directly

    I receive a Server not found or access denied.

    IN ODBC for instance I enter :

    Server Name as :myserver.database.windows.net
    Thjen check SQL connection and provide my user name as : myuser@pyservername, have try also without server name
    Then from Client confioguration I uncheck Dynamic port in order to use the tcp 1433

    By the way I have this error in SQL configuration tool that I cannot get ride of and not clear path to solve it

    wierd


    Your knowledge is enhanced by that of others.


    Friday, August 9, 2013 8:21 AM
    • Edited by dsmwb Friday, August 9, 2013 10:48 AM
    Friday, August 9, 2013 10:46 AM
  • I even can't connect through a simple ODBC connection !!!!

    No luck either

    Could you try from your side to see if you can succeed ? I have made a new test empty db
    server =zs6yeredql.database.windows.net

    user=sb

    pasw=Tiphaine-Logann-11


    Your knowledge is enhanced by that of others.


    Friday, August 9, 2013 11:41 AM
  • Did you install "SQL Server Native Client"?

    http://msdn.microsoft.com/en-us/library/windowsazure/hh974312.aspx


    • Edited by dsmwb Friday, August 9, 2013 11:54 AM
    Friday, August 9, 2013 11:52 AM
  • yes I have it

    Did you manage to connect ?


    Your knowledge is enhanced by that of others.


    Friday, August 9, 2013 12:33 PM
  • I have no problem with SSMS 2008 R2 (after an update) and with ODBC driver (http://msdn.microsoft.com/library/jj730314.aspx).

    However the procedure in http://documentation.telerik.com/openaccess-orm/developers-guide/database-specifics/microsoft-sql-azure/getting-started-root-quickstart-azure-connect-through-ssms always worked for me.

    I suggest you to install SSMSE 2012 or reinstall the last version of SSMS 2008 R2.

    Make sure that you have the appropriate client protocol(s) enabled.

    • Start SQL Server Configuration Manager 
    • Expand SQL Native Clent 10.0 Configuration
    • Click on Client Protocols
    • Verify that the protocol TCP/IP is enabled 



    • Edited by dsmwb Friday, August 9, 2013 12:45 PM
    Friday, August 9, 2013 12:40 PM
  • I think we are trying all high fundoo stuff without checking basics.

    Lets start with ground

    Did you checl telnet?

    telnet SQL Azure server name> 1433

    (if this fails your ISP is blocking outgoing connections for port 1433 which you need to get enabled)

    if this breaks there is no way your connections will work.

    Could you paste complete error message that you get in SSMS?

    Also do not make any changes to client confg also there is high probability that you made changes to 64 bit client config adn not 32 bit one. (SSMS is 32 bit utility so it will use 32 bit client config)

    I think we will be able to resolve connectivity if we go step by step.

    -Dilkush

    Saturday, August 10, 2013 10:19 AM
  • got it working by re applying SP2.

    I did not notice that the SP2 install of SQL server failed when pushed by our SUS server

    thanks to all of you

    regards

    serge


    Your knowledge is enhanced by that of others.

    Saturday, August 10, 2013 5:44 PM