none
Runtime.executionContextCreated has invalid getting while launching Chrome using Coded UI RRS feed

  • Question

  • Hi Team,

    After installed the Selenium Component in local machine...I Can able to Open the chrome through coded UI using below code, But chrome opening in Developer mode[getting popup as "Disable Developer mode Extension"] and after that closing the Browser... Can any one please help me here, after installed the Selenium component do i need to do any thing??


    Code : BrowserWindow.CurrentBrowser = "Chrome";
    BrowserWindow.Launch("www.msdn.com"); 
    Note: Am using Code Driver Version = 2.9
    Chrome Version = 54.0.2
    Visual Studio 2013

    From my solution getting below Error Message:
    Additional information: unknown error: Runtime.executionContextCreated has invalid 'context': {"auxData":{"frameId":"11040.1","isDefault":true},"id":1,"name":"","origin":"://"}

    Monday, October 31, 2016 3:54 PM

Answers

  • Hi Kiran Kumar Allagadda,

    According to your description, you want to play back the Coded UI scripts in Chrome. Am I right?

    The selenium components for Coded UI Cross Browser Testing was not working in Chrome v54. In my side I have encountered the similar issue.

    I have submitted a feedback to the following site, and let us wait patiently.

    https://visualstudiogallery.msdn.microsoft.com/11cfc881-f8c9-4f96-b303-a2780156628d/view/Discussions

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 1, 2016 5:15 AM
    Moderator

All replies

  • Hi Kiran Kumar Allagadda,

    According to your description, you want to play back the Coded UI scripts in Chrome. Am I right?

    The selenium components for Coded UI Cross Browser Testing was not working in Chrome v54. In my side I have encountered the similar issue.

    I have submitted a feedback to the following site, and let us wait patiently.

    https://visualstudiogallery.msdn.microsoft.com/11cfc881-f8c9-4f96-b303-a2780156628d/view/Discussions

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 1, 2016 5:15 AM
    Moderator
  • Many Thanks for Update Oscar
    Tuesday, November 1, 2016 7:36 PM
  • We have the same issue

    We are not able to work with the new version of chrome Browser V54, even though we updated with the chrome driver new version(2.25).


    As a work around we did a chrome browser version degradation(to V53)and working with the existing selenium component.

    Friday, November 4, 2016 11:24 AM
  • How to install 53 version of chrome.. Please help me

    Facing same issue

    Saturday, November 12, 2016 3:59 PM
  • For installing V53, please refer the below link.

    https://www.chrome-portable.com/index.php/google-chrome-offline-installer

    Note:- before installing this V53, you have to uninstall your current Chrome version and should disable automatic chrome update.

    Friday, November 18, 2016 8:08 AM