none
Unable to start program element not found RRS feed

  • Question

  • Installed IE 8 final the other day and since when i debug in VS 2008 with an asp.net project I get an error, sometimes:

    Unable to start program http://localhost:50183/directory/asppage.aspx element not found.

    Now, it does open IE 8 , but IE 8 says connecting I cannot close it except by the task manager. This does not happen all the time. This is driving me nuts and I cannot find any information on this issue anywhere.

    Any information on how to address this issue would be great.

    Monday, April 27, 2009 1:12 PM

Answers

  • Mike_O has something here... I've been getting the error in VS 2008 on Win7, on a project that was working fine for over a year.

    I updated to VS 2010 to see if that made a difference, and it worked for a day or two, then is sporatically happening again.

    I've tried all the suggestions above and as I said some days it works fine, others I have to run without debug to see the app. Sometimes even with debug turned off, I see wierd stuff like:

    • two iExplorer windows open with the app in it (not blank)
    • The blank window left behind when the app can't open would get filled with the app when launching without debugging (and in some cases I see 3 total windows open)

    I read Mike's post today and thought to look for a way to turn off page recovery (which I don't like either) and found it here:

    Internet Options - Advanced - Browsing-Enable Automatic Crash Recovery

    I turned it off and now the page loads quicker and the issue hasn't reproduced, of course the issue is sporatic so I may see it again but for now I feel happy, and that should count for something...

    • Proposed as answer by Zylin95 Monday, July 26, 2010 8:02 PM
    • Marked as answer by Vecdid Tuesday, September 28, 2010 11:21 AM
    Thursday, April 22, 2010 12:25 AM
  • I think it might have something to do with the browser restore in IE8.  If I open IE8 before running the app and click "go To My Homepage", then close the browser, there is no problem.  It only occurs when IE8 crashed the last time it was used.  I can't stand browser restore and wish they would just get rid of it.  My last session crashed so instead of letting me start over, I'm forced to sit and wait while it crashes again.
    • Marked as answer by Vecdid Tuesday, September 28, 2010 11:19 AM
    Monday, April 12, 2010 7:36 PM
  • I think I fixed it. It doesn't seem to happen when I turn protected mode off. Seems like a security concern, but so far after a few debugs all seems well...

     

    Ever since I did what I stated above I have not had that error on any machine.

    • Marked as answer by Vecdid Saturday, May 2, 2009 1:44 AM
    • Edited by Vecdid Tuesday, September 28, 2010 10:59 AM
    Saturday, May 2, 2009 1:43 AM
  • In IE 8
    Go into tools internet options.

    Click on security
    Clieckon trusted sites

    Add localhost as a trusted site.
    Make sure protected mode checkbox is unchecked
    Click OK
    • Proposed as answer by jeffreymergler Thursday, January 28, 2010 3:36 PM
    • Marked as answer by Vecdid Tuesday, September 28, 2010 11:20 AM
    Friday, May 22, 2009 3:55 PM

All replies

  • I am having the same problem and also can only close IE8 by using task manager.  The errors are not consistent.  Sometimes the browser will not even start but usually it shows as "connecting".
    Monday, April 27, 2009 2:09 PM
  • I am getting the same error on two machines running vs 2008 sp1 with IE 8 installed. It is so spuratic. On this laptop It doesn't happen as much, although if I go into power saving mode or try to browse with ie 8 in another window while stating the debugger I get the error. This is a real annoyance there has to be alot more people having this issue. Any advice would be great.
    Wednesday, April 29, 2009 4:00 AM
  • Hello Vecdid,

    Based on my understanding, we have an ASP.NET web application, when we press F5 (Start Debugging) in Visual Studio 2008, it sometimes shows us: Unable to start program, element not found. And sometimes IE 8 opened, but just shows Connectiong... If I misunderstand you, please don't hesitate and correct me.

    I did some tests on my machine, and here are my steps:
     1. create a new web application
     2. set a breakpoint at the beginning of the Page_Load event
     3. press F5 and start debugging
     4. IE 8 was launched and showed Connecting..., the breakpoint got hit at the mean time.
    Hence, this is a normal situation if we set a breakpoint at the Page_Load event.
    Do you happened to set some breakpoints there?

    Please following the steps below to verify if the Enable HTTP Keep-Alives option is checked in IIS:
     1. Open Internet Information Services (IIS) Manager 
     2. Expand the Web Sites node
     3. Right click the Default Web Site node and choose Properties
     4. Click Web Site tab and find the Connections section
     5. Check Enable HTTP Keep-Alives check box

    For more information to troubleshoot the issue, please refer to the link below and check those options:
    Error: unable start debugging on the Web Server:
    http://msdn.microsoft.com/en-us/library/dwesw3ee(VS.80).aspx

    Best regards,
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback, please tell us.
    Welcome to the All-In-One Code Framework!
    Thursday, April 30, 2009 5:36 AM
  • Roahn,

    I was unable to make the webserver work even when clicking the "Start Without Debugging" was used.  I also disabled all breakpoints when debugging and could not get the web server to work.  As noted above, the errors seem to differ even when repeating the exact same steps.  I had to uninstall IE8 and the web server on VS2008 is working perfectly, so this had to be the issue.

    Thursday, April 30, 2009 12:55 PM
  • I am not running IIS, I am using the built in development webserver that comes with VS 2008. There isn't a breakpoint and it doesn't happen all the time. Here is exactly the error I get when trying to start a project:

    This is from a from the template blank asp.net solution...

    Title: Microsoft Visual Studio
    Error: Unable to start program
    'http://localhost:49662/Website1/Default.aspx'

    Element Not Found

    This started when I installed IE 8 Release. When I roll back on one of my other machines, the error no longer occurs.

    I never installed any betas.

    It doesn't happen all the time, I notice it happens more when I am browsing while starting the debugger.

    IE 8 opens hanging at connecting, I cannot close it without going into task manager and end tasking on it.

    I also noticed that when I click to open IE 8 by shortcut it opens two iexplorer.exe but I only ever see one open in a window.

    This also happens when debugging. One will be like 4 mb of ram and the other like 100k.

    When I end task on one it kills the other, although I only see one window.

    The error is not because of the two as that happens when just launching IE8.

    Any ideas?
    Saturday, May 2, 2009 12:48 AM
  • Also I am running Vista Ult sp1 on one pc and home pro on the other
    Saturday, May 2, 2009 12:51 AM
  • I also reset the browser after the upgrade from IE7 to 8
    Saturday, May 2, 2009 12:52 AM
  • I think I fixed it. It doesn't seem to happen when I turn protected mode off. Seems like a security concern, but so far after a few debugs all seems well...

     

    Ever since I did what I stated above I have not had that error on any machine.

    • Marked as answer by Vecdid Saturday, May 2, 2009 1:44 AM
    • Edited by Vecdid Tuesday, September 28, 2010 10:59 AM
    Saturday, May 2, 2009 1:43 AM
  • In IE 8
    Go into tools internet options.

    Click on security
    Clieckon trusted sites

    Add localhost as a trusted site.
    Make sure protected mode checkbox is unchecked
    Click OK
    • Proposed as answer by jeffreymergler Thursday, January 28, 2010 3:36 PM
    • Marked as answer by Vecdid Tuesday, September 28, 2010 11:20 AM
    Friday, May 22, 2009 3:55 PM
  • I had the same issue and in my case, it was caused in relation to the sitemap.  I refreshed the object bound to the sitemap, and the issue disappeared

    I stand corrected.  The issue is intermittent.  Restart it one time,and it's fine, restart it again and the issue occurs, restart again, the issue occurs, restart again no issue. 

    • Edited by mamikel Friday, May 29, 2009 3:20 AM
    Friday, May 29, 2009 2:36 AM
  • i still have the problem

    any other solution?

    visual studio 2008 sp1
    windows vista business sp1
    ie8
    • Edited by Alkaloon Friday, May 29, 2009 12:18 PM
    Friday, May 29, 2009 12:14 PM
  • is the issue intermittent for you?
    Application Developer
    Friday, May 29, 2009 11:04 PM
  • It doesn't seem to be intermittent for me. Just upgraded from IE7 to IE8 on Vista Business, and now I can no longer start my ASP.NET site in debug mode - I get the error every time!

    [Edit]
    Correction. SOMETIMES I don't get the issue. MOST times I do. Very frustrating. I've added localhost to the trusted sites, and made sure 'protected mode' is off. Any other suggestions? I'm tempted to uninstall IE8, but as our users are starting to migrate to it, I really need to be able to support it.
    • Edited by JohnHorb Monday, June 8, 2009 9:50 AM More info
    Thursday, June 4, 2009 10:42 AM
  • I've had this problem for quite some time now...  It appears to be worst when I have IIS running.  I was just using it for the FTP site.  When I stop these services, I can connect with IE8 first time, everytime.  I would rather not shut down my ftp site so if anyone has another solution........

    Thanks
    Friday, June 12, 2009 1:08 AM
  • i met this problem after install windows7 rc with vs8 + sp1. any solution on this?

    thanks!
    Monday, July 6, 2009 12:31 AM
  • I'm having the same problem in Windows XP with Visual Studio 2008 and IE8.  My understanding is that there is no protected mode under XP, so that can't be the problem.  I am 100% sure that this error started to appear after I upgraded to IE8.  It occurs about 1 out of every 5 times I start debugging a web application using the Visual Studio test server, not IIS.
    Friday, August 14, 2009 7:43 AM
  • Getting very frustrated with this. It seems nobody has any solution.
    Friday, August 28, 2009 10:09 AM
  • I agree.  Could anyone at least suggest a better place to report this bug?
    Friday, August 28, 2009 2:37 PM
  • You can add me to the list of people with the same problem.  You would think someone at Microsoft would see these and do something about it.

    OK.  I solved the problem.  I ran two web sites in Visual Web Developement 2008 Express (one I wrote and one that I got off a Microsoft Tutorial) and they both failed with the message "Unable to start program "http://localhost:..."

    I then closed Visual Web Developement 2008 Express and opened Visual Web Developement 2005.  I ran the same two web sites and they worked perfectly.
    • Proposed as answer by almostrookie Friday, October 9, 2009 3:06 AM
    Wednesday, October 7, 2009 9:46 PM
  • You can add me to the list of people with the same problem.  You would think someone at Microsoft would see these and do something about it.

    OK.  I solved the problem.  I ran two web sites in Visual Web Developement 2008 Express (one I wrote and one that I got off a Microsoft Tutorial) and they both failed with the message "Unable to start program "http://localhost:..."

    I then closed Visual Web Developement 2008 Express and opened Visual Web Developement 2005.  I ran the same two web sites and they worked perfectly.

    lol, terrific.  Has this issue persisted with VS 2K8 SP1 anyone? 
    Application Developer
    Friday, October 9, 2009 3:16 AM
  • I also get the same problem

    using: Microsoft Visual Studio 2008 Standard Version
    Windows Vista Service Pack 2
    Internet Explorer 8

    Interesting though the error does not occur on the same machine if I use Visual Web Developer Express 2008.
    Tuesday, October 27, 2009 2:25 PM
  • Well,

    I bring not a solution, but a write-up of my experience, my scenario.  I am hoping that someone else who will have gone or is about to go thru the same scenario will save some steps reading 300 posts as I did.

    THERE IS NO FREAKIN SOLUTION; WE ARE ALL STUCK UNTIL MICROSOFT FIGURES OUT WHAT THEY SCREWED UP.

    See My Current SETUP below for context.

    I read some posts that the new way of debugging is more true and forces us developers to produce code that does not trigger this behavior.  These SEVERAL post suggest that we will not get a solution, that it is as it is and we need to navigate thru the mess ourselves! These are Microsoft engineers’ statements.  I will come back here and post the URL; I am not sure where I saw it at this time.
    (@@@)
    I do not even understand what that new approach is/means... I read the posts, and was left dumbfounded.
    ALL I KNOW IS THAT AFTER FIGHTING FOR a week to install all this software and to get my environment in proper order, I now get the final reward that the debugger is useless.

    This issue started show once I jumped to IE8 ON MY XP Pro setup at work.
    Somehow I was able to get rid of the behavior on my XP Pro setup, but it returned, lately, and I was never able to resolve it.

    I recently took opportunity to make the jump to WINDOWS 7 on a 64bit/32bit(x86) machine, at home.
    As I upgraded my system to the latest and greatest things got worse.
    - The SQL Server 2005 Express failed in the middle of the install. I had to turn off services to allow it to install.
    - at first I could not even create a new project
    - then I could not connect to the database with SQL Server Explorer.
    - then I could not connect to the Database via the site(web.config file)

    Now that I got it all working smoothly at my 3rd install, one of which meant to reinstall windows to clear the registry of the Frameworks, as the utility provided by Microsoft failed to clean it, MY REWARD IS NO DEBUGGER.
    - I am able to create projects
    - I access the Database from the SQL Server Explorer and make changes to schema and data
    - I access the Database thru the site(able to login etc...)
    - DEBUG???!!! FORGGGGGET IT! 2 minutes max and YOU ARE OUT!
      My Visual Studio Debugger whether in Studio Debug or IIS Debug times out within a 2 minutes mark.
      The debugger times out on the simplest VANILLA 1 page 'Hello world' app.
      Take note: This is a clean NEW install

    My Current SETUP:  (new setup at home)
    - Dual Core 64bit/32bit(x86)
    - WINDOWS 7 Pro(latest updates installed)
    - Visual Studio 2008 Pro SP1
    - Framework 3.5(you know...piggybacked on 2.0, 3.0, SPx...)
    - SQL Server Express 2005 (part of the Visual Studio install), SP3 installed on top
    - IIS 7.5 comes with WINDOWS 7 Pro (all integrated, does not show in Programs installed or Updates installed, one turns it on by going to windows features)
      Incidentally:  The manager for 7.5 still is listed in program files as the 6 version. (will verify that and see what the discrepancy is)
    - Latest version of IE (8...)

    It took me days to figure out how to get all this ____ to work. I read 300 pages on the internet.
    Somehow I installed no more than 3 times.
    (I am now going back thru my notes to create a map of all the steps I took to get it all to work!)

    ...ALAS, I have no answer for the debugger, just that in my scenario, NOTHING suggested in all the posts I read has worked.

    I am near the point of giving up... and get a new dev environment.
    (I will edit this post to correct any fallacies I may have introduced and to complete sections noted.)
    .


    SPA
    Sunday, November 15, 2009 5:48 AM
  • MS has fixed this issue.
    I reinstalled my IE8 leaving my internet connection ON and it has installed the latest version with the bug fixed.
    So all you need to do is reinstall IE8 with your internet connection on.
    Sarin
    Saturday, November 21, 2009 6:41 AM
  • Sarin,

    REF: My Post 2 boxes above, and your answer immediately above this post.

    I am assuming that you are referring to my post specifically.
    I you are... what does that actually mean?
    There is no install for IE8... where exactly do I go to download/trigger the reinstall that will work?
    And will this move zap all my setup in the IE advanced and other settings?

    Moreover, I am on automatic updates... why is this update u bring up not automatically applied?

    WHAT IS THE VERSION of IE after reinstall?
    Mine is now: 8.0.7600.16385 AS INCLUDED IN WINDOWS 7 NEWLY PURCHASED Dual Core 64-Bit box.
    .
    Note on the IE8 page NO WINDOWS 7 option?
    http://www.microsoft.com/windows/internet-explorer/worldwide-sites.aspx

    Also note that on WINDOWS 7, IE is a feature that is turned ON/OFF in the Windows Features dialog

    Thank you very much for your post.
    SPA
    Sunday, November 22, 2009 2:33 PM
  • I get the same problem.  Ever since I installed IE8, the Element not found error occurs on a random basis.  It happens when you start a web site using debug.  The message pops up on the visual studio debug session and IE8 hangs with the connect message.  As mentioned earlier, you have to use either task manager or Process Explorer to kill the process.

    Has anyone submitted it to Microsoft?
    Tuesday, December 1, 2009 3:28 PM
  • I'm getting this problem to, and have been for a while. It can surely only be a problem with IE. Changing VWD's default browser to be something else should lose the problem until it's patched (CSS seems to work better with Chrome). Anyone know is MS are aware of this?
    Saturday, December 12, 2009 2:25 PM
  • I got this error when debugging with VS 2005 as well as VWD 2008. Both with asp.net as well as Silvelight projects. I have IE8 on Windows XP sp3. When I press F5, I will get error "Unable to start program ...". The browser will say Connecting for ever and eventually I will have to kill it in Task Manager.

    After an hour of research I have found that it is IE8 design (bug/feature) which is causing this grief. I found solution here:
    http://blogs.msdn.com/greggm/archive/2009/04/01/script-debugging-broken-in-vs-2005-after-installing-ie8.aspx

    1)  Open RegEdit
    2)  Browse to HKEY_LOCALMACHINE -> SOFTWARE -> Microsoft -> Internet Explorer -> Main
    3)  Add a dword under this key called TabProcGrowth
    4)  Set TabProcGrowth to 0

    After making the above registry entry and killing all browser instances, I have been able to press F5 and strat browser every single time.
    • Proposed as answer by Starbuck Monday, August 22, 2011 8:49 PM
    Friday, January 1, 2010 10:37 PM
  • The solution by Vecdid above fixed the "Element Not Found" error for me.
    Thursday, January 28, 2010 3:37 PM
  • I think it might have something to do with the browser restore in IE8.  If I open IE8 before running the app and click "go To My Homepage", then close the browser, there is no problem.  It only occurs when IE8 crashed the last time it was used.  I can't stand browser restore and wish they would just get rid of it.  My last session crashed so instead of letting me start over, I'm forced to sit and wait while it crashes again.
    • Marked as answer by Vecdid Tuesday, September 28, 2010 11:19 AM
    Monday, April 12, 2010 7:36 PM
  • Mike_O has something here... I've been getting the error in VS 2008 on Win7, on a project that was working fine for over a year.

    I updated to VS 2010 to see if that made a difference, and it worked for a day or two, then is sporatically happening again.

    I've tried all the suggestions above and as I said some days it works fine, others I have to run without debug to see the app. Sometimes even with debug turned off, I see wierd stuff like:

    • two iExplorer windows open with the app in it (not blank)
    • The blank window left behind when the app can't open would get filled with the app when launching without debugging (and in some cases I see 3 total windows open)

    I read Mike's post today and thought to look for a way to turn off page recovery (which I don't like either) and found it here:

    Internet Options - Advanced - Browsing-Enable Automatic Crash Recovery

    I turned it off and now the page loads quicker and the issue hasn't reproduced, of course the issue is sporatic so I may see it again but for now I feel happy, and that should count for something...

    • Proposed as answer by Zylin95 Monday, July 26, 2010 8:02 PM
    • Marked as answer by Vecdid Tuesday, September 28, 2010 11:21 AM
    Thursday, April 22, 2010 12:25 AM
  • .
    ALL seems to point to IE... clientside.

    SOLUTIONS(go-arounds):
           go-around - cannot open
         
     resolved by going slow clicking between start/stop debugger

           go-around - debugger timeout(2 mins)
           resoved by removing a startup page that had a javascript popup window and some window manipulation in javascript

    NEW PROBLEMS:
    1 - get a dialog - Internet Explorer has stopped working (debug - close)
         . if continue to use IE, screen goes into a white shade all dead
         . if answer close, lose all work, all windows in IE close
           go-around . if enter debug and cancel, everything resumes as if no error ever occurred ?!

    2 - get a switch or continue waiting dialog to pop up very sporadically (not been able to track a scenario)
         . hitting switch or continue does NOTHING. (VS is DEAD)
         . killing the devenv process in Task Manager is the only way I found to recover.

    Any thoughts?  Thank you.

    3 - also get a page where the javascript hangs on the HOST but never fails on the local IIS
         . Refresh sometimes kicks it in
         . copying the exact same .aspx and/or .js to HOST gets it to work???
           (IE CACHE? need force a newpage each time? how?(the easy way))
         . DELETE all temp files on my browser soemtimes does the trick!
         . Start it from a machine across the world(works great) ?
           go-around . whenI click on Compatibility View it resumes
                               so, why never fails on the local?

    Any thoughts?  Thank you.

    Note: Have you noticed that if you click the ? in IE to get help on an option it takes you to a completely useless 'no-help' page that shows you how to get where you just clicked from?

    I found this page on the Net: (on my first attempt, search key: internet explorer advanced settings)
    http://www.jmu.edu/computing/helpdesk/selfhelp/IE7/advancedsettings.shtml
    .


    SPA

     

     

    Thursday, April 22, 2010 2:14 PM
  • Mike_O and Dave - THANK YOU!!!

     

    Started getting this today.  Same exact behavior (Element not found, two iexplorer.exe's in task manager, one partially open window saying connecting in IE8).  Followed Dave's suggestion and problem is solved AND IE8 does appear to open faster.

     

    van Zylin

    Monday, July 26, 2010 8:04 PM
  • I am having this problem as well. 

    I recently received a new laptop with IE8 already installed.  I installed Visual Studio 2008.  When debugging an application in VS2008 (using the green arrow icon), I get the "Unable to start program ... Element not found" error almost every time.  From reading this thread and similar threads in other forums, it seems like the problem has to do with IE8.  Several suggestions have been made, but nothing seems to be the definative fix (at least for me).

    Please help!

    And if there is a better place to report this error, please let me know. 

    Thanks!

    Thursday, August 12, 2010 9:17 PM
  • Mike's solution is a winner! I tried the one on the Registry/MACHINE/Software and although the IE8 did not crash upon starting Debug, I did get the "unable to find object" message anyway.  This is definitely weirder than the original problem.

    In eother case, I changed the Internet Options/Advance settings and WOW, it does open faster and the problem seems to go away.

     

    Thanks Mike. U D MAN!

    Thursday, September 23, 2010 3:47 PM
  • Well, it only took a few reopens (actually VS crapped up on me and I had to restart) and now the "unable to start program..." error is back. Looked in the Internet Options tab thinking that the "Crash recovery" flag was reset, but it was not. So now, I am back to where I was 3 hours ago.

    I am giving up on this one until a permanent solution is found.  BTW, I am running VS2008 and IE8 on an XP-SP2 machine.

    Thursday, September 23, 2010 6:41 PM
  • The absolute, definative fix for me, was to run Visual Studio 2008 as an Administrator.  I was having the same problem, nearly every time I debugged.  I have not had the problem even once since running as an Administrator, and I made the change about a month ago.

    To run Visual Studio 2008 as an Administrator - in the Start menu, instead of just clicking on VS2008, do a right click, and select "Run as Administrator".  There's an easy way to make it always start this way, which is how I have mine set, but at the moment I'm not remembering how.  I found it pretty easy by Googling, though.

    Thursday, September 23, 2010 6:57 PM
  • How I solve it is just delete the history of IE. (Tool=>Internet Option=>Common=>Browse History=>Delete and Check all checks to delete them).

    I don't know is it help for you.

    Monday, October 18, 2010 11:50 PM
  • Just in case this helps anyone else...

    I had the same problem and found there were about 30 orphan Internet Explorer processes running (Task Manager).  Killed them all off and all working fine now.  

    Friday, December 3, 2010 6:03 PM
  • It may be a crazy idea but I was also facing the same problem of "Unable to start program" when my IE7 got upgraded to ie8 accidently, i tried running my asp.net application first by pressing ctrl + F5, it opens the application in IE,keep it opened and then pressed F5 and that brought the application debug mode.
    Sunday, July 24, 2011 5:27 PM
  •  

    --------------------------- Microsoft Visual Studio --------------------------- Unable to start program 'http://localhost:49226/ERP/Default.aspx'. A device attached to the system is not functioning. --------------------------- OK ---------------------------

     

    IF this type of problem come then Change the Browser If we used IE then used for the FireFox OR Google Chrome  I think It work fine on same port

     

    IF in your pc other Browser is install then SET the other Browser And for Browser the Web application 

     

    Right Click on Project --> Browse with --> Set Other Browser If Not Exit Add --> Add Program Set .exe path of the Browser,  Set As Default -->  Click Browse It Work With Same Port number but different Browser


    OR

    In Web.config Set 

     <compilation defaultLanguage="VB" debug="false">

    Run it without debug mode

    then also it work fine but IE Open multiple Instance of Browser



    Thursday, August 4, 2011 1:14 PM
  • I've been doing VS2005/2008/XP/IE8 work for years and never saw this error. I haven't done ASP.NET work for some months but on a tiny project I started today I got the error being discussed. The only think funky in my setup is that I've been using Firefox as a default testing browser, and only today did I reset to IE for some IE-specific work that I'm doing.

    I checked Internet Options - Advanced - Browsing-Enable Automatic Crash Recovery and it was enabled. I disabled it. No joy.

    My localhost is already in trusted sites.

    I deleted my .suo and project user files as recommended somewhere else, no joy.

    I tried opening IE without debug, then opening another session with debug - no joy.

    But after the registry tweak by @RhoitJainn100 I was at least able to see the Element missing message. And after simply closing and restarting VS2008 the problem seems to have gone away.  I thought a reboot would be required, but it wasn't.

    I don't know exactly what's causing the error. All I can say is that I've tried everything else here and it was this registry tweak plus VS restart that did the trick.

    Sincere thanks to everyone who participated in this thread because everyone contributed to a solution. I hope my note will help someone else.

    Now I have to wonder if the problem will return... ;)

     

    Monday, August 22, 2011 8:59 PM
  • In IE 8
    Go into tools internet options.

    Click on security
    Clieckon trusted sites

    Add localhost as a trusted site.
    Make sure protected mode checkbox is unchecked
    Click OK

    I have been experiencing problems with testing in IE8 and have followed I think the above steps but I still cant build and run my application in IE8.

    Does anyone know why we experience some many problems between to Microsoft programs? I thought that the problems would occur with Firefox (which works fine) and or Chrome (which I have not yet tried.

     

    I build my application and it builds with no errors

    Then when I run the application I get this

    I have followed the above steps regarding trusted sites, can anyone help???

     

    Sunday, November 20, 2011 10:50 AM

  • This is the trusted site step, have I missed anything out?
    Sunday, November 20, 2011 10:51 AM
  • This was the one that worked for me. Thanks RohitJain100 - mine started going wrong after a Oracle Virtualbox update - go figure
    Wednesday, January 25, 2012 2:56 PM
  • Hi,

      Thanks for this solution. i am also getting this problem. now it is solved.

    Friday, March 23, 2012 7:37 AM
  • Turning off Tools/Internet Options/Advanced/Enable Automatic Crash Recovery solved the problem for me.
    Tuesday, April 10, 2012 2:59 AM
  • I encounter this problem too..

    I try one the following to fix it (sometimes it works but sometimes it doesn't)

    - when VS 2010 prompts the 'Unable to start localhost... Element not found'. First, I open task manager and kill the iexplore.exe. (Windows Task Manager > Processes tab > iexplore.exe click end process button or right click iexplore.exe then end process), (Secondly, Sometimes I) stop asp.net development server - port too (Task Manager > Processes> WebDev.WebServer20.exe, Third, I open a new Internet explorer and choose restore session button (sometimes I skip this step and just run vs 2010), Lastly run VS 2010 again.

    - I use CCleaner when this problem occurs. With CCleaner, I check Temporary Internet Files, Cookies, Index.dat files. System: Temporary Files, Clipboard, Memory Dumps, Chkdsk File Fragments, Windows Log Files, DNS Cache are checked. Then run VS 2010 again.

    -  I also added localhost as trusted site: IE > Tools > Internet Options > Security > Trusted Sites > Click Sites button > Uncheck require server verification (https:) for all sites in this zone then add http:// localhost - In the Advanced tab (IE > Tools > Internet Options > Advanced > Browsing Category), uncheck Disable script debugging (Internet Explorer)

    Wednesday, October 24, 2012 5:10 AM
  • I tried following solution to overcome the issue. Its worked for me.

    1)  Open RegEdit
    2)  Browse to HKEY_LOCALMACHINE -> SOFTWARE -> Microsoft -> Internet Explorer -> Main
    3)  Add a dword under this key called TabProcGrowth
    4)  Set TabProcGrowth to 0

     If you are using a 64-bit computer, you need to edit the 32-bit registry.

     It can be run by going to Start -> Run and entering %systemroot%\syswow64\regedit and clicking OK.


    Friday, January 4, 2013 3:26 PM
  • 1. Try emptying the Temporary ASP.Net files and perform an iisreset. 
    2. Go to C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files and delete everything in it.
    Monday, May 13, 2013 2:29 PM