Associating with the store. White screen RRS feed

  • Question

  • Hi,

    My name is Vitaliy, I am one of the manager at IT company. One of our clients has requested cross-platform Ionic (Cordova) app with in-app payments. This was successfully implemented within Android and iOS platforms but unfortunately we have stuck on Windows app. Currently there is issue that we are struggling with for more than couple months - Associating the app with Windows store. 

    In general the app works fine, we can run and debug it without any problems until we associate the app with the store. The app starts but everything we get is a white screen on the device without any errors in Visual Studio. Same happens if we take a blank app (default Cordova app that comes with a standard bundle) so it is not something on our app specifically. It works on Windows Phone 8 but we are looking for universal app target Windows 10 (WP8 do not support some of the plugins that we need). 

    Below is a screenshots of what we get in the console:

    - We have tried to create packages but here is a screenshot of what we receive in Visual Studio - 

    - After associating with the store we run the app on the device, nothing happens, no error -

    - Same happens in BlankCordova app - 

    We have tried following solutions:

    - We have tried to change app manifest manually 

    - We have tried to build the app in different environments Ionic and Visual Studio

    Our parameters:

    - Visual Studio 2015 with Update 3 

    - Node Version 4.5.0 

    - Cordova Version 6.3.1

    - Target version - Windows 10

    - Angular 1

    - Device: Nokia Lumia  Windows Phone 10

    - Ionic 1

    We would really appreciate any help.

    Thank you,

    Vitaliy Dobroshtan

    • Edited by Vitaliy.D Friday, November 4, 2016 9:50 AM Removing wrong formating
    Friday, November 4, 2016 9:49 AM

All replies

  • Hi,

    Are you able to debug your app after associating with the store?

    Best Regards,

    Elvis Xia

    Monday, November 7, 2016 9:17 AM
  • Hi, Thank you for your reply.

    Unfortunately we can not debug it. 

    This is what we see in the new blank app (default app that comes with default bundle) so it doesn't have any code that may crash the app. When we try to sign the app (associate it with the store) it gives following errors - When we try to debug the app it shows nothing - or -

    Looking forward to hear back from you.

    Thank you,

    Vitaliy D.

    Monday, November 7, 2016 5:34 PM
  • Hi, looks like I have faced with the same issue:

    I am using ionic2 and when I make a build everything is ok, when I run application in debug mode - everything is ok

    But when I tried to associate the application with shote I have got success, signing is successful, but when I run . appxbundle generated file - it is white screen and no errors. I have tried to debug this again - white screen and no errors. That's why I can't find solution, because I can't find error
    I would be very happy if you can help me
    This is important to me

    I want to repeat flow with more technical details:
    1) install ionic2 dependencies (with node 4.5.0)
    2) npm install -g ionic cordova
    3) ionic start cutePuppyPics --v2
    4) cd cutePuppyPics
    5) ionic serve (works fine in browser)
    6) ionic build windows
    7) open generated CordovaApp.Windows10.jsproj file (
    8) debug is successful (Debug -> any CPU -> Local Machine)
    9) associate with store -> success
    10) Create App Packages -> Do you want to build packages to upload to the Windows Store? - No -> x86, x64, ARM
    11) Open .appxbundle file -> white screen

    Tuesday, November 8, 2016 7:53 AM
  • Hi, I know windows phone is not supported anymore. But due to client's need, we are still developing it. 

    When you build the project after associating the project to your reserved name, it will show a blank screen. 

    It's because it is looking for the widget ID that co-response to the reserved name. 
    To fix this, override the widget ID by adding the lines below to your config.xml with the Package Name value of the reserved name.

    <platform name="windows">
      <preference name="WindowsStoreIdentityName" value="12345NameofPublisher.YourReservedName" />

    Rebuild the project and it will continue with your app.

    P.S. You might also want to add. (I'm not using it)

    <preference name="WindowsStorePublisherName" value="NameOfPublisher" />

    Friday, October 13, 2017 2:18 AM
  • This worked but my preferences look like this as I am doing an ionic app so I have to also specify the first preference line which targets windows 10. Honestly have no idea why this worked but it did. 

    <preference name="windows-target-version" value="10.0"/>
    <preference name="Store Name" value="Store Value"/>

    • Edited by 1tempy1 Tuesday, April 24, 2018 12:20 PM
    Tuesday, April 24, 2018 12:19 PM
  • This was the nudge I needed to get my app on the store.  Thank you so much.

    Some combination of this preference, and confirming that I associated my app on Visual Studio 2017 with the app name that I took out on the MS store portal got me where I needed to be.

    Things I tried, for posterity

    * remove / add these new preference / add platform / rebuild
    * associate app in Visual Studio code in the store
    * New preferences were WindowsStoreIdentityName and WindowsStorePublisherName

    Good luck to anyone else!

    Thursday, July 18, 2019 12:26 PM