MS .net 1.1 setup fails -LotR:O requires



    This is my download for the .net 1.1, and I got SP1 as well to run Lord of the Rings Online, though that installation cancels because of . I've tried installing .net 2.0, 3.5, and the 4.0 versions and Lord of the Rings Online still gives the same error:

    "Please set registry key 

    HKLM\Software\Microsoft\.NETFramework\InstallRoot to point to the .NET Framework install location."


    When I started trying to fix it the error was just 1.1.4something .net is not installed, not sure about this either.


    My computer is running Vista SP2 32-bit and I've run the game on it a few years ago, I currently have no .net version installed and am trying to install 1.1 version with sp1.

    I've searched the game forums and these for any similiar problems with the specific .net version to no avail, and used the cleanup tool for .net found here

    and tried to start the game with every .net version, nothing has worked and 1.1 the one I actually need won't install.


    I get 5 or 6 errors,

    Internal Error 2908. {7D4B5591-4C80-42BB-B0E5-F2C0CEE02C1A}

    Internal Error 2908. {9922FCCE-8CAF-4A22-AA39-DA835B6C608A}

    Internal Error 2908 {67A0ABEE-BEE-0FA1-461F-A1FF-0C359C8FC6D}

    Internal Error 2908 {FF766460-2F2B-4ADE-8E9B-781040797C80}

    Internal Error 2908 {EB2A851A-66CC-4064-B8FA-B719D9F6D279}

    Internal Error 2908 {54C33516-0034-4CDB-A2DA-55C0ECEFDA7A}

    Error 1935. An error occurred during the installation of assembly 'Miscrosoft.VisualBasic,Version="7.0.5000.0",FileVersion="7.10.3052.4". Please refer to Help and Support for more information.

    And then tells me the setup failed and to contact product customer support.

    I already had an issue where windows installer being disabled wouldn't let the netfx.exe installer start and the setup failed when it unpacked, now that I get the install prompt and graphic it fails when I attempt install.

    I also tried using the "sfc /scanow" in cmd prompt with admin rights and got this huge text file, I have no idea what to do with it.

    17.22MB CBS log file



    Thursday, December 30, 2010 11:10 PM


All replies