none
Installation Problem RRS feed

  • Question

  •  

    Using Visual C# 2008 Express Edition, I developed a Window Forms and WPF application. I published the application and it installs fine on the PC (Windows XP) I developed the application on. However, when attempting to install it on another PC (Windows Vista), I encounter the following error:

    "Unable to install or run the application. The application requires the System.Core Version 3.5.0.0 be installed in the Global Assembly Cache (GAC) first

    Please contact your system administrator."

    .NET Framework 3.5 (Pre-Release Version) is installed on the Windows Vista PC.

    Any thoughts?
    Wednesday, October 17, 2007 3:55 PM

All replies

  • I suggest making sure the file versions match (or are very close).  If you had an app built against Beta1 binaries and tried to run on Beta2, or vice versay, it could cause issues like this due to different file hash or other difference.

    Thursday, October 18, 2007 11:05 PM
    Moderator