none
Microsoft Azure SDK 2.8.2 shows up as a product update even after uninstalling and reinstalling 2.8.2. RRS feed

  • Question

  • Yesterday I got a prompt telling me that I had a product/extension update for "Microsoft Azure SDK 2.8.2".  Current Version: 2.8.1.0 New Version 2.8.2.0. I hit Update, went through the motions and was surprised to see the same notification the next time I started up Visual Studio 2015.

    I ran a repair on the install, same issue.

    I uninstalled everything in Programs and Features that had to do with Azure, loaded up Visual Studio and it still gave the same message(that 2.8.1.0 was installed).

    I did a disk cleanup and used the "delete installer cache folder" option to reinstall the Microsoft Azure SDK for .NET (VS 2015) 2.8.2.  After it finished installing, I added the SDK 2.8.2 and it successfully installed.

    Loaded back up Visual Studio 2015 and there's the exact same prompt.

    How do I fix Visual Studio 2015 to recognize that I -do- have 2.8.2 not 2.8.1?

    Here's a screen shot showing VS, Add Remove Programs, and the Azure installer that I get when I hit "Update".

    https://bjmpkg.dm2303.livefilestore.com/y3mEwZtUpaqUOYdQ4tFnpZ4UvaSFlGlPDZFxVotPOSdOgJ23me3ZoMkwCnos8ciEz6TAUZDkQ6CZhSHm_FnFty_vT5vcez9wmTq223WefI41T9xWK_jXmyP5PW6NMpI9G3JlxL2NjINfHScHuCsLqKDdvh7yX7VO1qOeUXDXySzKsI?width=1872&height=981&cropmode=none

    Thursday, February 11, 2016 1:56 PM

Answers

  • I just happened to try again and they released 2.8.2.1, so if you install that you are good.
    • Proposed as answer by cwmizner Tuesday, February 16, 2016 11:28 PM
    • Marked as answer by Jason Baginski Wednesday, February 17, 2016 2:20 PM
    Tuesday, February 16, 2016 11:06 PM

All replies

  • Same issue on all computers
    Thursday, February 11, 2016 2:03 PM

  • Same issue. Annoying.
    Thursday, February 11, 2016 3:13 PM
  • Same here. It's triggering my OCD to see an open update, please fix :D
    Friday, February 12, 2016 2:18 PM
  • Same here
    Friday, February 12, 2016 6:38 PM
  • I'm also seeing this issue. Very inconvenient. Seems to be breaking deployments (Table Storage incompatibilities).
    Friday, February 12, 2016 7:44 PM
  • Same issue.
    Friday, February 12, 2016 9:16 PM
  • Same exact problem here. What in the world could it be?
    Friday, February 12, 2016 10:19 PM
  • same here
    Saturday, February 13, 2016 3:43 PM
  • same behavior
    Saturday, February 13, 2016 6:18 PM
  • Same issue on all installations
    Saturday, February 13, 2016 7:04 PM
  • Yeah, same here...
    Sunday, February 14, 2016 11:35 AM
  • Same Problem also for my VS 2015
    Sunday, February 14, 2016 3:59 PM
  • I have both VS 2013 and 2015 installed;  this fake update notification is displayed by both of them.
    Sunday, February 14, 2016 7:25 PM
  • Hello All,

    I can reproduce this issue from my side. I will try report this for you.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, February 15, 2016 8:23 AM
    Moderator
  • Same issues here
    Monday, February 15, 2016 10:34 AM
  • I also have this issue. Has been blocking our deployment since last week, highly inconvenient. Please advise on how to resolve the issue manually if possible, without waiting for a new release.
    Monday, February 15, 2016 5:20 PM
  • Same here for me
    Tuesday, February 16, 2016 8:59 AM
  • Same scenario using VS Enterprise 2015
    Tuesday, February 16, 2016 9:49 AM
  • I also get this issue with the "Tools for Universal Windows Apps (1.1.1) and Windows SDK (10.0.10240)" 
    Tuesday, February 16, 2016 12:56 PM
  • me too, seems I had this issue another time, but not sure how i solved it...
    Tuesday, February 16, 2016 10:25 PM
  • I just happened to try again and they released 2.8.2.1, so if you install that you are good.
    • Proposed as answer by cwmizner Tuesday, February 16, 2016 11:28 PM
    • Marked as answer by Jason Baginski Wednesday, February 17, 2016 2:20 PM
    Tuesday, February 16, 2016 11:06 PM
  • @cwmizner Confirmed. It's solved!
    Tuesday, February 16, 2016 11:23 PM
  • Installation of a fresh Azure SDK 2.8.2.1 helped me. I've downloaded it directly from Azure website (http://go.microsoft.com/fwlink/?linkid=518003&clcid=0x409), not as an update in VS 2015.

    Wednesday, February 17, 2016 1:52 PM
  • I just tried the update inside of VS 2015 and they've fixed it on their side.  When I first had the issue, I tried clearing my cache+cookies+installer folder and had gotten it directly from Azure website and still had the issue. They've fixed the installer.
    Wednesday, February 17, 2016 2:21 PM
  • Even the v 2.8.2.1 did not seem to solve the issue. Visual Studio 2015(Community Edition) extensions and updates dialog is showing me that my current version is 2.8.1 and 2.8.2 is available to update.

    WebPI interfaces is telling me that I have additional tasks to complete and transferring me to this page. https://azure.microsoft.com/en-us/downloads/dotnet-sdk-28/?WT.mc_id=DOTNET_SDK_28

    Any idea what needs to be done?

    --Anyone?

     
    • Edited by _ilr Thursday, February 18, 2016 12:55 AM
    Wednesday, February 17, 2016 6:45 PM
  • For the chronicle, I have tried just now (Community Edition) and, despite Extensions and Updates was still saying 2.8.2, I went on to install the update, WPI did say 2.8.2.1, and after completing the installation and reopening VS, the problem was gone.

    Julio


    Julio P. Di Egidio - Software Analyst Programmer - http://julio.diegidio.name

    Thursday, February 18, 2016 9:38 AM