none
Devenv crashes during startup initialization of Team Foundation connection

    Question

  • I have installed Visual Studio 2010 Shell on my TFS 2010 Server. It connected to the server and worked fine until I changed the TFS server id.

    Now, when it starts up, I can see the Team Explorer view with a message "Connecting to Server" and then Visual Studio abruptly ends. There is no error message and the Windows Event log shows nothing unusual.

    If I delete the VersionControl.config file and restart Visual Studio it comes up. I can connect to the Team Foundation server and all projects show up.  If I then close Visual Studio and start it up again, it abends just as before.

    I have tried:

    - Clearing all user cache in %USERPROFILE%\AppData\Local\Microsoft\Team Foundation\3.0

    - Uninstall/Reinstall

    - devenv /ResetSettings

    - devenv /log (Nothing unusual appears in the log)

    Nothing seems to work.

    Does anyone have any other suggestions?

    Visual Studio 2010

    Team Foundation 2010

    SharePoint 2010

    Windows Server  Enterprise 2008

    Richard



    • Edited by Richard Winks Thursday, April 12, 2012 1:32 PM use more familiar terminology
    Thursday, April 12, 2012 11:28 AM

All replies

  • Hello Richard,

    For your issue I feel a little confused, please kindly offer me more information about it:

    1. What do you mean of changing the TFS server id? Do you mean you changed the TFS GUID by executing the TFSConfig ChangeServerID command? Please make sure you have changed the TFS GUID successfully. Please see this article for further information about TFSConfig ChangeServerID command: http://msdn.microsoft.com/en-us/library/ee349259.aspx
    2. If you connect to the TFS server with another VS on another machine, will you get the same issue?

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Friday, April 13, 2012 2:32 AM
    Moderator
  • Vicky,

    1. Yes, that is exactly what I mean.  I used tfsconfig changeserverid command.  I'm not suggesting that this is the cause. I am just relating actions that I took between when VS worked and when it started crashing on startup.

    2. Visual Studio still works on other installations. We have at least 20 other users. I have not heard any other complaints. I have my own development system where it works just fine. The only one that does not seem to work (so far) is the VS shell that I installed on the TFS Server AT for maintenance.

    Some additional pieces of information. 

    My online searches indicated in more than one place that installing VS SP1 corrected some crash issues.  Last night I installed VS SP1 on the TFS Server AT. It did not help. It still crashes.

    If it was not apparent (from the SP 2010 installation) the TFS AT system is running 64Bit Windows Server 2008.

    Richard

    Friday, April 13, 2012 11:15 AM
  • Hello Richard,

    Thanks for providing me more information. And based on your description, I think that actually there is nothing wrong with your TFS2010 server, instead there may be something wrong with your VS2010 Shell.

    And as far as I know that in order to use VS2010 Shell (Integrated or Isolated) to connect to TFS2010 server, you need to install Team Explorer 2010. To deal with your issue, please try repairing the Team Explorer 2010. And then delete the version control cache on the TFS Server AT machine: the default location is C:\Program Files\Microsoft Team Foundation Server 2010\Application Tier\Web Services\_tfs_data. After you delete the version control cache, please restart TFS2010 server and then use VS2010 Shell to re-connect it.

    Please update me your results after you finished it.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Monday, April 16, 2012 2:52 AM
    Moderator
  • Just so we are clear.  I had installed Team Explorer 2010 on the AT.  That is what this is all about. The VS2010 shell with TE fails to start. This was working at one time. Now Visual Studio crashes at the point where it looks like it is trying to connect to the (local) TFS 2010 Server.

    I repaired VS 2010 Shell

    Clearing the TFS 2010 version control cache and seemed rather drastic (considering that the problem is related to Visual Studio) but I did it. Waiting until the weekend so that I would not be interfering with WIP.

    I restarted the TFS server.

    I tried to start VS2010 Shell (with TE) on the Server. The shell still crashes.

    Although I uninstalled the VS2010 Shell once before I would like to try again.  The last time, I uninstalled the application and then removed all the App Data in my User profile and in the ProgramData folders that applied to Visual Studio that uninstall leaves, caches and other residual stuff.  I did not clear out any registry detritus that might have been left over that might contain information that would get picked up after reinstall. Can you recommend any registry settings that might need to be cleaned out?

    Richard


    Sunday, April 22, 2012 11:09 PM
  • Hello Richard,

    I am sorry that I lose track of this case, and have you resolved your issue?

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Friday, May 04, 2012 3:38 AM
    Moderator
  • Not yet Vicky.  I will post the resolution here when I have it.

    Right now I plan on uninstalling and purging all Vistual Studio artifact that I can find (registry settings, application data, etc.) then reinstalling.

    I'm not completely dead in the water because I can access the TFS functions I need from another machine. It is just more convenient to have Team Explorer installed locally on the TFS server when I am logged on to the server itself.

    Richard

    Friday, May 04, 2012 11:07 AM
  • Hi Richard,

    I am sorry that you still have this issue. And I am trying to involve someone familiar with this topic to further look at it.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Monday, May 07, 2012 8:07 AM
    Moderator
  • I appreciate that Vicky.  I will figure it out eventually. I just thought someone else might have experienced a similar problem and already had a solution.

    This is likely to be a slow process. I have to be careful to avoid any disruption to developer activities.  I have to schedule any changes for off time and must keep downtime to a minimum.

    As I said, I have a work around, if inconvenient.

    Richard

    Monday, May 07, 2012 11:11 AM
  • Richard -

    Did you ever arraive at a solution to your problem? I have the exact same problem and with 7 hours invested so far, we are considering moving to SubVersion because connecting to TFS is what caused VS to stop responding in the first place. And it doesn't appear Vicky has provided any meaningful guidance.

    Please let me know if you are able...

    Rob

    Friday, February 01, 2013 4:25 PM
  • I never did resolve this.  It wasn't necessary after I got the server itself up and running. I did all access from a remote client.

    I have the problem only on the TFS Application Tier itself. I had installed the shell only for convenience while logged on to the server.  None of the other clients have had any similar problems.

    We've been using TFS2010 successfully otherwise.

    Richard 

    Friday, February 01, 2013 4:32 PM