locked
can't open csproj in visual studio 2008 RRS feed

  • Question

  • I am trying to open a .sln with a .csproj in it and I always get the following error:

    The project type is not supported by this installation

    I tried to re-install my visual studio 2008 and it did not work. I tried to type in devenv /setup from the command line and it didn't work.
    Please help me what to do. I want to write some codes... :(
    Tuesday, March 2, 2010 5:30 AM

Answers

  • Hello,

    You may try the following ways to see if it helps:

    a)     Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.

    b)     Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems. (For more detailed VS command line switches information, see: http://msdn2.microsoft.com/en-us/library/xee0c8y7.aspx )

    c)     Try creating a new project. Sometimes corrupted project settings can cause problems. These are project specific.

    d)     Make sure that we have the latest service pack applied.

    e)     Try to reboot the operating system to safe mode. This can help to isolate whether any other applications are interfering with Visual Studio. Note that some features (like IIS) are not available under safe mode. Please check whether this can be applied or not. In addition to safe mode, we can also try “clean boot”: How to configure Windows XP to start in a "clean boot" state http://support.microsoft.com/kb/310353 .

    f)      Try to create a new user account. This can help isolate user profile corruption related causes.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    • Marked as answer by Edwer Fang Tuesday, March 9, 2010 2:15 AM
    Tuesday, March 2, 2010 9:13 AM

All replies

  • Hello,

    You may try the following ways to see if it helps:

    a)     Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.

    b)     Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems. (For more detailed VS command line switches information, see: http://msdn2.microsoft.com/en-us/library/xee0c8y7.aspx )

    c)     Try creating a new project. Sometimes corrupted project settings can cause problems. These are project specific.

    d)     Make sure that we have the latest service pack applied.

    e)     Try to reboot the operating system to safe mode. This can help to isolate whether any other applications are interfering with Visual Studio. Note that some features (like IIS) are not available under safe mode. Please check whether this can be applied or not. In addition to safe mode, we can also try “clean boot”: How to configure Windows XP to start in a "clean boot" state http://support.microsoft.com/kb/310353 .

    f)      Try to create a new user account. This can help isolate user profile corruption related causes.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    • Marked as answer by Edwer Fang Tuesday, March 9, 2010 2:15 AM
    Tuesday, March 2, 2010 9:13 AM
  • Problem with the env, regardless if u are using xnu or not the following fixed for me so try for yourself

     

    http://blogs.msdn.com/b/astebner/archive/2009/08/30/9889189.aspx

    For XNA Game Studio Express 1.0 and XNA Game Studio 2.0:

    • For Visual Studio 2005 Standard Edition and higher:  "%ProgramFiles%\Microsoft Visual Studio 8\Common7\IDE\devenv.exe" /ResetSkipPkgs
    • For Visual C# 2005 Express Edition:  "%ProgramFiles%\Microsoft Visual Studio 8\Common7\IDE\vcsexpress.exe" /ResetSkipPkgs

    For XNA Game Studio 3.0 and 3.1:

    • For Visual Studio 2008 Standard Edition and higher:  "%ProgramFiles%\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe" /ResetSkipPkgs
    • For Visual C# 2008 Express Edition:  "%ProgramFiles%\Microsoft Visual Studio 9.0\Common7\IDE\vcsexpress.exe" /ResetSkipPkgs

    For XNA Game Studio 4.0:

    • For Visual Studio 2010 Professional Edition and higher:  "%ProgramFiles%\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe" /ResetSkipPkgs
    • For Visual C# 2010 Express Edition:  "%ProgramFiles%\Microsoft Visual Studio 10.0\Common7\IDE\vcsexpress.exe" /ResetSkipPkgs
    • For Visual Studio 2010 Express Edition for Windows Phone:  "%ProgramFiles%\Microsoft Visual Studio 10.0\Common7\IDE\vpdexpress.exe" /ResetSkipPkgs

    Note – the above command lines assume that you have installed Visual Studio to the default location and that you are using a 32-bit version of Windows.  You may need to modify the command lines depending on where Visual Studio is installed on your system.  You should use %ProgramFiles(x86)% instead of %ProgramFiles% if you are using a 64-bit version of Windows.

    <update date="11/16/2009"> Added a link to a Japanese version of the information in this blog post.  Thanks Ito! <update>

    <update date="1/29/2011"> Added information about Visual Studio 2010 and XNA Game Studio 4.0. </update>

     

    -Miles E

    Friday, July 22, 2011 3:15 AM