none
Please help - Error5 Opening registry key

    Question

  • I am trying to create a web site on a remote server within my LAN using Visual Studio 2005. When trying to connect to IIS I get this error.

    Unable to create Web 'http://web'reports/test' Server error: Error5 opening registry key "SOFTWARE/classes/application".

    Wednesday, February 01, 2006 7:32 PM

Answers

  • Given this is a local machine, I assume you have some control over it... have you tried taking the advice of this KB article: http://support.microsoft.com/?kbid=833699 ?
    Wednesday, February 01, 2006 8:59 PM
    Moderator
  • Well I am getting close to the same error, but in Frontpage.

    Server error: Error 5 opening registery key "SOFTWARE\Classes\.aom".

    Have a feeling they are closely related.

    Please if somebody has the solution, would love to know what it is.

    Tuesday, February 07, 2006 3:40 AM

All replies

  • Given this is a local machine, I assume you have some control over it... have you tried taking the advice of this KB article: http://support.microsoft.com/?kbid=833699 ?
    Wednesday, February 01, 2006 8:59 PM
    Moderator
  • Yes I have tried that but it did not work.
    Wednesday, February 01, 2006 10:01 PM
  • Well I am getting close to the same error, but in Frontpage.

    Server error: Error 5 opening registery key "SOFTWARE\Classes\.aom".

    Have a feeling they are closely related.

    Please if somebody has the solution, would love to know what it is.

    Tuesday, February 07, 2006 3:40 AM
  • I have the same problem. It came after the installation of . Net Framework 2. When I go to IIS and go to the Frontpage server extensions and do a "Upgrade virtual server with FrontPage Server Extensions 2002" everything works fine for 1 - 2 hours. After some time I have the same error.

     

     

    Friday, March 10, 2006 1:10 PM
  • Things I tested:

    Clean computer with newely installed frontpage 2000 gave the same error.

    The new visual web developer 2005 express edition gave not a error

    Deleted the installation of frontpage extensions on the server and after a reboot installed the extensions  

     

     

    Saturday, March 11, 2006 5:08 PM
  • At last solved

     

    On the server change the permissions

    hkey_local_machine/software/classes/.applications

    add permissions to the following users

    administrators, system, users and give them permissions to access.

     

    Test it and if you set it right you get another key

    hkey_local_machine/software/classes/.appref-ms

    change the permission

    Test it and if you set it right you get another key

    hkey_local_machine/software/classes/.inv

    change the permission

     

    It worked for me.

    Sunday, March 12, 2006 11:11 AM