none
Cannot sign in with Visual Studio 2017 Community version RRS feed

  • Question

  • When I try to Sign In using Visual Studio 2017 or Windows 10 IoT Dashboard, I get
    the page login.microsoftonline.com/cookiesdisabled, and a error diaglog box,
    which are both shown below:

    (!)  An error has occurredin the script on this page.
    Line:       20
    Char:     198
    Error:     '$loader' is undefined Code:     O
    URL:      https:/ Aogin.microsoftonline.com/ cookiesdisabled

    Doyou wantto continue running scripts on this page?



    Page this refers to:

    Something went wrong

     Microsoft
    We can't sign you in.
    Your browser is currently set to block cookies. You  need to allow cookies to use this 
    service.

    Cookies are small text files sto red on your co mp uter  that  tell u s w hen  yo u're signe d in. 
    To learn  how  to  all ow cookies, check the online help in your web browser.

    I have of course enabled all cookies in IE11 and Chrome, my two browsers.

    Has anyone had this problem?


    Wednesday, May 30, 2018 1:51 AM

Answers

  • Someone in another forum found a solution that helped me as well. Start VS 2017 and be quick to click on the user feedback menu up in the right corner and then Report a Problem.

    I first got the usual license dialog where I was asked to login but waiting a bit I then got the user feedback window where I clicked the sign in link. I got logged in and when closing the user feedback dialog I was successfully logged in to VS 2017!

    Hope it helps!

    • Marked as answer by Michel805 Monday, June 10, 2019 8:51 PM
    Monday, June 10, 2019 9:23 AM

All replies

  • Hi,

    Open Internet Explorer and click the Tools button. Next click Internet Options and select the Privacy tab. This is where your "Cookies" settings are...

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, May 30, 2018 6:45 AM
  • My question indicates I had already done what you suggest, but thanks anyway.
    Wednesday, May 30, 2018 2:44 PM
  • Yes, running into the same problem. My hunch is that one of the corporate domain security policies is preventing cookies in IE. I'm beyond frustrated at this point.
    Wednesday, August 1, 2018 9:46 PM
  • Hi Michel,

      Having same issue here. Did you manage to fix this?

    Thanks

    Thursday, January 3, 2019 7:04 PM
  • No, and I really do think it is a problem of our settings.  Microsoft, do you care about this?!
    Friday, May 3, 2019 4:29 PM
  • Someone in another forum found a solution that helped me as well. Start VS 2017 and be quick to click on the user feedback menu up in the right corner and then Report a Problem.

    I first got the usual license dialog where I was asked to login but waiting a bit I then got the user feedback window where I clicked the sign in link. I got logged in and when closing the user feedback dialog I was successfully logged in to VS 2017!

    Hope it helps!

    • Marked as answer by Michel805 Monday, June 10, 2019 8:51 PM
    Monday, June 10, 2019 9:23 AM
  • Works like a charm!  Thank you Riddler7777.  Microsoft still needs to fix this.
    Monday, June 10, 2019 8:46 PM
  • Make the cookies in the browser blocked, then enable them again - it worked for me.
    Tuesday, August 27, 2019 1:09 PM