none
how to set physical path of IIS app in Web Deploy Publish Profile RRS feed

  • Question

  • I'm setting up a PublishProfile for a web service project, and am able to get it to deploy to IIS, but I'm unable to find a way to over-ride the default physical path, so it always ends up in C:\inetpub\wwwroot\...

    Is there any way to do this?  I've tried setting RemoteSitePhysicalPath (<RemoteSitePhysicalPath>D:\DEV\Services\</RemoteSitePhysicalPath>), but I just get the warning:  "Setting value to $(RemoteSitePhysicalPath) might not work if IIS setting is not included" -- and that's true, it doesn't work, but I can't seem to find a way to get it working.

    Thanks!

    Wednesday, March 9, 2016 11:58 PM

Answers

  • Hi MikeDowd,

    >>I've tried setting RemoteSitePhysicalPath (<RemoteSitePhysicalPath>D:\DEV\Services\</RemoteSitePhysicalPath>), but I just get the warning:  "Setting value to $(RemoteSitePhysicalPath) might not work if IIS setting is not included"

    RemoteSitePhysicalPath must be a virtual directory in IIS. So you need to add this folder as virtual directory on IIS.

    Best Regards,
    Li Wang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, March 10, 2016 2:51 AM