locked
Release burndown - Sprints (iterations) are not ordered by date - TFS 2012 - Scrum template 2.0 RRS feed

  • Question

  • When I display Release burndown report in TFS 2012, the sprints are not ordered and thus I cannot see trend of remaining story points.

    Does anyone experience the same issue? Is there any fix to this problem?

    For reporting we use SQL Server 2012 and all services (TFS, SQL Server, SQL Analysis Services and Reporting Services) are installed on single server.

    Thank you for your help.


    MCAD

    Wednesday, November 21, 2012 1:41 AM

All replies

  • Hi Duracellko, 

    Thanks for your post.

    I’m currently looking into this issue and will give you an update as soon as possible. But I think there’s no default way to order by sprint in default Release Burndown report, please refer to this document: http://msdn.microsoft.com/en-us/library/ff731579.aspx.   


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, November 22, 2012 12:06 PM
    Moderator
  • Hello John and Duracellko,

    I am having the same problem. Our dates are in chronological order, but our sprints are not displayed in any logical order on the release burndown report.

    Our team is using VS 2012 with the Scrum 2.0 Template.

    The link that you posted John did not help resolve the problem. If this issue has any resolution, please let me know.

    Thanks,

    Josh

    Wednesday, December 12, 2012 4:30 PM
  • Hello,

    I would encourage you to use Excel to produce these types of reports.  I have had too many challenges with the SSRS Reports.  I can get all the information I need using Excel. You can even have TFS produce a report from a query to get you started.  Create a Query in TFS, then select to Create a Report in Excel (the query must be a flat query to get this option). 

    Using Pivot Tables in Excel is also very powerful and relatively easy to use.

    After struggling with TFS Reports for months, I've now switched over to Excel.

    Just my two-bits.

    - Bruce


    Bruce

    Thursday, December 13, 2012 9:30 PM
  • Yeah, that makes the report of marginal value.  Here's the solution I implemented:

    Open the report in Report Builder

    Expand the Datasets Folder in the Report Data section on the left

    Right click on dsSprints, choose Properties

    Update the Query as follows:

    Insert these lines

         where wi.StartDate > '2012-11-15'  -- (Optional) only include sprints after a certain date
         ORDER BY wi.StartDate  -- order the sprints by date

    Right before this:

         END ELSE BEGIN
          -- Return "dummy values" that will a) prevent further ...

    Good luck,

    Brett

    Thursday, April 11, 2013 5:44 PM
  • Select your Chart to bring up the Chart Data pane. Click the drop down for your Category Group properties. Select the Sorting tab. Add the Sprint start date as the sort on column.

    "You will find a fortune, though it will not be the one you seek." - Blind Seer, O Brother Where Art Thou
    Please Mark posts as answers or helpful so that others may find the fortune they seek.

    Friday, April 12, 2013 6:45 PM
  • Were you able to resolve this issue? If so, please post/mark the answer so others can more easily find a solution to this problem.

    "You will find a fortune, though it will not be the one you seek." - Blind Seer, O Brother Where Art Thou
    Please Mark posts as answers or helpful so that others may find the fortune they seek.

    Monday, April 22, 2013 8:47 PM