none
Xaml Editor Crashes after Visual Studio 2008 SP1

    Question

  • After installation of the Service Pack 1, opening existing XAML files in Visual Studio results in a hard crash of Visual Studio 2008.  It attempts to open the XAML editor, the Visual Studio 2008 disappears.

    The event log as the following entry:

    .NET Runtime version 2.0.50727.3053 - Fatal Execution Engine Error (6FE55E00) (80131506)

    I've not found any reference to this specific error on any error report to date.

    The environment is:

    • Vista SP1 x64
    • Direct Upgrade from Visual Studio 2008 (no betas of Service pack 1)
    • No SilverLight Beta
    • NO KB944899 Hot Fix on the machine
    • Clean install as far as I can tell.

    Unlike some other reports, I'm unable to create and edit a new XAML file either.  Editing and existing file or creating a new file immediately crashes the IDE.

    What steps can I take to debug this problem?  I have 5 other developers with the same set-up and I don't want to turn them loose on the upgrade until we get to the bottom of the problem.

    Wednesday, August 13, 2008 9:53 PM

Answers

  • I also had the same issue. I heard that using Windows Update helped, but on trying it, it still did not work.

    I found that opening the toolbox panel before opening a project helped. This still caused the IDE to stop responding for a few minutes, but it eventually sorted itself out. Opening a project afterwards showed that it had indeed been fixed.

    • Marked as answer by Jeff Odell Thursday, August 14, 2008 2:31 PM
    • Marked as answer by Jeff Odell Thursday, August 14, 2008 2:33 PM
    • Marked as answer by Jeff Odell Thursday, August 14, 2008 2:34 PM
    • Marked as answer by Jeff Odell Thursday, August 14, 2008 2:34 PM
    Thursday, August 14, 2008 1:03 AM

All replies

  • I also had the same issue. I heard that using Windows Update helped, but on trying it, it still did not work.

    I found that opening the toolbox panel before opening a project helped. This still caused the IDE to stop responding for a few minutes, but it eventually sorted itself out. Opening a project afterwards showed that it had indeed been fixed.

    • Marked as answer by Jeff Odell Thursday, August 14, 2008 2:31 PM
    • Marked as answer by Jeff Odell Thursday, August 14, 2008 2:33 PM
    • Marked as answer by Jeff Odell Thursday, August 14, 2008 2:34 PM
    • Marked as answer by Jeff Odell Thursday, August 14, 2008 2:34 PM
    Thursday, August 14, 2008 1:03 AM
  • Admittedly, when I first read Michael's fix using the the Toolbox pane, the solution seemed unlikely.  But I tried it this morning and it worked!  To clarify:

    1. I opened up Visual Studio 2008 SP1.
    2. I opened up and pinned the Toolbox pane.
    3. I opened up the project where the XAML editor was failing.
    4. I opened up one of the XAML files, and, as Michael described, it spun a little bit.  In my case - maybe 8-10 seconds.
    5. The designer pane filled in with my XAML form displayed.

    As of this point forward, I can open up the project with or without the Toolbox pane open and the designer works fine.  Something about the procedure resets that pane and allows it to work properly.

    Thank you Michael!

    • Edited by Jeff Odell Thursday, August 14, 2008 2:32 PM spelling
    Thursday, August 14, 2008 2:31 PM
  • Hi Guys,

    I have the exact same problem as explained above, but the solutions are not working. When I first installed it everything was fine, but now out of the blue all XAML files crash VS 2008 Sp1 hard. HELP!

    NEM
    Thursday, August 14, 2008 4:53 PM
  • Ok I got it fixed. I had to blow away my import export custom settings, and reload them. Then close every component window in Visual Studio (Solution Explorer, Team Explorer ETC).  Then reopened what I needed and that fixed it.

    NEM
    Thursday, August 14, 2008 5:13 PM
  • BTW this keeps happening and now my fix is no longer working all the time. What the heck is going on with VS 2008 SP1? 
    Thursday, August 14, 2008 11:54 PM
  • As it turns out through Microsoft support it is Power Commands 2008 that causes the problem for me. As soon as it was uninstalled the errors when away. They are looking into now and searching for hot fixes or workarounds. So Power Commands 2008 has compatibility problems with VS 2008 SP1 . Hope this helps some one!

    Another thread on this.

    http://forums.msdn.microsoft.com/en-US/vssetup/thread/e2434065-9921-4861-b914-9cc9d6c55553


    NEM
    • Proposed as answer by Nick McCready Tuesday, August 26, 2008 8:24 PM
    Friday, August 15, 2008 6:49 PM
  • I'm having the same problem. I can't open any XAML files unless they are pure ResourceDictionaries. I could for a while open other files as well but now... It just crashes.

    I uninstalled the Power Commands before installing VS2008 SP1 so that is not the cause of the crash for me. This is not good!
    Karin, Stockholm
    • Edited by Karin P Monday, September 08, 2008 5:13 AM typo
    Monday, September 08, 2008 5:12 AM
  • Do you have other third party applications? If so try removing them. Otherwise I would contact Microsoft Technical Support.
    Monday, September 08, 2008 2:03 PM
  • I must have done something wrong when applying the steps described above. Now it is fixed.  If I take a clean project and make sure no files are opened when the studio starts I'm fine. I still can't use the designer, but I know why and I never use it anyhow. I started with XAML before the designer worked ok so I'm fine with writing the XAML directly. It's just a shame that I need to still have it in the background in order for code-assist to work. It takes too long to load.
    Karin, Stockholm
    Tuesday, September 09, 2008 7:10 AM
  • Not sure if you have done this already, as I do not use the designer in VS 2008. Go to Tools/Options/TextEditor/XAML/Miscellaneous, check the "Always open open documents in full XAML view"

    Now you should be directed to straight XAML and the designer loads in the background.

    This is slightly faster, but I agree waiting for the designer to load is annoying, especially if all you need it for is code completion.
    Tuesday, September 09, 2008 5:16 PM
  • Monday, February 16, 2009 2:12 PM
  •  
    Philipp.Munin said:

    I have this problem and nothing helps me. Here is my problem http://social.msdn.microsoft.com/Forums/en-US/vswpfdesigner/thread/6c7a9c6c-d565-46ae-83ed-d39998c0fd41/



    Hi Philipp,

    I have written an add-in that attempts to work around one common cause of VS crashes by preloading referenced assemblies when opening solutions/projects (and allowing the load order to be changed if necessary). You can read more (and download it) from http://www.huagati.com/ProjectLoader/

    If you try it out, please report back whether it fixes (or doesn't fix) the problem for you.

    Best regards,
    Kristofer
    Kristofer - Huagati Systems Co., Ltd. - web: www.huagati.com - blog: blog.huagati.com - twitter: twitter.com/KristoferA
    Wednesday, February 25, 2009 8:36 AM
  • With regards to my previous post in this thread about "Always Open Documnets in full XAML view" this solution is way better and faster.

    ////////////////////

    Have you tried disabling VS2008 from opening in Design View. The design view is not good anyway for XAML which is why you should get blend or just do it manually.

    To do this I suggest going here :  http://weblogs.asp.net/fmarguerie/archive/2009/01/29/life-changer-xaml-tip-for-visual-studio.aspx  .
    Wednesday, February 25, 2009 3:19 PM

  • Thanks Nick! Works for me. I am not going back to Visual studio editor for XAML.
    Tuesday, April 28, 2009 4:02 PM
  • I did it without WPF designer, read the post carefully:
    http://social.msdn.microsoft.com/Forums/en-US/vswpfdesigner/thread/6c7a9c6c-d565-46ae-83ed-d39998c0fd41/

    >> 1) open just 3 primitive XAML files in XAML editor (not WPF designer)

    More over i noticed this bug not with XAML only but with App.Config too! If i close app.config with another editors many times - i'll get invisible intellisense, until VS2008 restarts. So i guess the problem is in XML editor.

    Wednesday, April 29, 2009 6:49 PM
  • I also have had this problem.  I always resolve it by removing and then re-adding references to PresentationFramework and PresentationCore.  That has consistently eliminated the issue for me...until the next time I re-open Visual Studio. 
    Monday, June 01, 2009 2:54 PM
  • Oh... it seems it works for me too. It is very strange, but it saves me hours of anger. Thanks for this very "intuitive" solution.
    Thursday, January 14, 2010 3:45 PM
  • I found a way of solving this problem when trying to solve another one related to the toolbox.

    See my post at http://social.msdn.microsoft.com/Forums/en/vssetup/thread/490c9f52-f0c3-4fd3-9770-b8be9e0fd9d9

    Basically here is what the post says:

    I went to C:\Documents and Settings\MYUSERNAME\Local Settings\Application Data\Microsoft\VisualStudio\9.0

    There, I created a temp folder and moved in it the 4 toolbox*.tbd files into a temp folder.

    Then I restarted visual and not only did it reset my toolbox with long missing custom items this also solved a problem of random crashes when opening xaml ui files in wpf projects.

    Pasx

    Wednesday, December 01, 2010 11:22 PM
  • I found a way of solving this problem when trying to solve another one related to the toolbox.

    See my post at http://social.msdn.microsoft.com/Forums/en/vssetup/thread/490c9f52-f0c3-4fd3-9770-b8be9e0fd9d9

    Basically here is what the post says:

     

    I went to C:\Documents and Settings\MYUSERNAME\Local Settings\Application Data\Microsoft\VisualStudio\9.0

    There, I created a temp folder and moved in it the 4 toolbox*.tbd files into a temp folder.

    Then I restarted visual and not only did it reset my toolbox with long missing custom items this also solved a problem of random crashes when opening xaml ui files in wpf projects.

    Pasx

     

    Yep, that helped me! Thank you!
    Wednesday, December 29, 2010 12:12 PM