none
Can different versions of Test Agent be run 'side-by-side' on the same machine? RRS feed

  • Question

  • Can different versions of Test Controller and Test Agent (2010, 2015) be run 'side-by-side' on the same machine?

    Alternatively, can Visual Studio 2015 use Test Controller version 2010 to run load tests?

    Tuesday, April 5, 2016 3:53 PM

Answers

  • Hi JN.QA.Prog,

    >> Can different versions of Test Controller and Test Agent (2010, 2015) be run 'side-by-side' on the same machine?

    No, we can't install different versions of Test Agents on the same machine. I have tried to install Test Agent 2015 after I installed Test Controller and Test Agent 2010, it tell me to uninstall previous version of agent.

    >>Alternatively, can Visual Studio 2015 use Test Controller version 2010 to run load tests?

    Visual Studio 2015 can't use Test Controller version 2010. After I configure my Test Controller and Test Agent on my Visual Studio 2015 machine and I try use Test Controller 2010 in my load test, I get follow error message.

    The following error was received:

    Cannot communicate with the Controller due to version mismatch

    So I suggest you use Test Controller and Test Agent 2013 with Visual Studio 2015. Please refer to following article to configure the Test Controller and Test Agent 2013.

    https://msdn.microsoft.com/en-us/library/vs/alm/test/lab-management/test-machines/install-configure-test-agents

    Best Regards,
    Weiwei

    • Marked as answer by JN.QA.Prog Wednesday, April 6, 2016 12:36 PM
    Wednesday, April 6, 2016 8:30 AM
    Moderator

All replies

  • Hi JN.QA.Prog,

    >> Can different versions of Test Controller and Test Agent (2010, 2015) be run 'side-by-side' on the same machine?

    No, we can't install different versions of Test Agents on the same machine. I have tried to install Test Agent 2015 after I installed Test Controller and Test Agent 2010, it tell me to uninstall previous version of agent.

    >>Alternatively, can Visual Studio 2015 use Test Controller version 2010 to run load tests?

    Visual Studio 2015 can't use Test Controller version 2010. After I configure my Test Controller and Test Agent on my Visual Studio 2015 machine and I try use Test Controller 2010 in my load test, I get follow error message.

    The following error was received:

    Cannot communicate with the Controller due to version mismatch

    So I suggest you use Test Controller and Test Agent 2013 with Visual Studio 2015. Please refer to following article to configure the Test Controller and Test Agent 2013.

    https://msdn.microsoft.com/en-us/library/vs/alm/test/lab-management/test-machines/install-configure-test-agents

    Best Regards,
    Weiwei

    • Marked as answer by JN.QA.Prog Wednesday, April 6, 2016 12:36 PM
    Wednesday, April 6, 2016 8:30 AM
    Moderator
  • Thank you! Knowing these details helps me a lot.
    Wednesday, April 6, 2016 12:37 PM