locked
failed to install because of system error 0x80131107...help! *SOLVED RRS feed

  • General discussion

  • *CASE CLOSED

     

    Hi, new to this so bear with me.

     

    i was trying to install visualbasic express version 2.0.50727.42  for my pc. and found after all the modules were downloaded that .NETfrmwork 2.0 failed to install( causing all the other modules to fail too)  the fail error is as follows

     

    EventType : visualstudio8setup     P1 : 183     P2 : 8.0.50727.42_rtm_x86ret
    P3 : msi     P4 : inst     P5 : f    
    P6 : ca_installassemblydef.3643236f_fc70_11d3_a536     P7 : -     P8 : 1603
    P9 : -     P10 : -    

     

    it sent details to microsoft using various other log info that i can't seem to find on my pc.

     

    i've ran the MS baseline analyser to check if everything is up to date and is ok.

    I uninstalled .NET 1.1 from the add/remove programs in case this was the problem, even ran the 2.0 uninstall utility.

    checked msi version= 3.1.4000.2435

     

    pls help?

     

    event log:

     

    msiinstall er
    Product: Microsoft .NET Framework 2.0 -- Error 25015.Failed to install assembly 'C:\WINDOWS\Microsoft.NET\Fram ework\v2.0.50727\Microsoft.Vis ualBasic.Vsa.dll' because of system error: 0x80131107

     

     

     

    basic System INFO:

     

    System Information report written at: 09/19/07 09:50:41
    System Name: FRS180
    [System Summary]

    Item Value 
    OS Name Microsoft Windows XP Professional 
    Version 5.1.2600 Service Pack 2 Build 2600 
    OS Manufacturer Microsoft Corporation 
    System Name FRS180 
    System Manufacturer Compaq Presario 061 
    System Model RF786AA-ABU SR2019UK GB680 
    System Type X86-based PC 
    Processor x86 Family 15 Model 79 Stepping 2 AuthenticAMD ~2204 Mhz 
    BIOS Version/Date Phoenix Technologies, LTD  3.07, 02/08/2006 
    SMBIOS Version 2.4 
    Windows Directory C:\WINDOWS 
    System Directory C:\WINDOWS\system32 
    Boot Device \Device\HarddiskVolume1 
    Locale United Kingdom 
    Hardware Abstraction Layer Version = "5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)" 
    User Name beebop\Compaq_Administrator 
    Time Zone GMT Daylight Time 
    Total Physical Memory 2,048.00 MB 
    Available Physical Memory 1.26 GB 
    Total Virtual Memory 2.00 GB 
    Available Virtual Memory 1.94 GB 
    Page File Space 3.85 GB 
    Page File C:\pagefile.sys 

     

    *update*

    OK just got this sorted.  previous versions of .NET framework uninstalls left fragments still in the registry ( not seen anything like that since the early days of windows)

     

    visited Aarons Blog  http://blogs.msdn.com/astebner/archive/2005/10/11/479928.aspx

     

    He has a neat wee uninstall utility (well done Aaron, it worked 1st time) as well as other handy troubleshooting tips.

     

    *Addenda

    if your system re-boots to minimum resolution don't panic. just re-install your video drivers(NVIDIA 7300 in my case)

     

    *CASE CLOSED

     

     

     

    Wednesday, September 19, 2007 9:06 AM

All replies