locked
Installation - Failed to connect to SQL database. RRS feed

  • Question

  • When trying to install the TFSIntegrationTools (25 march 2011) I select the current SQL server instance on the machine (not the default SQLExpress).

    When it starts to 'Executing SQL Strings' it throws an error stating 'Failed to connect to SQL database. (-2147467259 master )

    At this point, I can only click OK and then the installer reverts everything.

    Using SSMS (Microsoft Sql Server Management Studio) I can connect to the instance and query the master database using the same account.

     

     


    MCP TFS 2010
    Professional Scrum Developer Trainer - Scrum.org
    Wednesday, May 11, 2011 9:43 AM

All replies

  • What are you entering at the database prompt?   Just the current machine name (to use the default SQL server instance)?   Or <machine name>\<instance name>?  Or something else?   Are you an administrator of that SQL server instance?
    Wednesday, May 11, 2011 1:36 PM
    Moderator
  • I'm just using the 'default' instance of SQL Server, so I tried 'localhost', '<machinename>' and '.' : all give the same error.

    I've verified using SSMS that I am indeed an administrator on the SQL server.

    I'm doing this on a VM (the one available here: http://blogs.msdn.com/b/briankel/archive/2010/06/25/now-available-visual-studio-2010-rtm-virtual-machine-with-sample-data-and-hands-on-labs.aspx)

    I have also run the Installation on my windows 7 install and that actually does run using the default 'localhost\sqlexpress'.


    MCP TFS 2010
    Professional Scrum Developer Trainer - Scrum.org
    Wednesday, May 11, 2011 2:03 PM
  • I got this error, so instead of LOCALHOST\SQLEXPRESS I installed it to MYCOMPUTERNAME\SQLEXPRESS  

    This worked for me

    • Proposed as answer by Patrick Rehder Tuesday, October 2, 2012 7:02 AM
    • Marked as answer by Rudi - Euricom Tuesday, October 2, 2012 7:19 AM
    • Unmarked as answer by Rudi - Euricom Tuesday, October 2, 2012 7:19 AM
    • Unproposed as answer by Rudi - Euricom Thursday, April 10, 2014 12:11 PM
    Wednesday, May 11, 2011 3:13 PM
  • I am getting the same error, and I have tried the 'machinename\instancename' with no luck.  I am on Win7 SP1 with SQL Server 2008 R2.  my account is a sysadmin role - so I'm not sure why this is failing.  any help is appreciated, thanks!
    Wednesday, March 21, 2012 8:26 PM
  • I'm also seeing this error.  An assistance would be appreciated

    Matt Ruwe

    Thursday, September 20, 2012 7:28 PM
  • I got same issue and got it resolve by replacing 'localhost' with '.'


    Thursday, January 14, 2016 12:44 AM
  • I'm getting the same thing.  If I enter a bad server\instance name, installation doesn't get past the screen with that field.  But every combination I've tried goes through 80% of the installation and fails on "Executing SQL Strings" with this error.  And I've tried all these valid combinations because I have the default instance and SQL Express both installed:

    .

    localhost

    <machine name>

    .\SQLExpress

    localhost\SQLExpress

    <machine name>\SQLExpress


    Also, I've run SQL Profiler and watched the queries that go through to the database engine.  I see the database get created, but then nothing happens when it reaches the step where it fails.  Is it failing connecting to the database it just created?
    • Edited by TMGirvin Sunday, October 22, 2017 7:41 PM
    Sunday, October 22, 2017 7:34 PM