CommunicationObjectFaultedException was unhandled.


  • The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state.


    I have upgraded my cloud to 1.3, i have checked out the config file still getting the same error. 

    I saw the help given in some forums but didnt help..

    i have reinstalled everything still the error remains the same..Can anyone help!!!




    Monday, December 13, 2010 9:57 AM


  • Hello, do you mean Windows Azure SDK 1.3? Are you using source control? The most common cause to this issue is web.config is set to read only. This usually occurs if you're using source control like TFS, as after a file is checked in, it is marked as read only on the client side automatically. This is a known Windows Azure bug. Please check if this is the cause to your problem. If it's still not solved, please ask the question on the Windows Azure forum.
    Lante, shanaolanxing This posting is provided "AS IS" with no warranties, and confers no rights.
    Windows Azure Technical Forum Support Team Blog
    • Marked as answer by Yi-Lun Luo Friday, December 17, 2010 9:10 AM
    Tuesday, December 14, 2010 5:22 AM