none
Lightswitch apps hosted in Sharepoint 2013 RRS feed

  • Question

  • Is it possible to host the current preview release of Lightswitch apps on Sharepoint 2013 on premise or only O365?  If On premise is not supported is this coming so that applications we currently develop could be converted to be hosted with our on premise sharepoint 2013?
    Sunday, January 20, 2013 6:00 AM

Answers

  • It's not supported in Preview 2, but you will be able to host LightSwitch apps on SharePoint 2013 with the final release. SharepPoint 2013 was still a moving target at the time the preview was released.

    Regards,


    Steve Hoag Microsoft aka the Lights Witch (IEnumerable of Newt)

    • Proposed as answer by Steve HoagModerator Monday, January 21, 2013 6:33 PM
    • Marked as answer by Angie Xu Tuesday, February 5, 2013 1:49 AM
    Monday, January 21, 2013 6:33 PM
    Moderator

All replies

  • Beth speaks about her recent experience creating SharePoint apps with LightSwitch here, Get Started Building SharePoint Apps in Minutes with LightSwitch, but she doesn't mention on premise.

    Yann - LightSwitch Central - Click here for FREE Themes, Controls, Types and Commands
     
    Please click "Mark as Answer" if a reply answers your question. Please click "Vote as Helpful" , if you find a reply helpful.
     
    By doing this you'll help others to find answers faster.

    Monday, January 21, 2013 2:43 AM
    Moderator
  • Yes I have read that article and many others and there is never any mention of on premise.  We are simply looking for some direction.  If and when it will be supported.

    Monday, January 21, 2013 2:52 PM
  • It's not supported in Preview 2, but you will be able to host LightSwitch apps on SharePoint 2013 with the final release. SharepPoint 2013 was still a moving target at the time the preview was released.

    Regards,


    Steve Hoag Microsoft aka the Lights Witch (IEnumerable of Newt)

    • Proposed as answer by Steve HoagModerator Monday, January 21, 2013 6:33 PM
    • Marked as answer by Angie Xu Tuesday, February 5, 2013 1:49 AM
    Monday, January 21, 2013 6:33 PM
    Moderator
  • I'm using VS2012 Update 3 and I'm having trouble figuring out how to make the above scenario work.  My local SP013 dev VM is:

    VS2012.3, SP2013 Server, SQL Server all running on single "developer" VM.

    I can:

    1. create a new LS HTML project

    2. connect to a SP list and create a new DataSource

    3. create screens

    ...but when I F5, I get an IIS permissions error (see below).  Any pointers to how to make this simplest of simple environments work for LS/HTML apps running on a local SP2013 VM?


    HTTP Error 401.0 - Unauthorized

    You do not have permission to view this directory or page.

    Most likely causes:
    •The authenticated user does not have access to a resource needed to process the request.

    Things you can try:
    •Check the failed request tracing logs for additional information about this error. For more information, click here.

    Detailed Error Information:

    Module
       LightSwitchModule

    Notification
       AuthorizeRequest

    Handler
       PageHandlerFactory-Integrated-4.0

    Error Code
       0x00000000

    Requested URL
       https://localhost:44300/SharePointLaunch.aspx?SPHostUrl=http%3A%2F%2Fdev%2Esp2013%2Elocal&SPLanguage=en%2DUS&SPClientTag=0&SPProductNumber=15%2E0%2E4420%2E1017

    Physical Path
       C:\Users\Administrator\documents\visual studio 2012\Projects\LSTasks144\LSTasks144\Bin\Debug\SharePointLaunch.aspx

    Logon Method
       Anonymous

    Logon User
       Anonymous

    Request Tracing Directory
       C:\Users\Administrator\Documents\IISExpress\TraceLogFiles\LSTASKS144


    Xpert Search Agents for Microsoft web sites: http://www.parallelspace.net/MicrodeX

    Thursday, September 12, 2013 8:20 PM
  • Are there any updates to this?  I am using VS 2013 Update 3 and SharePoint 2013 w/Updates applied through 09/2014.  I am getting an error when trying to build a LS Cloud Business App.  I am building this on my Development VM (based on Criical Path's v 3.0 VM).   I'm getting the following error when trying to develop/debug:

    value cannot be null. Parameter name: sharePointHostData


    Cheers, Alan

    Friday, October 24, 2014 12:21 PM