locked
WHAT THE *...!!! Visual Studio 2010 Macros Not Working after ******* Windows Update RRS feed

  • Question

  • I installed windows updates on two my pc (last night at home and office) and ...
    visual studio macros will not working. what the...i used visual studio 2010 service pack1.

    my windows updates list.

    * feb-2-2014
    KB2817369
    KB2901112
    KB2919469
    KB2916036
    KB2898869
    KB2898857
    KB2843630
    KB2901126
    KB2775360
    KB2862973
    KB2909210
    KB2817396
    KB2909921
    KB2912390
    KB2911501
    KB2760601
    KB2687567
    KB2837595
    KB2837583
    KB915597


    • Edited by Paulesoft Thursday, February 13, 2014 1:41 AM
    Thursday, February 13, 2014 1:41 AM

Answers

All replies

  • * problem fix
    KB2898869, KB2901126 uninstall...

    what the...
    Thursday, February 13, 2014 2:10 AM
  • Hi,

    It seems that they are used for Microsoft .NET Framework 4.5.1.

    Reference:

    http://support.microsoft.com/kb/2898869/en-us

    http://support.microsoft.com/kb/2901126/en-us

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, February 13, 2014 6:47 AM
  • Thanks for posting a fix for this.  That's really helpful.
    Thursday, February 13, 2014 2:27 PM
  • Hi folks,

    Just a quick update on this thread. The Visual Studio and CLR teams are currently investigating this problem. I'll post back on this thread as soon as we have additional info.

    Sincerely,


    Ed Dore

    Monday, February 17, 2014 8:01 PM
  • Hello all,

    I got this info from MS: add the configuration setting

    <configuration>
        <runtime>
            <AllowDComReflection enabled="true"/>

    to the config files vsmsvr10.exe.config, vsaenv10.exe.config, devenv.exe.config. This should fix the problem without deinstalling the hotfix.

    Jens

    • Proposed as answer by Yoni Horovitz Thursday, February 20, 2014 10:14 AM
    Tuesday, February 18, 2014 2:34 PM
  • What about VS2008? We still need to develop for real things out there like rugged controllers with Windows Mobile...
    Tuesday, February 18, 2014 4:00 PM
  • What about VS2008? We still need to develop for real things out there like rugged controllers with Windows Mobile...

    AllowDComReflection works for Visual Studio 2008 too, but the files to modify are different: vsmsvr.exe.config, vsaenv.exe.config, devenv.exe.config. See the following page for more details:

    Visual Studio 2010 Macros Stop Working after February 2014 Windows Update



    Sergey Vlasov | Vlasov Studio | Visual Studio add-ins, extensions and tools

    Wednesday, February 19, 2014 4:17 AM
  • Hello all,

    I got this info from MS: add the configuration setting

    <configuration>
        <runtime>
            <AllowDComReflection enabled="true"/>

    to the config files vsmsvr10.exe.config, vsaenv10.exe.config, devenv.exe.config. This should fix the problem without deinstalling the hotfix.

    Jens

    Jens solution worked for me.

    You can see this post for more details on how to apply it.

    Thanks Jens!

    Thursday, February 20, 2014 10:15 AM
  • The Visual Studio and CLR Teams have completed they're security review and updated the following KB article with details on how to bypass the block on marshalling reflection types for the binaries responsible for running macros from the Visual Studio IDE.

    Marshaling
    of reflection types may not work over DCOM after you install a security update
    from security bulletin MS14-009

    Please refer to the detail in the "Workaround" section of the above KB article.

    Sincerely,


    Ed Dore

    Monday, February 24, 2014 7:16 PM
  • Please see http://www.microsoft.com/en-us/download/details.aspx?id=42541 for the official KB

    Carl Brochu, Visual Studio

    Monday, May 19, 2014 11:41 PM
  • For VS 2008, I have added this configuration to these files and it worked thanks.

    <configuration>
        <runtime>
            <AllowDComReflection enabled="true"/>

    "C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe.config"

    "C:\Program Files (x86)\Common Files\Microsoft Shared\VSA\9.0\VsaEnv\vsaenv.exe.config""C:\Program Files (x86)\Common Files\Microsoft Shared\VSA\9.0\VsaEnv\vsmsvr.exe.config"

    Wednesday, September 27, 2017 7:34 AM