"The Operation could not be completed. Access is denied." VS 2010 Pro start up


  • Hello, I have a legitimate copy of VS 2010 Pro through Dreamspark, and it's been working for a long time but a month ago or so it stopped working properly.

    The Problem: Whenever I try to run VS 2010 Pro, I get an error message after the splash screen saying "The operation could not be completed. Access is denied."

    Things to note:

    - I'm the admin on this install of Win 7 Home Premium (x64), running as administrator makes no difference (tested)

    - Reinstalling/Repairing VS 2010 Pro has no effect (tested, many many times)

    - Downloaded new copies of the Dreamspark software in case of a corrupt installler, that was not the case

    - Reinstalling/Repairing .NET framework has no effect (tested, also many many times haha)

    - I started a forum post on bleeping computer about this, they had me look through some error logs which I uploaded to the thread. If you'd like to see those they are here:

    - I've used a registry cleaner (CCleaner) to see if I could get rid of some bad registry, but it had no effect

    Any ideas? I'm going to slowly begin backing up things on my computer, if I can't fix it I'll just have to format my HD and start from scratch. Thanks ahead of time for any response!

    Sunday, February 19, 2012 4:21 PM


All replies

  • Hi Krugilla, have you tried creating a new administrative account on the same computer and trying to launch VS from there?
    Monday, February 20, 2012 1:15 AM
  • I just gave that a shot, it let me get to the screen where I pick which language I want to use. I chose C# and got the same error screen immediately after. Thanks for the suggestion though, I'll play around with it later to see if I can make any progress from another account.
    Monday, February 20, 2012 1:27 PM
  • Hi Krugzilla,

    Welcome to the MSDN forum.
    Maybe your Visual Studio are affecting by some third party software, I guess. So please also try these steps below:
      1.Open Visual Studio Command Prompt (2010) under Start menu -> All Programs -> Microsoft Visual Studio 2010 ->Visual Studio Tools (run it with Administrator privilege: right-click the program -> Run as administrator);
      2.Try some devenv switches in command prompt:
        a.Run devenv /Resetsettings to eliminate the cause of corrupted settings.
        b.Run devenv /ResetSkipPkgs in Command Prompt.
        c.Run devenv /Safemode to see if you can apply it correctly. This can eliminate the possibility that third party Add-ins or packages are causing problems.
      3.Reboot the machine in Safe Mode. This can isolate some third party application/driver's interference.
    If you still meet any error, please try running devenv.exe /log <log path> in Command Prompt. The log files will be generated in the <log path>. Then you can check and analyze the log file to see if there is anything incorrect. After that, you can also post your log file to a public site, like SkyDrive, and post the link here so that I can help you.

    Best regards,

    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, February 21, 2012 2:01 AM
  • Hey Barry,

    I tried running the commands you gave me, but my command prompt doesn't recognize "run" (weird..) or "devenv" as commands :\ ... So I went to the directory (C:\...\common7\IDE\) for devenv and ran it there. By the way, was present in the IDE directory, I'm not sure why it's not registered with command prompt though.

    The results:

    a. the windows visual studio splash screen popped up, then an access denied error just as usual.

    b. same as a

    c. same as a

    I don't have time to try the reboot/safe mode right now but I'll be sure to do that tomorrow.  Thanks for the reply.

    Wednesday, February 22, 2012 2:35 AM
  • Hi Krugzilla,

    If you only have Visual Studio 2010 installed and you don't mind, could you please try running devenv.exe /log <log path> in Command Prompt?(I also list it on my screen shots) The log files will be generated in the <log path>. Then you can check and analyze the log file to see if there is anything incorrect. After that, you can also post your log file to a public site, like SkyDrive, and post the link here so that I can help you. 

    Best regards,

    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, February 22, 2012 8:37 AM
  • Barry,

        "devenv.exe /log <log path>" got me the same results as before, splash screen pops up and then error access denied. I tried a few different paths, all got the same result. I went to Win7 safe mode and tried all these commands again, but nothing changed. I'm considering using the 23 steps listed here (in answer):

    Although those steps are for installing  VS2010 SP1, maybe all that cleaning and uninstalling will also resolve my issues. Anyways, I will need to install SP1 for MVC 3 which is my primary interest, so I might have to do these things anyways.

    Thanks again for your help.

    Wednesday, February 22, 2012 11:46 PM
  • Hi Krugzilla,

    To be honest, "devenv.exe /log <log path>" is a command with which you can collect some logs for me to analyze. I see that you may want to use the "Windows Installer CleanUp Utility"
    Please note:
      The utility was retired by Microsoft on June 25, 2010, due to conflicts with Office 2007. It was replaced by a   Microsoft Fix It, which can be found here:
    Anyway, to make a clean uninstallation, you can refer to this page
      With this command:
      Complete (VS2010_Uninstall-RTM.ENU.exe /full /netfx)
      Removes entire set of Visual Studio 2010 and supporting products, including Microsoft .NET Framework 4.0 and components shared with previous versions of Visual Studio. Note: may break features of previous versions of Visual Studio or other products taking dependency on Microsoft .NET Framework 4.0.
    If you have any updates, please feel free to let me konw.

    Best regards,

    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, February 23, 2012 2:12 AM
  • Sorry, seems nothing I do will work.. I followed both the guide I linked to and the clean uninstaller you linked to. Nothing seems to fix this issue, and I need it working soon so I'm just going to reset Win7 to factory defaults and start over. Hopefully no one else runs into this issue, I have no idea how to resolve it. Anyways, thanks for trying.
    Tuesday, February 28, 2012 3:05 AM
  • Hi Krugzilla,

    To reset Win7 to factory defaults and start over maybe is the easiest way to solve your problem. But it seems that you are puzzled about how to collect some logs to analyse your issue. When trying this command "devenv.exe /log <log path>" you will get a Activity.xml log and you will find  the root reason why your application crashed from that log. I haven't received your logs until now so it is a bit difficult for me to help you. Anyway, after reinstalling OS, you issue will be solved.

    Best regards,

    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, February 28, 2012 3:17 AM
  • Hi! I have the same error. VS2010 downloaded from dreamspark just stopped working. Worked one day, didnt work the next. I tried reinstalling and now i get the same error.
    While installing VS2010, during the installation of office developer tools a "operation failed. access denied" window pops up. Then the installer just continues like normal and it sais installation was successful at the end.

    I started in devenv /log and uploaded it to my skydrive.!122&parid=root

    If i try to open this log i get the same error, access denied. I am an admin on this computer.

    The error i got that made me reinstall was that it just stopped loading projects correctly. Nor could i start new projects in XNA correctly. So i chose the reapply option and then VS couldn't load packages when i started it. I then uninstalled(with the uninstaller i downloaded from Microsoft) and now I'm here.

    I'm very thankful for any help!
    • Edited by Ollejf Saturday, April 21, 2012 8:59 AM
    Friday, April 13, 2012 9:12 AM
  • I'm seeing these same issues with VS2013.  This is a fresh install with updates 1&2.  No VS has been on this machine before.

    Prior to coming here I tried flushing the ComponentModelCache as was suggested elsewhere.

    I then tried devenv/setup from a developer command prompt for VS2013 but get 'Access is Denied'

    I'm a local admin of this machine.

    Friday, October 31, 2014 4:00 AM
  • I am getting the same issue, it appears that installing VS 2013 as an administrator, then normal users are having this issue. when I did the install I did not see an option to install for all users on this machine.
    Wednesday, November 26, 2014 2:50 PM